Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442122 - www-plugins/mozplugger-2.1.6 version bump (reintroduce to tree)
Summary: www-plugins/mozplugger-2.1.6 version bump (reintroduce to tree)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick McLean
URL:
Whiteboard:
Keywords:
: 404575 410293 442664 484522 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-06 23:53 UTC by Michael Lawrence
Modified: 2015-03-10 16:34 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mozplugger-1.14.6.ebuild (mozplugger-1.14.6.ebuild,1.10 KB, text/plain)
2012-12-01 07:22 UTC, Patrick McMunn
Details
files/mozplugger-1.14.6-Makefile.in.patch (mozplugger-1.14.6-Makefile.in.patch,1.31 KB, patch)
2012-12-01 07:24 UTC, Patrick McMunn
Details | Diff
ebuild, patch, and manifest for mozplugger-2.1.3 (mozplugger.tar.gz,2.12 KB, application/octet-stream)
2013-08-27 00:07 UTC, Mark Tomich
Details
mozplugger ebuild 2.1.3 with QA ok (mozplugger-2.1.3.ebuild,1.45 KB, text/plain)
2013-09-20 18:11 UTC, Arnaud Launay
Details
mozplugger-2.1.3.ebuild (mozplugger-2.1.3.ebuild,971 bytes, text/plain)
2013-10-13 18:11 UTC, David Leverton
Details
mozplugger-2.1.3-build-system.patch (mozplugger-2.1.3-build-system.patch,3.21 KB, patch)
2013-10-13 18:12 UTC, David Leverton
Details | Diff
mozplugger-2.1.3-rd_chld_fd.patch (mozplugger-2.1.3-rd_chld_fd.patch,1.37 KB, patch)
2013-10-13 18:13 UTC, David Leverton
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Lawrence 2012-11-06 23:53:37 UTC
ebuild request.... 
all gripe about security ... 
Mozilla or chrome Midori etc 

builds so far from the fresh downloaded page...
Comment 1 Patrick McMunn 2012-12-01 07:22:59 UTC
Created attachment 331114 [details]
mozplugger-1.14.6.ebuild

Not much changed from 1.14.3 except the ebuild is a little more configurable.
Comment 2 Patrick McMunn 2012-12-01 07:24:29 UTC
Created attachment 331116 [details, diff]
files/mozplugger-1.14.6-Makefile.in.patch
Comment 3 David 2013-02-21 08:37:18 UTC
Looks like version 2.1.2 has been released.

http://www.mozdev.org/source/browse/mozplugger/downloads/
Comment 4 Ian Stakenvicius gentoo-dev 2013-08-26 14:55:20 UTC
Since the package in the tree is severely outdated, and nobody in the mozilla herd has any interest at all in attempting to bring it up to date nor continue to bump it with every new mozilla release, this package has been masked for removal from the tree in 30 days.
Comment 5 Ian Stakenvicius gentoo-dev 2013-08-26 14:55:44 UTC
*** Bug 410293 has been marked as a duplicate of this bug. ***
Comment 6 Ian Stakenvicius gentoo-dev 2013-08-26 14:56:05 UTC
*** Bug 404575 has been marked as a duplicate of this bug. ***
Comment 7 Ian Stakenvicius gentoo-dev 2013-08-26 14:56:21 UTC
*** Bug 442664 has been marked as a duplicate of this bug. ***
Comment 8 Michael Lawrence 2013-08-26 18:44:57 UTC
 2.1.2 ebuild then I suppose 
just hopefully the item gets bumped at least from time to time.
Comment 9 Mark Tomich 2013-08-27 00:07:04 UTC
Created attachment 357132 [details]
ebuild, patch, and manifest for mozplugger-2.1.3

For whoever still needs / wants this package, here is an updated ebuild (with patch and manifest) for mozplugger-2.1.3.
Comment 10 Arnaud Launay 2013-08-27 08:01:41 UTC
Yeah, mozplugger *IS* needed, at least to include evince in the browser. So please, instead of "killing" it, update the ebuilds. This is something that:

1/ works
2/ do the job
3/ has no other alternative.
Comment 11 Ian Stakenvicius gentoo-dev 2013-08-27 14:39:00 UTC
Do any of you want to proxy-maintain it?  If so, I'll add your email addresses to metadata and will drop the removal.  Mozilla herd doesn't have the manpower to take care of it but if the userbase is willing to step up then I won't remove it from the tree.
Comment 12 Arnaud Launay 2013-08-27 15:36:24 UTC
I have no idea what it represents as a work flow... Mark or maybe Patrick might be better candidate for this (I can test, though. 2.1.3 does work, but mozplugger doesn't do what it did, ie, open evince /in/ the browser, now I have a separate window. So, some work is needed for upgrade instructions. I also had to run mozplugger-update )
Comment 13 Ian Stakenvicius gentoo-dev 2013-08-27 16:08:12 UTC
Proxy maintenance means that you would check for and test updated versions of the softare by version-bumping the ebuilds, check for and provide fixes for bugs when they're filed here (you'll get CC'd on them by bug-wranglers), ensure the ebuild and package meets all QA checks, and that the package continues to work as expected.

Note, for instance, that the proposed ebuild here has a -big- QA violation related to the executable stack.  Also src_configure is malformed (econf fails silently if ./configure doesn't exist??  i highly doubt emake will succeed if econf wasn't run).  Couple that with the fact that apparently it still doesn't do what you want it to (launch evince within the browser) and I'm wondering if the package really isn't good enough to remain in the tree even after being bumped.
Comment 14 Mark Tomich 2013-08-27 18:13:50 UTC
I'm willing to maintain it as I use this package as a part of my job (so I'll get paid to maintain it :).  However, I could use a primer on ebuilds as most of what I've done in the past is very simple stuff.
Comment 15 Ian Stakenvicius gentoo-dev 2013-08-27 19:19:06 UTC
http://devmanual.gentoo.org , 'man 5 ebuild', and eclass-manpages pretty well cover everything you'd need to know.  Also be sure to learn how to use 'repoman' to check for various errors and QA issues.


Also, if you could post what you needed to do after installation to get this package (2.1.3) actually working with browsers (firefox-17.0.8 , chromium-latest-stable) that would be great; for me, the plugin is entirely ignored in firefox (it's loaded, i can see a proper registration in about:plugins, but no mime types are successfully processed), and it is reported as 'cannot load' in chromium.  --enable-debug didn't provide any useful info in the log, and after trying everything I could think of for 30 mins or so I just gave up.
Comment 16 Ian Stakenvicius gentoo-dev 2013-09-11 18:20:10 UTC
*** Bug 484522 has been marked as a duplicate of this bug. ***
Comment 17 Arnaud Launay 2013-09-20 18:11:24 UTC
Created attachment 359144 [details]
mozplugger ebuild 2.1.3 with QA ok

This one corrects the QA and repoman is (almost) happy (some warning about m4, don't know what to do with it).

Still doesn't work here, though...
Comment 18 David Leverton 2013-10-13 18:11:43 UTC
Created attachment 360808 [details]
mozplugger-2.1.3.ebuild

Updated/tidied ebuild; this one seems to work well enough for me.

(In reply to Ian Stakenvicius from comment #15)
> Also, if you could post what you needed to do after installation to get this
> package (2.1.3) actually working with browsers (firefox-17.0.8 ,
> chromium-latest-stable) that would be great

I didn't have to do anything special with SeaMonkey or Opera, but I can't speak for other browsers.
Comment 19 David Leverton 2013-10-13 18:12:35 UTC
Created attachment 360810 [details, diff]
mozplugger-2.1.3-build-system.patch

Patch to bring the build system a bit more in line with Gentoo standards, derived from the previous Makefile.in patch and extended
Comment 20 David Leverton 2013-10-13 18:13:43 UTC
Created attachment 360812 [details, diff]
mozplugger-2.1.3-rd_chld_fd.patch

Patch to hopefully fix this issue:

(In reply to Arnaud Launay from comment #12)
> mozplugger doesn't do what it did, ie, open evince /in/ the browser, now I
> have a separate window.
Comment 21 Weedy 2014-07-09 09:23:35 UTC
Pretty please with sugar on top revert the removal?
Comment 22 Michael Weber (RETIRED) gentoo-dev 2015-03-04 13:02:56 UTC
Can I just re-add it with myself as maintainer?
The current release (April 2014) works with firefox 36.

For now, it's in my dev overlay (layman -a xmw)
Comment 23 Ian Stakenvicius gentoo-dev 2015-03-04 14:54:57 UTC
(In reply to Michael Weber from comment #22)
> Can I just re-add it with myself as maintainer?
> The current release (April 2014) works with firefox 36.
> 
> For now, it's in my dev overlay (layman -a xmw)

I don't think mozilla@ has any problem with it being in the tree, we just can't maintain it ourselves.
Comment 24 Patrick McLean gentoo-dev 2015-03-04 19:38:01 UTC
As far as I am concerned, go ahead and re-add it to the tree with yourself as maintainer. I just have no interest in maintaining it anymore.
Comment 25 haarp 2015-03-09 07:11:20 UTC
I, too, would enjoy this coming back into the tree. I've been using the 2.1.3 ebuild from here in a local overlay with no troubles.
Comment 26 Michael Weber (RETIRED) gentoo-dev 2015-03-10 15:19:17 UTC
+*mozplugger-2.1.6 (10 Mar 2015)
+
+  10 Mar 2015; Michael Weber <xmw@gentoo.org> +metadata.xml,
+  +mozplugger-2.1.6.ebuild:
+  Re-add new version.
Comment 27 haarp 2015-03-10 16:34:38 UTC
Confirmed working. Thanks!