Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 438500 - install-amd64-minimal-20121013 broken nano: error while loading shared libraries: libmagic.so.1: cannot open shared object file: No such file or directory
Summary: install-amd64-minimal-20121013 broken nano: error while loading shared librar...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: InstallCD (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 440282 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-15 19:19 UTC by Ben Kohler
Modified: 2012-12-16 06:11 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Kohler gentoo-dev 2012-10-15 19:19:12 UTC
The current amd64 minimal install iso has a broken /usr/bin/nano.  This is because it is using the broken app-editors/nano-2.3.1-r1 which is missing the hardcoded dep on sys-apps/file.  This is documented in bug #407599.  

I would guess that nano initially gets built against & linked to sys-apps/file's libmagic, but file is later depcleaned since there is no dep on it.

Bumping the install cd's nano version to 2.3.1-r2 should fix things.  It will either pull in sys-apps/file as a dep or disable the linking to libmagic, depending on whether USE=magic is set.  Either way it would leave us with a working nano.
Comment 1 deface 2012-10-29 16:58:47 UTC
I second this bug. I am currently unable to run nano on a clean install of the AMD64 minimal.
Comment 2 Ben Kohler gentoo-dev 2012-11-08 21:19:02 UTC
Problem persists with install-amd64-minimal-20121107.iso
Comment 3 John R. Graham gentoo-dev 2012-11-10 20:01:24 UTC
*** Bug 440282 has been marked as a duplicate of this bug. ***
Comment 4 Ben Kohler gentoo-dev 2012-11-14 04:20:08 UTC
Bumping nano's version to 2.3.1-r2 is not (alone) going to fix this.  This nano version has IUSE=".. +magic .." so magic support will be on by default, BUT the installcd-stage2-minimal.spec file has sys-apps/file in its "livecd/unmerge" list so it gets purged unconditionally.

So (as I understand it) we need to either add -magic to the stage1 spec's USE, or remove sys-apps/file from stage2's unmerge list.  This is my first day with catalyst livecd builds, be gentle if I'm off-base here =)
Comment 5 John Moe 2012-11-14 22:01:40 UTC
I was searching Google for more info about this before coming here, and found that this seems to not be limited to nano not working. The links /var/lock (to /run/lock), /var/mail (to /var/spool/mail) and /var/run (to /run) all seem to be broken, as the target dirs don't exist. The lack of /var/run means dhcpcd can't run.
Comment 6 Simon Hill 2012-12-07 06:19:50 UTC
(In reply to comment #5)
> I was searching Google for more info about this before coming here, and
> found that this seems to not be limited to nano not working. The links
> /var/lock (to /run/lock), /var/mail (to /var/spool/mail) and /var/run (to
> /run) all seem to be broken, as the target dirs don't exist. The lack of
> /var/run means dhcpcd can't run.

This problem is covered in two other bugs: bug #441978 for amd64-minimal-20121013.iso (needs to be confirmed, I had this one as well), and bug #443442 for amd64-minimal-20121107.iso (confirmed).
Comment 7 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-12-16 06:11:08 UTC
We have a new CD[1] working and this version is being dropped from the mirrors.

 [1] - http://distfiles.gentoo.org/releases/amd64/autobuilds/20121210/