Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 407599 - app-editors/nano-2.3.1-r1: Missing sys-apps/file dependency
Summary: app-editors/nano-2.3.1-r1: Missing sys-apps/file dependency
Status: RESOLVED DUPLICATE of bug 364211
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: SpanKY
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-09 22:54 UTC by Richard Yao
Modified: 2012-03-12 14:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
app-editors/nano-2.3.1-r1 build failure (build.log,17.55 KB, text/plain)
2012-03-09 22:54 UTC, Richard Yao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Yao gentoo-dev 2012-03-09 22:54:42 UTC
Created attachment 304757 [details]
app-editors/nano-2.3.1-r1 build failure

This is related to bug #364211, which complains about a dependency on /usr/lib/libmagic.so because libmagic.so is in /usr.

Upstream appears to have introduced a dependency on sys-apps/file in nano 2.3.1, which is absent from the ebuild. I noticed this on Gentoo Prefix, because building app-editors/nano failed with "error: unknown type name ‘magic_t’". Adding the dependency does not fix it, but I consider the absence of the dependency to be a QA concern.
Comment 1 SpanKY gentoo-dev 2012-03-12 14:37:52 UTC

*** This bug has been marked as a duplicate of bug 364211 ***