Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 364211 - app-editors/nano[magic]: /bin/nano links to /usr/lib/libmagic.so
Summary: app-editors/nano[magic]: /bin/nano links to /usr/lib/libmagic.so
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 407599 (view as bug list)
Depends on:
Blocks: 398051
  Show dependency tree
 
Reported: 2011-04-20 08:10 UTC by Marcin Mirosław
Modified: 2021-03-06 05:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Mirosław 2011-04-20 08:10:03 UTC
Nano binary is placed in /bin , but link dependency are inside /lib and /usr/lib dirs.

$ ldd /bin/nano|grep usr
        libmagic.so.1 => /usr/lib64/libmagic.so.1

Btw, nano is useless in emergency case (e.g. /usr can't be mounted) now.

Reproducible: Always




# emerge --info
FEATURES variable contains unknown value(s): Xfail-clean, Xkeepwork
Portage 2.1.9.46 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-r2-x86_64-Intel-R-_Celeron-R-_CPU_E1500_@_2.20GHz-with-gentoo-2.0.2
Timestamp of tree: Wed, 20 Apr 2011 06:00:01 +0000
ccache version 3.1.4 [enabled]
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.11.1-r1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.5, 4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
sys-kernel/linux-headers: 2.6.38
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1 PUEL Q3AEULA skype-eula dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fpeel-loops -fomit-frame-pointer -frename-registers -fpredictive-commoning -fweb -ftree-vectorize -floop-interchange -ftree-loop-distribution -fivopts -floop-block -floop-strip-mine -fira-loop-pressure -floop-interchange -ftree-loop-linear -s -floop-parallelize-all -fipa-sra"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -fpeel-loops -fomit-frame-pointer -frename-registers -fpredictive-commoning -fweb -ftree-vectorize -floop-interchange -ftree-loop-distribution -fivopts -floop-block -floop-strip-mine -fira-loop-pressure -floop-interchange -ftree-loop-linear -s -floop-parallelize-all -fipa-sra"
DISTDIR="/usr/portage/distfiles"
FEATURES="Xfail-clean Xkeepwork assume-digests binpkg-logs ccache collision-protect distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LC_ALL="pl_PL.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl en es es_ES"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-O"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/sunrise /usr/local/portage/layman/zugaina /usr/local/portage/layman/sping /usr/local/portage/layman/mysql /usr/local/portage/miro-overlay/portage /usr/local/portage/miro-overlay/in_sunrise /usr/local/portage/miro-overlay/staging"
SYNC="rsync://192.168.138.254/gentoo-portage"
USE="64bit X a52 aac acl acpi alsa amd64 apm async bash-completion bfq bittorrent branding bzip2 cairo caps cdr chroot cli consolekit cracklib crypt cups cxx dbus dmx dri dts dvd dvdr emboss encode exif fam firefox flac fortran ftp gif glibc-omitfp gpm graphite gstreamer iconv idn iproute2 ipv6 ithreads jpeg kde laptop lcms libnotify lightning logrotate mad mikmod mmap mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses network-cron nls nptl nptlonly nsplugin nspluginwrapper objc ogg opengl openmp openssl optimization optimized-qmake pam pango pch pcre pdf phonon png policykit ppds pppd qt3support qt4 readline samba sdl semantic-desktop session sharedmem smp spell sse sse2 sse3 ssl ssse3 startup-notification svg sysfs threads threadsafe tiff tools truetype udev unicode urandom usb vim vim-pager vim-syntax vorbis x264 xattr xcb xinerama xml xorg xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cgid dav dbd deflate dir env expires ext_filter filter headers include info log_config logio mime mime_magic negotiation rewrite setenvif speling status unique_id usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="Xkeyboard Xmouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl en es es_ES" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 SpanKY gentoo-dev 2012-03-12 14:37:52 UTC
*** Bug 407599 has been marked as a duplicate of this bug. ***
Comment 2 Sergey Popov gentoo-dev 2013-06-19 10:02:38 UTC
This dependency is enabled by default in app-editors/nano-2.3.2 with USE="magic". But you can disable this USE flag and nano will not link against libmagic.so, so i think this bug can be closed as FIXED.
Comment 3 SpanKY gentoo-dev 2013-06-19 14:55:28 UTC
(In reply to Sergey Popov from comment #2)

not really.  people with the USE flag will still link across /usr.

in reality, i'm just going to sit on this until we merge /usr.
Comment 4 William Hubbs gentoo-dev 2019-09-02 14:48:23 UTC
People should be using initramfs for this now, so I think we can close
it.