Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 441978 - install-amd64-minimal-20121013.iso fails to boot due to faulty /var symlinks
Summary: install-amd64-minimal-20121013.iso fails to boot due to faulty /var symlinks
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: InstallCD (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-06 04:23 UTC by Scott M.
Modified: 2012-12-16 05:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott M. 2012-11-06 04:23:25 UTC
At the boot, after the keyboard configuration, the following error messages are shown: 

* WARNING: rc_sys not defined in rc.conf. Falling back to automatic detection 

* ... 

* Configuring kernel parameters ... 
mkdir: cannot create directory '/var/run': File exists 
* failed to create needed directory /var/run 
*ERROR: bootmisc failed to start 

After this, dhcpcd and syslog-ng fail to start. 

I believe the problem is the following broken symlinks in /var: run, mail, lock, and lib/misc. Therefore, the manual workaround is as follows:

# rm -rf /var/lock
# rm -rf /var/mail
# rm -rf /var/lib/misc
# rm -rf /var/run
# mkdir /var/lock
# mkdir /var/run
# mkdir /var/lib/misc
# mkdir /var/mail
# /etc/init.d/dhcpcd start
# /etc/init.d/syslog-ng start

This bug is in addition to the problems with nano, etc. not running with the latest minimal installation CD.

Reproducible: Always

Steps to Reproduce:
1. Boot from above mentioned CD image
2. Notice the errors after selecting the keymap
Actual Results:  
The services did not start properly, and error messages were displayed.

Expected Results:  
The system should have booted properly, as the previous release did.

Running on: VirtualBox, Apple MacBook Pro 8,1 OS X Host, Intel Core i5-2415M, 4 GB RAM.
Comment 1 Simon Hill 2012-12-07 06:08:20 UTC
I can confirm this. Same problem on VirtualBox, Apple MacBook Pro 8,2. A very similar problem also affects install-amd64-minimal-20121107.iso making it unusable as well.
Comment 2 Simon Hill 2012-12-07 06:13:52 UTC
One message seen earlier which may be related: 

No cdupdate.sh script found, skipping...

Attempting to manually start dhcpcd yields:

dhcpcd[]: open `/var/run/dhcpcd.pid': No such file or directory

On 20121107, dhcpcd runs but throws lots of errors related to /run not found, is unable to create /etc/resolv.conf
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-12-16 05:41:02 UTC
We have a new CD[1] working and this version is being dropped from the mirrors.

 [1] - http://distfiles.gentoo.org/releases/amd64/autobuilds/20121210/