Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 427544 - Gnome* maintained packages stabilization list for September
Summary: Gnome* maintained packages stabilization list for September
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ, Tracker
: 422987 433189 433231 433233 433285 433305 (view as bug list)
Depends on: glib-2.32 416725 421979 422437 425826 426678 427546 427548 427552 427554 427556 427558 427560 427942 CVE-2012-4048 428038 428040 428042 428044 428048 428050 428052 428054 428058 428060 428062 431830 434756 435072
Blocks: 422985 422989 CVE-2012-2738 CVE-2012-4037 430240 433189 CVE-2012-3524 436388
  Show dependency tree
 
Reported: 2012-07-21 19:44 UTC by Pacho Ramos
Modified: 2012-12-08 21:35 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Lista (LISTA.txt,11.00 KB, text/plain)
2012-07-21 20:16 UTC, Pacho Ramos
Details
Maintainers (LISTA.maintainers.xml,35.30 KB, text/plain)
2012-07-24 17:04 UTC, Pacho Ramos
Details
Lista (lista.txt,11.22 KB, text/plain)
2012-09-27 03:34 UTC, Alexandre Rostovtsev (RETIRED)
Details
Lista (lista.txt,11.22 KB, text/plain)
2012-09-27 03:44 UTC, Alexandre Rostovtsev (RETIRED)
Details
Lista (attachment.cgi.txt,11.11 KB, text/plain)
2012-09-30 12:37 UTC, Pacho Ramos
Details
Lista (attachment.cgi.txt,11.11 KB, text/plain)
2012-09-30 12:56 UTC, Pacho Ramos
Details
Lista (attachment.cgi.txt,11.11 KB, text/plain)
2012-09-30 13:34 UTC, Pacho Ramos
Details
Lista (lista.txt,11.11 KB, text/plain)
2012-10-16 02:24 UTC, Alexandre Rostovtsev (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2012-07-21 19:44:54 UTC
This time again ;)

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2012-07-21 20:13:55 UTC
*** Bug 422987 has been marked as a duplicate of this bug. ***
Comment 2 Pacho Ramos gentoo-dev 2012-07-21 20:16:36 UTC
Created attachment 318850 [details]
Lista
Comment 3 Pacho Ramos gentoo-dev 2012-07-21 20:17:53 UTC
CC co-maintainers to confirm they are ok with the list
Comment 4 Matt Turner gentoo-dev 2012-07-21 20:18:55 UTC
> gnome-extra/gnome-dvb-daemon-0.2.9

Good for me.
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-07-21 20:28:45 UTC
(In reply to comment #2)
> Created attachment 318850 [details]
> Lista

Suggest adding =x11-themes/zukitwo-2012.07.02
Suggest adding =sys-apps/gnome-disk-utility-3.4.1
Is libcanberra-0.29 fine for gnome2? (I don't use gnome2 and can't test.)
Comment 6 Rémi Cardona gentoo-dev 2012-07-21 20:44:04 UTC
No objections from me.

In fact, could app-office/grisbi-0.8.9-r1 tag along on that list to be stabilized with the other packages?

Cheers
Comment 7 Pacho Ramos gentoo-dev 2012-07-22 08:29:00 UTC
(In reply to comment #5)
> (In reply to comment #2)
> > Created attachment 318850 [details]
> > Lista
> 
> Suggest adding =x11-themes/zukitwo-2012.07.02

I already thought on adding it but I couldn't as it needed x11-themes/zukitwo-shell... but we could make a revision without gnome-shell USE flag, what do you think?

> Suggest adding =sys-apps/gnome-disk-utility-3.4.1

I am unsure about how would it work due bug 417629, looks like gnome2 still relies in some way on old udisks for mounting CDs properly :-/

> Is libcanberra-0.29 fine for gnome2? (I don't use gnome2 and can't test.)

I don't know how to test if it still works ok, for now, sounds are still played for me, but my system runs pulseaudio :|
Comment 8 Pacho Ramos gentoo-dev 2012-07-22 08:35:22 UTC
(In reply to comment #6)
> No objections from me.
> 
> In fact, could app-office/grisbi-0.8.9-r1 tag along on that list to be
> stabilized with the other packages?
> 
> Cheers

It's already included
Comment 9 Rémi Cardona gentoo-dev 2012-07-22 09:30:06 UTC
(In reply to comment #8)
> It's already included

[headdesk] Sorry for missing it. Full ack from me then.

Thanks
Comment 10 Mike Gilbert gentoo-dev 2012-07-23 01:15:56 UTC
I'm not sure why sgml is CC-ed; it doesn't maintain any of those packages.
Comment 11 Justin Lecher (RETIRED) gentoo-dev 2012-07-23 08:59:54 UTC
app-backup/deja-dup-23.2

if fine.
Comment 12 Andreas K. Hüttel gentoo-dev 2012-07-23 21:41:46 UTC
Looks good to me, I think we can un-cc kde. Go for it! :)
Comment 13 Andreas K. Hüttel gentoo-dev 2012-07-23 21:43:12 UTC
Also looks good with my printing hat on.
Comment 14 Eray Aslan gentoo-dev 2012-07-24 05:13:56 UTC
No objections.  Removing net-mail from cc.
Comment 15 Alexis Ballier gentoo-dev 2012-07-24 12:37:22 UTC
(In reply to comment #3)
> CC co-maintainers to confirm they are ok with the list

can we have co-maintainers appear in the list too please ? it'd be quicker to get a clue on what one needs to ack/nack :)
Comment 16 Pacho Ramos gentoo-dev 2012-07-24 17:04:00 UTC
Created attachment 319100 [details]
Maintainers

Maybe this could help
Comment 17 Pacho Ramos gentoo-dev 2012-07-24 17:48:32 UTC
Comment on attachment 319100 [details]
Maintainers

This is not ok :S

But running the following can help:
epkginfo -Hm $(cat LISTA.txt|cut -d " " -f1)
Comment 18 Alexis Ballier gentoo-dev 2012-07-24 17:55:02 UTC
 * media-libs/libcanberra [gentoo]
gnome (gnome@gentoo.org)
sound (sound@gentoo.org)

 * media-libs/audiofile [gentoo]
gnome (gnome@gentoo.org)
sound (sound@gentoo.org)

should be ok wrt sound herd, removing
Comment 19 Gilles Dartiguelongue gentoo-dev 2012-08-31 09:00:36 UTC
*** Bug 433231 has been marked as a duplicate of this bug. ***
Comment 20 Gilles Dartiguelongue gentoo-dev 2012-08-31 09:02:01 UTC
*** Bug 433285 has been marked as a duplicate of this bug. ***
Comment 21 Gilles Dartiguelongue gentoo-dev 2012-08-31 09:02:37 UTC
*** Bug 433305 has been marked as a duplicate of this bug. ***
Comment 22 Gilles Dartiguelongue gentoo-dev 2012-08-31 09:08:20 UTC
*** Bug 433189 has been marked as a duplicate of this bug. ***
Comment 23 Gilles Dartiguelongue gentoo-dev 2012-08-31 09:09:09 UTC
*** Bug 433233 has been marked as a duplicate of this bug. ***
Comment 24 Samuli Suominen gentoo-dev 2012-09-25 09:48:49 UTC
Can we separate GTK+ 3.4 stabilization into it's own bug since this is in deadlock? This is blocking critical security bugs.
Comment 25 Pacho Ramos gentoo-dev 2012-09-25 19:23:42 UTC
(In reply to comment #24)
> Can we separate GTK+ 3.4 stabilization into it's own bug since this is in
> deadlock? This is blocking critical security bugs.

The real blocker here is gvfs-1.12.x since it defaults to use udisks2 and that needs udev-18x. Regarding udev stabilization, I am unsure about what is really blocking it, probably bug 421839 (that I don't know how to handle :S). Do you have time to ping WilliamH on IRC?  Me not until Saturday as I am in the lab during all the day :|
Comment 26 Samuli Suominen gentoo-dev 2012-09-26 10:52:42 UTC
(In reply to comment #25)
> (In reply to comment #24)
> > Can we separate GTK+ 3.4 stabilization into it's own bug since this is in
> > deadlock? This is blocking critical security bugs.
> 
> The real blocker here is gvfs-1.12.x since it defaults to use udisks2 and
> that needs udev-18x. Regarding udev stabilization, I am unsure about what is
> really blocking it, probably bug 421839 (that I don't know how to handle
> :S). Do you have time to ping WilliamH on IRC?  Me not until Saturday as I
> am in the lab during all the day :|

We can revision bump gvfs from 1.12.3 to 1.12.3-r1 and change the default for 1.12.3 back to gdu, solving the problem for now.
Comment 27 Samuli Suominen gentoo-dev 2012-09-26 10:57:57 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > (In reply to comment #24)
> > > Can we separate GTK+ 3.4 stabilization into it's own bug since this is in
> > > deadlock? This is blocking critical security bugs.
> > 
> > The real blocker here is gvfs-1.12.x since it defaults to use udisks2 and
> > that needs udev-18x. Regarding udev stabilization, I am unsure about what is
> > really blocking it, probably bug 421839 (that I don't know how to handle
> > :S). Do you have time to ping WilliamH on IRC?  Me not until Saturday as I
> > am in the lab during all the day :|
> 
> We can revision bump gvfs from 1.12.3 to 1.12.3-r1 and change the default
> for 1.12.3 back to gdu, solving the problem for now.

And it's done. Now 1.12.3 is using gdu by default, and >=1.12.3-r1 udisks2, so you can CC arch's here now
Comment 28 Jeroen Roovers (RETIRED) gentoo-dev 2012-09-26 15:19:55 UTC
Comment on attachment 318850 [details]
Lista

That should be:
=dev-libs/libxml2-2.8.0-r2

Can we get a suggestion for a replacement for:
=x11-libs/gdk-pixbuf-2.26.1
Comment 29 Jeroen Roovers (RETIRED) gentoo-dev 2012-09-26 15:22:31 UTC
Comment on attachment 318850 [details]
Lista

And =x11-libs/gtk+-2.24.11-r1
Comment 30 Jeroen Roovers (RETIRED) gentoo-dev 2012-09-26 15:58:04 UTC
And =net-im/gajim-0.15.1 will need to go stable because of net-libs/farstream.
Comment 31 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-27 03:34:11 UTC
Created attachment 325088 [details]
Lista

(In reply to comment #7)
(In reply to comment #28)
(In reply to comment #29)
(In reply to comment #30)

Updated list: now with libxml2-2.8.0-r2, gdk-pixbuf-2.26.4, gtk+-2.24.12, gajim-0.15.1, and zukitwo-2012.07.02
Comment 32 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-27 03:44:21 UTC
Created attachment 325090 [details]
Lista

... and webkit-gtk-1.8.3-r{2,3}00; 1.8.1 is gone from the tree, and upstream release notes for 1.8.3 indicate that it fixes security issues.
Comment 33 Pacho Ramos gentoo-dev 2012-09-29 17:06:05 UTC
+  29 Sep 2012; Pacho Ramos <pacho@gentoo.org> grilo-plugins-0.1.18.ebuild:
+  Drop tracker support for version to stabilize as tracker is still not ready
+  for stable.
+
Comment 34 Agostino Sarubbo gentoo-dev 2012-09-30 11:40:56 UTC
gentoo-x86/app-admin/system-config-printer-common/system-config-printer-common-1.3.9-r4.ebuild: file does not exist
gentoo-x86/media-libs/grilo/grilo-0.1.18.ebuild: file does not exist
gentoo-x86/net-im/telepathy-mission-control/telepathy-mission-control-5.12.1.ebuild: file does not exist
gentoo-x86/net-misc/rygel/rygel-0.14.0.ebuild: file does not exist

@gnome

Please update your list. Note, we have already system-config-printer-common stable.
Comment 35 Pacho Ramos gentoo-dev 2012-09-30 12:37:57 UTC
Created attachment 325378 [details]
Lista

Try with this please
Comment 36 Agostino Sarubbo gentoo-dev 2012-09-30 12:51:30 UTC
(In reply to comment #35)
> Try with this please

again:
gentoo-x86/net-im/telepathy-mission-control/telepathy-mission-control-5.12.1.ebuild: file does not exist
Comment 37 Pacho Ramos gentoo-dev 2012-09-30 12:56:40 UTC
Created attachment 325380 [details]
Lista

Bleh, I didn't uploaded the final version from my desktop :S
Comment 38 Samuli Suominen gentoo-dev 2012-09-30 13:26:18 UTC
(In reply to comment #37)
> Created attachment 325380 [details]
> Lista
> 
> Bleh, I didn't uploaded the final version from my desktop :S

Should be -r1 of dev-libs/glib wrt bug 436028, so either remove it from the list or upgrade it... or trust people will see this comment. :P
Comment 39 Pacho Ramos gentoo-dev 2012-09-30 13:34:45 UTC
Created attachment 325386 [details]
Lista

Done
Comment 40 Jeroen Roovers (RETIRED) gentoo-dev 2012-10-02 16:06:07 UTC
Stable for HPPA.
Comment 41 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-04 07:42:05 UTC
x86 stable
Comment 42 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-04 07:44:07 UTC
(In reply to comment #41)
> x86 stable

except for dev-libs/libpeas-1.4.0-r1 which requires '>=dev-libs/gjs-1.31.11', '>=dev-libs/seed-2.91.91'

Feel free to re-add x86@ after fixing the list (and ideally just say what's updated so we don't have to re-emerge everything etc).
Comment 43 Agostino Sarubbo gentoo-dev 2012-10-04 14:46:03 UTC
NOTE:

I will skip voluntarily app-backup/deja-dup because it needs some other ~arch packages and new spidermonkey, so please file a bug in the near future.
I added =net-libs/gupnp-av-0.10.3 already stabilized by x86.

Next time do not rush with CC'ing arches, because 
1) Does not mean faster action because we can't do anything
2) if the list is not correct we only lose time.
Comment 44 Agostino Sarubbo gentoo-dev 2012-10-04 15:08:29 UTC
amd64 stable
Comment 45 Markus Meier gentoo-dev 2012-10-06 10:07:42 UTC
arm stable
Comment 46 Anthony Basile gentoo-dev 2012-10-14 15:07:56 UTC
ppc64 almost done, but we have an issue: webkit-gtk-1.8.3-r{200,300} depends on app-accessibility/at-spi2-core.  The one all the other arch teams have stabilized is 2.2.3 but that is not keyworded ~ppc64.  The other two 2.4.2 and 2.6.0 are keyworded ~ppc64.

I've keyworded at-spi2-core-2.2.3 as well, but I should wait a bit before stabilizing.  Alternatively, I could stabilize 2.4.2 or 2.6.0.
Comment 47 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-10-14 17:00:05 UTC
(In reply to comment #46)
> I've keyworded at-spi2-core-2.2.3 as well, but I should wait a bit before
> stabilizing.  Alternatively, I could stabilize 2.4.2 or 2.6.0.

Feel free to stabilize at-spi2-core-2.4.2.

at-spi2-core-2.6 is for gnome-3.6 and masked, so don't stabilize it right now :)
Comment 48 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-10-16 02:24:07 UTC
Created attachment 326672 [details]
Lista

Updated: stabilize =cups-pk-helper-0.2.4 due to security issues (bug #438450)
Comment 49 Raúl Porcel (RETIRED) gentoo-dev 2012-10-28 17:20:29 UTC
alpha/ia64/m68k/s390/sh/sparc stable, i believe
Comment 50 Agostino Sarubbo gentoo-dev 2012-12-08 19:00:24 UTC
ppc64 stable
Comment 51 Agostino Sarubbo gentoo-dev 2012-12-08 21:35:42 UTC
ppc stable. Last arch, closing