Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410451 - www-servers/apache-2.4.1-r1 APACHE2_MPMS="itk" - configure: error: MPM itk is not supported on this platform.
Summary: www-servers/apache-2.4.1-r1 APACHE2_MPMS="itk" - configure: error: MPM itk is...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: apache-2.4-stable
  Show dependency tree
 
Reported: 2012-04-01 17:04 UTC by Michael Orlitzky
Modified: 2014-05-28 02:28 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.txt,4.55 KB, text/plain)
2012-04-01 17:04 UTC, Michael Orlitzky
Details
build log (build-log.txt,20.63 KB, text/plain)
2012-04-01 17:05 UTC, Michael Orlitzky
Details
config.log (config.log,80.21 KB, text/plain)
2012-04-01 21:38 UTC, Michael Orlitzky
Details
mpm_itk-2.4.4_p3.ebuild (mpm_itk-2.4.4_p3.ebuild,814 bytes, text/plain)
2013-02-27 17:12 UTC, Timo Gurr (RETIRED)
Details
00_mpm_itk.conf (00_mpm_itk.conf,105 bytes, text/plain)
2013-02-27 17:12 UTC, Timo Gurr (RETIRED)
Details
mpm_itk-2.4.4_p3_seccomp_64bit.patch (mpm_itk-2.4.4_p3_seccomp_64bit.patch,1.51 KB, text/plain)
2013-02-27 17:12 UTC, Timo Gurr (RETIRED)
Details
apache-2.4.4-r1368121-post-perdir-config-hook.diff (apache-2.4.4-r1368121-post-perdir-config-hook.diff,2.54 KB, text/plain)
2013-02-27 17:13 UTC, Timo Gurr (RETIRED)
Details
apache-2.4.4-r1388447-dirwalk-stat-hook.diff (apache-2.4.4-r1388447-dirwalk-stat-hook.diff,4.24 KB, text/plain)
2013-02-27 17:13 UTC, Timo Gurr (RETIRED)
Details
apache-2.4.4-r1389339-pre-htaccess-hook.diff (apache-2.4.4-r1389339-pre-htaccess-hook.diff,2.28 KB, text/plain)
2013-02-27 17:13 UTC, Timo Gurr (RETIRED)
Details
mpm_itk-2.4.4_p4.ebuild (mpm_itk-2.4.4_p4.ebuild,767 bytes, text/plain)
2013-03-07 12:39 UTC, Timo Gurr (RETIRED)
Details
mpm_itk_and_apache.tar.bz2 (mpm_itk_and_apache.tar.bz2,6.19 KB, application/octet-stream)
2013-03-07 12:43 UTC, Timo Gurr (RETIRED)
Details
mpm_itk-2.4.6_p1.ebuild (mpm_itk-2.4.6_p1.ebuild,705 bytes, text/plain)
2013-07-24 15:43 UTC, Timo Gurr (RETIRED)
Details
apache-2.4.6.ebuild.patch (apache-2.4.6.ebuild.patch,690 bytes, patch)
2013-07-24 15:44 UTC, Timo Gurr (RETIRED)
Details | Diff
apache-2.4.6-r1498880-open_htaccess_hook.patch (apache-2.4.6-r1498880-open_htaccess_hook.patch,5.06 KB, patch)
2013-07-24 15:44 UTC, Timo Gurr (RETIRED)
Details | Diff
mpm_itk-2.4.7_p1.ebuild (mpm_itk-2.4.7_p1.ebuild,705 bytes, text/plain)
2014-02-18 16:49 UTC, Timo Gurr (RETIRED)
Details
mpm_itk-2.4.7_p2.ebuild (mpm_itk-2.4.7_p2.ebuild,735 bytes, text/plain)
2014-03-19 12:20 UTC, Timo Gurr (RETIRED)
Details
Candidate ebuild (mpm_itk-2.4.7_p2.ebuild,1.08 KB, text/plain)
2014-05-26 02:01 UTC, Michael Orlitzky
Details
Default conf file (00_mpm_itk.conf,130 bytes, text/plain)
2014-05-26 02:02 UTC, Michael Orlitzky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Orlitzky gentoo-dev 2012-04-01 17:04:23 UTC
Created attachment 307383 [details]
emerge --info

It dies at the end of the configure:

  ...
  checking which MPM to use by default... itk
  configure: error: MPM itk is not supported on this platform.
  ...
Comment 1 Michael Orlitzky gentoo-dev 2012-04-01 17:05:56 UTC
Created attachment 307385 [details]
build log
Comment 2 Michael Orlitzky gentoo-dev 2012-04-01 17:12:52 UTC
There was also (early this morning) a new release of the mpm-itk patch for 2.4.1:

  http://mpm-itk.sesse.net/apache2.4-mpm-itk-2.4.1-pre01/

And the mailing list message:

  http://lists.err.no/pipermail/mpm-itk/2012-April/000533.html
Comment 3 Patrick Lauer gentoo-dev 2012-04-01 17:38:10 UTC
checking which MPM to use by default... peruser
configure: error: MPM peruser is not supported on this platform.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/www-servers/apache-2.4.1-r2/work/httpd-2.4.1/config.log
 * ERROR: www-servers/apache-2.4.1-r2 failed (configure phase):
 *   econf failed
Comment 4 Michael Orlitzky gentoo-dev 2012-04-01 21:11:45 UTC
Sorry, was in a hurry. Here's the config log and emerge -vp output.

$ sudo FEATURES="noclean" ACCEPT_KEYWORDS="~amd64" emerge -vp apache

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] www-servers/apache-2.4.1-r1 [2.2.21-r1] USE="doc* ssl -debug -ldap (-selinux) -static -suexec -threads" APACHE2_MODULES="alias* auth_basic* auth_digest* authn_anon* authn_default* authn_file* authz_dbm* authz_default* authz_host* authz_user* autoindex* cgid* deflate* dir* env* expires* filter* headers* include* log_config* logio* mime* rewrite setenvif* -actions -asis -authn_alias -authn_dbd -authn_dbm -authz_groupfile -authz_owner -cache -cern_meta -cgi -charset_lite -dav -dav_fs -dav_lock -dbd -disk_cache -dumpio -ext_filter -file_cache -ident -imagemap -info -log_forensic -mem_cache -mime_magic -negotiation -proxy* -proxy_ajp -proxy_balancer -proxy_connect* -proxy_ftp -proxy_http* -proxy_scgi -reqtimeout -speling -status -substitute -unique_id -userdir -usertrack -version -vhost_alias" APACHE2_MPMS="itk* -event -peruser -prefork -worker" 0 kB
Comment 5 Michael Orlitzky gentoo-dev 2012-04-01 21:38:17 UTC
Created attachment 307419 [details]
config.log
Comment 6 Toei Rei 2012-04-02 20:48:48 UTC
same 'problem' here. Found some patches around to port this MPM to 2.4 but haven't had time to test it
Comment 7 Michael Orlitzky gentoo-dev 2012-11-28 03:36:17 UTC
ITK users are probably better off waiting a while before upgrading to the 2.4.x (or even 2.5.x) series. The updated patchset should work here; however, the author recently announced that upstream changes will finally obviate the need to patch Apache at all:

  http://lists.err.no/pipermail/mpm-itk/2012-November/000591.html

Apache maintainence has slowed recently (no offense to those who stepped up to fix bugs!), and personally I'd feel more comfortable compiling a separate package that I or someone else can maintain against a vanilla Apache (which necessarily gets more attention).
Comment 8 shinydoofy 2013-01-27 23:31:43 UTC
I just ran into this issue as well. Is there any progress on this issue, possibly even a workaround using an overlay to get this running?
Comment 9 Timo Gurr (RETIRED) gentoo-dev 2013-02-27 17:11:37 UTC
Attaching a new ebuild www-apache/mpm_itk following upstreams direction in providing a separate module instead of patching apache directly now that apache 2.4 supports this kind of stuff. Currently apache 2.4.4 still needs 3 minor patches (shipped with mpm_itk tarball) which according to the mpm_itk readme are already applied in svn trunk. I'm also attaching the apache patches for completeness and since one of them needs a little modification.
Comment 10 Timo Gurr (RETIRED) gentoo-dev 2013-02-27 17:12:05 UTC
Created attachment 340382 [details]
mpm_itk-2.4.4_p3.ebuild
Comment 11 Timo Gurr (RETIRED) gentoo-dev 2013-02-27 17:12:35 UTC
Created attachment 340384 [details]
00_mpm_itk.conf
Comment 12 Timo Gurr (RETIRED) gentoo-dev 2013-02-27 17:12:48 UTC
Created attachment 340386 [details]
mpm_itk-2.4.4_p3_seccomp_64bit.patch
Comment 13 Timo Gurr (RETIRED) gentoo-dev 2013-02-27 17:13:08 UTC
Created attachment 340388 [details]
apache-2.4.4-r1368121-post-perdir-config-hook.diff
Comment 14 Timo Gurr (RETIRED) gentoo-dev 2013-02-27 17:13:21 UTC
Created attachment 340390 [details]
apache-2.4.4-r1388447-dirwalk-stat-hook.diff
Comment 15 Timo Gurr (RETIRED) gentoo-dev 2013-02-27 17:13:32 UTC
Created attachment 340392 [details]
apache-2.4.4-r1389339-pre-htaccess-hook.diff
Comment 16 Christophe PEREZ 2013-03-04 19:12:22 UTC
I have the same problem too, with apache 2.4.4 in stable portage.
I tried to use ebuild and patches given, it compiles but doesn't start.
what I did :

=> /etc/portage/patches/www-servers/apache-2.4.4-r1
apache-2.4.4-r1368121-post-perdir-config-hook.diff
apache-2.4.4-r1389339-pre-htaccess-hook.diff
apache-2.4.4-r1388447-dirwalk-stat-hook.diff

=> grep apache /etc/portage/package.keywords
=www-apache/mpm_itk-2.4.4_p3 ~amd64
=www-servers/apache-2.4.4-r1 ~amd64

ls -R /usr/local/portage/www-apache/mpm_itk/
/usr/local/portage/www-apache/mpm_itk/:
files
Manifest
mpm_itk-2.4.4_p3.ebuild

/usr/local/portage/www-apache/mpm_itk/files:
00_mpm_itk.conf
mpm_itk-2.4.4_p3_seccomp_64bit.patch
(ebuild digest is ok)

added epatch_user to /usr/portage/www-servers/apache/apache-2.4.4-r1.ebuild

added -D MPM_ITK to /etc/conf.d/apache2

Apache seems to be patched :
 * Applying user patches from /etc/portage/patches//www-servers/apache-2.4.4-r1 ...
 * Done with patching

But :
 # /etc/init.d/apache2 restart
 * apache2 has detected an error in your setup:
apache2: Syntax error on line 156 of /etc/apache2/httpd.conf: Syntax error on line 2 of /etc/apache2/modules.d/00_mpm_itk.conf: Cannot load modules/mpm_itk.so into server: /usr/lib64/apache2/modules/mpm_itk.so: undefined symbol: ap_hook_pre_htaccess
 * ERROR: apache2 failed to stop

(sorry for my bad english)
Comment 17 Christophe PEREZ 2013-03-04 20:13:21 UTC
In fact, patches seems not to be applied, I don't know why.
I tried to patch manually after ebuild $(equery which apache) configure
(I had to modify a little the patches), then merge. Rebuild modules like php (subversion conf gives a warning) and it seems to work now.
Comment 18 Michael Orlitzky gentoo-dev 2013-03-04 23:30:28 UTC
(In reply to comment #16)
> But :
>  # /etc/init.d/apache2 restart
>  * apache2 has detected an error in your setup:
> apache2: Syntax error on line 156 of /etc/apache2/httpd.conf: Syntax error
> on line 2 of /etc/apache2/modules.d/00_mpm_itk.conf: Cannot load
> modules/mpm_itk.so into server: /usr/lib64/apache2/modules/mpm_itk.so:
> undefined symbol: ap_hook_pre_htaccess
>  * ERROR: apache2 failed to stop
> 
> (sorry for my bad english)

Apache failed to *stop*. If you killed it manually (without letting it parse the config and try to load that module), it probably would have started up afterwards.

Unrelated: 2.4.4_p4 was just released and it looks like at least the seccomp fix was upstreamed.
Comment 19 Timo Gurr (RETIRED) gentoo-dev 2013-03-07 12:39:42 UTC
Created attachment 341226 [details]
mpm_itk-2.4.4_p4.ebuild
Comment 20 Timo Gurr (RETIRED) gentoo-dev 2013-03-07 12:43:51 UTC
Created attachment 341228 [details]
mpm_itk_and_apache.tar.bz2

To ease testing a tarball containing a modified apache ebuild (based on apache-2.4.4-r1) with the needed patches and the recent mpm_itk ebuild (mpm_itk-2.4.4_p4) attached above.
Comment 21 Milos Ivanovic 2013-03-21 02:56:57 UTC
I can confirm that this patch works and I have been using it since the 7th of March 2013. I have not encountered any issues so far.
Comment 22 Timo Gurr (RETIRED) gentoo-dev 2013-07-24 15:43:56 UTC
Created attachment 354112 [details]
mpm_itk-2.4.6_p1.ebuild
Comment 23 Timo Gurr (RETIRED) gentoo-dev 2013-07-24 15:44:21 UTC
Created attachment 354114 [details, diff]
apache-2.4.6.ebuild.patch
Comment 24 Timo Gurr (RETIRED) gentoo-dev 2013-07-24 15:44:42 UTC
Created attachment 354116 [details, diff]
apache-2.4.6-r1498880-open_htaccess_hook.patch
Comment 25 Timo Gurr (RETIRED) gentoo-dev 2013-08-01 12:27:15 UTC
Upstream has accepted/backported the open_htaccess_hook patch to branch 2.4.x:
https://github.com/apache/httpd/commit/7e875b3b4d25d6e734573ab1a650f30bada77b3a
Comment 26 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-11-11 21:28:47 UTC
What are we waiting for on this bug? :)
Comment 27 Michael Orlitzky gentoo-dev 2013-11-12 13:37:18 UTC
The last word from upstream was,

  http://lists.err.no/pipermail/mpm-itk/2013-July/000676.html

At this point, I think we should wait for a separate mpm-itk, hopefully in the next apache release.

That puts us closer to upstream, and reduces the complexity in the ebuild.
Comment 28 Timo Gurr (RETIRED) gentoo-dev 2013-11-26 10:28:40 UTC
Since apache 2.4.7 has been released now it carries the last missing piece (open_htaccess_hook) to build mpm_itk as an external module without patching apache. mpm_itk-2.4.6_p1 still builds against apache 2.4.7 and also seems to work just fine.
Comment 29 Michael Orlitzky gentoo-dev 2013-11-27 01:53:43 UTC
And we have an official mpm-itk release for apache-2.4.7:

http://lists.err.no/pipermail/mpm-itk/2013-November/000713.html

Due to the way the apache ebuild is written, it's difficult to modify/test in an overlay. I'd like to test this ASAP, but I'll probably wait for apache-2.4.7 to hit ~arch and then begin testing a standalone mpm-itk-2.4.7 based on Timo's ebuild.

Once standalone mpm-itk hits the tree, apache can be revbumped to clean up its build system.
Comment 30 Christophe PEREZ 2014-01-22 05:41:10 UTC
So, if APACHE2_MPMS="itk" doesn't work anymore, why mpm_itk isn't in portage tree ?
Comment 31 Michael Orlitzky gentoo-dev 2014-01-23 14:48:52 UTC
(In reply to Christophe PEREZ from comment #30)
> So, if APACHE2_MPMS="itk" doesn't work anymore, why mpm_itk isn't in portage
> tree ?

I said I'd test with apache-2.4.7 ASAP, but I've had another project over the winter break. Realistically it will be either spring break (March) or summer before I can give this a good testing. We have several hundred sites I'd have to upgrade first.

If someone else wants to package mpm-itk and just stick it in ~arch, that's fine with me though.
Comment 32 Stefan00 2014-02-18 16:37:01 UTC
Confirmed this bug on Apache 2.4.7 too

Now, there must be a way to get this working somehow. Some easy way. Since PERUSER seems dead, ITK seems the only option to run Apache with a reasonable performance gain in a multiuser vhost environment. Although the option to use ITK is documented even on gentoo setup tutorials, emerge fails. 

This bug should be confirmed and considered important.
Comment 33 Timo Gurr (RETIRED) gentoo-dev 2014-02-18 16:49:08 UTC
Created attachment 370724 [details]
mpm_itk-2.4.7_p1.ebuild
Comment 34 Stefan00 2014-02-18 17:20:56 UTC
thank you Timo for this ebuild which seems to match the 2.4.7 Apache.

Unfortunatly, I have no idea what to do with this file to make my Apache compile, I never used ebuilds. Any short hints? 

It's really nuts. I run a couple gentoo boxes since 1999 and Apache / PHP emerge has always been the most - lets say - "challanging" part. Thank you :)
Comment 35 Timo Gurr (RETIRED) gentoo-dev 2014-03-19 12:20:16 UTC
Created attachment 373014 [details]
mpm_itk-2.4.7_p2.ebuild
Comment 36 Lars Wendler (Polynomial-C) gentoo-dev 2014-05-22 14:03:24 UTC
I've removed itk mpm from >=apache-2.4.9-r3

So if anyone wants to add the standalone package to the tree, go ahead.
Comment 37 Michael Orlitzky gentoo-dev 2014-05-22 14:55:53 UTC
School's out, I am promising to do this within the week.
Comment 38 Michael Orlitzky gentoo-dev 2014-05-26 02:01:38 UTC
Created attachment 377636 [details]
Candidate ebuild

Here's what I've got. I'll probably commit this in a day or two unless someone makes noise.
Comment 39 Michael Orlitzky gentoo-dev 2014-05-26 02:02:35 UTC
Created attachment 377638 [details]
Default conf file
Comment 40 shinydoofy 2014-05-27 19:22:35 UTC
FWIW, your latest ebuild and config file work great for me. However, I stumbled across the fact that mpm-itk needs a non-threaded apache and says so while failing to configure. Could that be incorporated into the ebuild to keep people from running into this and instead having an appropriate USE flag restriction?
Comment 41 Michael Orlitzky gentoo-dev 2014-05-28 02:28:53 UTC
Good idea. The 2.4.x series supports building more than one MPM, so depending on apache[-threads] won't work eventually. But for now, it should (see bug #511658). If that ever changes I can add an elog about it or something.

*mpm_itk-2.4.7_p2 (28 May 2014)

  28 May 2014; Michael Orlitzky <mjo@gentoo.org> +files/00_mpm_itk.conf,
  +metadata.xml, +mpm_itk-2.4.7_p2.ebuild:
  New package: www-apache/mpm_itk, for itk support in apache-2.4. Fixes bug
  #410451.