Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 39397 - module-init-tools-3.0pre6
Summary: module-init-tools-3.0pre6
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
: 39458 39703 39805 (view as bug list)
Depends on:
Reported: 2004-01-25 16:50 UTC by Yi Quang (RETIRED)
Modified: 2004-05-01 12:45 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---

mod-init-tools-regression.patch (mod-init-tools-regression.patch,947 bytes, patch)
2004-01-28 10:35 UTC, Martin Schlemmer (RETIRED)
Details | Diff
mrannanj-linux-2.6.2-rc2-config (mrannanj-linux-2.6.2-rc2-config,20.64 KB, text/plain)
2004-01-29 10:39 UTC, Martti Rannanjärvi
My /etc/modprobe.* (modprobe-files.tgz,2.40 KB, application/x-compressed-tar)
2004-01-31 19:10 UTC, M Guzman
/etc/modprobe.* (modprobes.tar.gz,2.47 KB, application/gzip)
2004-02-01 06:50 UTC, Jonathan Heaney
UberLords modprobe (modprobe.tar.bz2,2.30 KB, application/x-bzip)
2004-02-01 11:46 UTC, Roy Marples (RETIRED)
Kernel config for 2.6.2 (kernel_config.gz,5.46 KB, application/gzip)
2004-02-07 04:31 UTC, Jonathan Heaney

Note You need to log in before you can comment on or make changes to this bug.
Description Yi Quang (RETIRED) gentoo-dev 2004-01-25 16:50:20 UTC
I'm getting these errors when booting with module-init-tools-3.0pre6:
FATAL: Module off not found.
FATAL: Module st not found.
FATAL: Module ide_probe_mod not found.
FATAL: Module ide_tape not found.
FATAL: Module off not found.
FATAL: Module st not found.
FATAL: Module ide_probe_mod not found.
FATAL: Module ide_tape not found. 

I've confirmed this with one other user.  Also, pre7 is out, I'm going to reboot right now and see if the problem is fixed.  

Reproducible: Always
Steps to Reproduce:
Comment 1 FieldySnuts 2004-01-25 16:51:47 UTC
I am that one user, I also get these problems.

Portage 2.0.49-r20 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r9, 2.6.1-mm5)
System uname: 2.6.1-mm5 i586 AMD-K6(tm) 3D processor
Gentoo Base System version
distcc 2.12.1 i486-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
CFLAGS="-fstack-protector -O3 -march=i586 -pipe -mmmx -m3dnow"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-fstack-protector -O3 -march=i586 -pipe -mmmx -m3dnow"
FEATURES="autoaddcvs buildpkg ccache distcc notitles sandbox"
USE="3dnow apache2 apm arts avi berkdb crypt encode foomaticdb gdbm gpm libg++ libwww mad mikmod mmx motif mysql ncurses oggvorbis pam perl python quicktime readline sdl slang snmp spell ssl tcpd truetype x86 xml2 zlib"
Comment 2 FieldySnuts 2004-01-25 17:01:08 UTC
I do not get this problem with pre5.
Comment 3 M Guzman 2004-01-25 17:47:09 UTC
I'll be the third that's having problems with this new version.  Not only am I having problems with the modules listed here, but my soundcard modules (ALSA/emu10k1) don't load either.  Here's my dmesg output:

snd_pcm: Unknown symbol snd_dma_get_reserved
snd_pcm: Unknown symbol snd_dma_free_reserved
snd_pcm: Unknown symbol snd_dma_free_pages
snd_pcm: Unknown symbol snd_malloc_pages
snd_pcm: Unknown symbol snd_dma_set_reserved
snd_pcm: Unknown symbol snd_dma_alloc_pages
snd_pcm: Unknown symbol snd_free_pages
snd_emu10k1: Unknown symbol snd_pcm_new
snd_emu10k1: Unknown symbol snd_pcm_hw_constraint_minmax
snd_emu10k1: Unknown symbol snd_ac97_mixer
snd_emu10k1: Unknown symbol snd_ac97_bus
snd_emu10k1: Unknown symbol snd_free_pci_pages
snd_emu10k1: Unknown symbol snd_malloc_pci_page
snd_emu10k1: Unknown symbol snd_pcm_lib_malloc_pages
snd_emu10k1: Unknown symbol __snd_util_mem_alloc
snd_emu10k1: Unknown symbol snd_util_memhdr_new
snd_emu10k1: Unknown symbol snd_pcm_lib_ioctl
snd_emu10k1: Unknown symbol snd_pcm_lib_free_pages
snd_emu10k1: Unknown symbol snd_hwdep_new
snd_emu10k1: Unknown symbol snd_pcm_set_ops
snd_emu10k1: Unknown symbol snd_pcm_hw_constraint_list
snd_emu10k1: Unknown symbol snd_pcm_lib_preallocate_sg_pages
snd_emu10k1: Unknown symbol snd_pcm_lib_preallocate_pci_pages
snd_emu10k1: Unknown symbol snd_pcm_sgbuf_ops_page
snd_emu10k1: Unknown symbol snd_malloc_pci_pages
snd_emu10k1: Unknown symbol snd_pcm_hw_constraint_integer
snd_emu10k1: Unknown symbol __snd_util_mem_free
snd_emu10k1: Unknown symbol snd_util_memhdr_free
snd_emu10k1: Unknown symbol snd_pcm_lib_preallocate_pci_pages_for_all
snd_emu10k1: Unknown symbol snd_pcm_lib_preallocate_free_for_all
snd_emu10k1: Unknown symbol snd_pcm_period_elapsed
snd_emu10k1: Unknown symbol __snd_util_memblk_new
snd_emu10k1: Unknown symbol snd_ac97_write
snd_emu10k1: Unknown symbol snd_pcm_format_width
request_module: failed /sbin/modprobe -- snd-card-0. error = 256
snd_pcm_oss: Unknown symbol snd_mixer_oss_ioctl_card
Comment 4 Jonathan Heaney 2004-01-26 05:02:18 UTC
Using module-init-tools-3.0_pre6

I can confirm the noisy output with both FATAL module load errors and unknown symbol errors when loading the ALSA stuff.  Although the FATAL module errors don't seem to be a problem, it does break ALSA (or at least the mixer settings restore/save part).

The latest update to development-sources-2.6.2_rc2 also depends on this module-init-tools version.

Back to pre5 and holding off emerge-u world until this gets fixed.
Comment 5 Jonathan Heaney 2004-01-26 17:04:49 UTC
module-init-tools-3.0pre7 doesn't fix the problem if anyone's interested.
Comment 6 SpanKY gentoo-dev 2004-01-26 17:43:36 UTC
*** Bug 39458 has been marked as a duplicate of this bug. ***
Comment 7 Phil Almquist 2004-01-26 20:01:16 UTC
as previously stated pre7 doesnt fix this issue but going back to pre5 does get rid of the errors.
Comment 8 Roy Marples (RETIRED) gentoo-dev 2004-01-27 02:35:05 UTC
This problem also happens with vanilla kernel 2.6.1 orinoco drivers.
Happens with pre6 and pre7 :(
pre5 and prior work fine

orinoco_lock() called with hw_unavailable (dev=d9671800)
orinoco_cs: Unknown symbol orinoco_reinit_firmware
orinoco_cs: Unknown symbol hermes_struct_init
orinoco_cs: Unknown symbol orinoco_interrupt
orinoco_cs: Unknown symbol __orinoco_up
orinoco_cs: Unknown symbol __orinoco_down
orinoco_cs: Unknown symbol alloc_orinocodev
Comment 9 Veszi Gabor 2004-01-27 06:20:27 UTC
Same with pre7 for me...
Comment 10 Ronny Spiegel 2004-01-27 08:52:11 UTC
yesterday I got the same problem (esp. alsa and orinoco stuff)

seems that modprobe ignores the entries in modules.dep because when I load the modules named there by hand it works.

Comment 11 FieldySnuts 2004-01-27 14:03:41 UTC
I'm no dev here, but wouldn't it make sense to mask pre6 and pre7?
Comment 12 Jonathan Heaney 2004-01-27 16:26:57 UTC
"I'm no dev here, but wouldn't it make sense to mask pre6 and pre7?"

Neither am I, but yes, you would have thought that.  And there the culprit is, still in portage, lingering like a stale fart.
Comment 13 SpanKY gentoo-dev 2004-01-27 18:21:56 UTC
------- Additional Comment #7 From SpanKY 2004-01-26 17:43 PST -------

if you dont like buggy stuff dont use unstable :P

or locally mask it
Comment 14 Yi Quang (RETIRED) gentoo-dev 2004-01-27 20:15:22 UTC
Uh, I thought we already went over the fact that ~arch is NOT a testing ground for buggy software, but rather for ebuilds.  This is *not* the right attitude towards these kind of problems.  For broken software like this, it should definitely be masked by the dev's, not the end users.  
Comment 15 SpanKY gentoo-dev 2004-01-27 20:23:55 UTC
it isnt broken over here, in fact, it works just fine

having a bug in a package doesnt mean it's suddenly broken and should be masked
Comment 16 Yi Quang (RETIRED) gentoo-dev 2004-01-27 21:08:20 UTC
Well, considering that there have been 3 or 4 confirmations, I'd say it's pretty safe bet that it's broken, especially since it can be replicated.  "Works for me" really doesn't help the many of us for whom it doesn't work.  
Comment 17 Natanael Copa 2004-01-28 00:12:36 UTC
I'am using module-init-tools-3.0pre7) I am having same problems here (FATAL: Module X not found messages) and problems with orinoco_cs. But I also experienced a Oops, module off not found and kernel crashed. I actually have problems with remergeing anything because of this. So, does anyone knows what the problem is? I think thats more interresting than if it should be masked or not.
Comment 18 Leandro Dorileo (RETIRED) gentoo-dev 2004-01-28 07:45:56 UTC
Who has got errors like this "Module XXX not found" (where XXX is the name of your module) please try modproble -q XXX. Tt happens when the dependencies of you module is broken and the -q (quiet operation) isnt used.
Comment 19 Jonathan Heaney 2004-01-28 08:41:14 UTC

I think the problem here is not that we can't deal with the odd bug or package breakage, but that a relatively system-critical core package like this, which has a history of precisely this kind of problem, would warrant a bit more testing before being put in portage.

At the end of the day it's a minor irritant that's easily dealt with until it gets properly fixed.
Comment 20 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-28 09:58:03 UTC
The point of unstable, is not to roll something, and then mask if not working,
but roll it, get a fix going, try it, try again, etc until its fixed.  This
however only works if the dev have enough time.

I do get a similar issue, although not as severe as yours.  I will get to it,
but prob only this weekend.

As Mike said, it _is_ unstable after all, and only 4 out of how many thousand
do not mean its a case of live and death.
Comment 21 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-28 10:35:09 UTC
Created attachment 24547 [details, diff]

Above is the change that causes the breakage, but for the live of me, I cannot
see why this is - the module is not inserted that it should try (dependency),
so it should not be true (the test that exists, and cause the issues).

This seems to affect basically all autoprobing of dependencies it seems.
Comment 22 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-28 10:45:58 UTC
I mailed Rusty to see what he says, else I will have a look a bit later when
I am more rested.
Comment 23 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-28 10:49:12 UTC
Mike, adding in case you see something I miss.
Comment 24 SpanKY gentoo-dev 2004-01-28 11:36:37 UTC
like i said, i dont have this bug ;)
and i'm on the base-system alias so no need to cc me
Comment 25 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-28 20:37:56 UTC
No, I meant on code level.  If you are using 2.6 kernel, try to build sound
via modules, and enable gameport support (also module) - this seems to garentee
results over here =)
Comment 26 SpanKY gentoo-dev 2004-01-28 22:59:51 UTC
*** Bug 39703 has been marked as a duplicate of this bug. ***
Comment 27 Rusty Russell 2004-01-29 03:24:26 UTC
Hi all,

I can't reproduce the problem here 8(

Can someone who is having the problem please send me:
1) Their .config file (from the kernel build)
2) Their /etc/modprobe.conf, and
3) The output of the failing modprobe -v command.

Comment 28 Jonathan Heaney 2004-01-29 03:34:43 UTC

Thanks for the input, I use ALSA as modules, so I'll compile the gameport one in as well.

As for just 4 users out of thousands, two other bugs have been marked as duplicates of this, and a quick look on the forums showed these 3 threads (one sticky)

Looks like many more are having this problem, and I noticed only 3 people even mentioned, and one of them was me, so that may indicate a lot of people that use ~x86 don't know this place exists or don't bother using it.
Comment 29 Jonathan Heaney 2004-01-29 04:26:50 UTC

Built kernel with gameport support, didn't fix the problem here.
Comment 30 Rafael Pinto 2004-01-29 06:20:51 UTC
I am having the same problems with ALSA drivers and today I'll probably test changing to module-init-tools-3.0_pre5 and see if it works.
Comment 31 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-29 08:26:23 UTC
Jonathan, I was explaining to Mike how he might have tried to recreate it.

Who that have this issue, do _not_ run a -mm kernel?  I do not, but I manually
patches my own kernel, which after checking, also include the last alsa-1.0.1
update ... Anybody want to try same .config with vanilla?
Comment 32 Vermyndax 2004-01-29 09:23:29 UTC
I've had this problem on module-init-tools_pre6 and pre7.  I run gentoo-dev-sources with two patches: vesafb for higher refresh rates and mppe patch.
Comment 33 Jonathan Heaney 2004-01-29 09:30:38 UTC

The latest mm patch I'm using has alsa 1.0.2 in it, fwiw.
Comment 34 Martti Rannanjärvi 2004-01-29 10:39:18 UTC
Created attachment 24597 [details]

I have had this bug with 2.6.2-rc2, 2.6.2-rc2-mm1 and 2.6.1.
I have the alsa stuff (via82xx, oss support and all else) compiled as modules.

So when i updated linux to 2.6.2-rc2 i thought it was some linux bug and tried
-mm1 after which i went back to 2.6.1 and found out it didn't work anymore

Modules like nvidia (the proprietary thing) and via-rhine loaded ok with any
module-init-tools I tried.

Now trying to compile them in kernel to get sound back.. but am afraid that the
init script breaks.. lets see.

Attached is my 2.6.2-rc2 config before changing alsa to in-kernel.

What's fwiw?
Comment 35 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-29 10:43:54 UTC
Yeah well, was just the alsa patch combination I was wondering about.
Comment 36 Jonathan Heaney 2004-01-29 11:02:09 UTC
fwiw = 'for what it's worth'
Comment 37 Martti Rannanjärvi 2004-01-29 11:15:05 UTC
yay sound works when compiling in kernel!

But now I cannot play any quake based games since they use some wierd way to access the sound device (mmap). I had "options snd-pcm-oss dsp_map=1" at modules.conf (actually /etc/modules.d/alsa) and then it worked before.

Can I set this option somehow? maybe kernel commandline?
Comment 38 Ronny Schoebel 2004-01-29 11:17:07 UTC
Hi devs, I can cofirm this bug too
Some more info that wasn't covered until now:

If I do a modprobe snd-emu10k1 (with no ALSA modules inserted) it works.
If I run the /etc/init.d/alsasound script it fails.
Somehow modprobe gets consfuesd by loading the OSS emulation modules first the script does.

Running 2.6.1-mm4
Comment 39 Martti Rannanjärvi 2004-01-29 12:08:18 UTC
Ah thanks. I added DRIVERS="snd-via82xx ${DRIVERS}" to /etc/init.d/alsasound before the part where it loads those. This bug troubles me no more :-)
Comment 40 Markus Liebl 2004-01-29 14:02:49 UTC
i am not sure, but i think the problem is here:


static void insmod(
        /* Don't do ANYTHING if already in kernel. */
        if (!ignore_proc
            && module_in_kernel(newname ?: mod->modname, NULL) == 1)
                goto exists_error;
       /* Do things we depend on first, but don't die if they fail. */
        if (!list_empty(list)) {
                insmod(list, NOFAIL(strdup("")), NULL, 0, warn,
                       dry_run, verbose, options, commands, 0, ignore_proc,
                       strip_vermagic, strip_modversion);

First you test, if the modul is already in kernel. If true, you exit. AFTER that you look, if there a more moduls in the list, which you have to load. 
So modprobe exit, if it finds a modul in the list, which is already loaded. All modules after that in the list are ignored.

But i am not sure :)

Comment 41 Yi Quang (RETIRED) gentoo-dev 2004-01-29 18:40:21 UTC
Rusty just replied...and I quote:
"Simple logic bug, disguised by a misleading comment.  If module A               
depends on B and C, and B is already inserted, we should continue so            
we install C: my "trivial change" stopped recursing."
He says it's fixed in pre8, so shall we give it a try? :)
Comment 42 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-29 20:34:36 UTC
Fixed in pre8.
Comment 43 Martin Holzer (RETIRED) gentoo-dev 2004-01-29 23:47:06 UTC
*** Bug 39805 has been marked as a duplicate of this bug. ***
Comment 44 Benoit Boissinot 2004-01-30 01:12:07 UTC
pre8 solved the alsa stuff for me.
But i still get:
FATAL: Module off not found.
FATAL: Module st not found.
FATAL: Module ide_probe_mod not found.
FATAL: Module ide_tape not found.
FATAL: Module off not found.
FATAL: Module st not found.
FATAL: Module ide_probe_mod not found.
FATAL: Module ide_tape not found. 

I don't know if it is related to module-init-tools or the init-script but i didn't get this output with pre5.

BTW i have not ide-tape compiled (as module or in the kernel)
Comment 45 Matteo Settenvini 2004-01-30 01:33:23 UTC
Yep, me too. Neither I have ide_tape compiled. Btw, what modules are "off" and "st"? I gave a quick look, but I hadn't been able to find them in kernel documentation.
Comment 46 Benoit Boissinot 2004-01-30 01:57:03 UTC
off is like a null module. It is used to prevent loading a module. You can used it like : "alias module off".

But i don't know if this is still true with the last kernels and/or module-init-tools.

(what is strange is that i haven't any line with "off" in my modules.conf)
Comment 47 Muli Ben-Yehuda 2004-01-30 02:31:32 UTC
'st' is SCSI tape, IIRC. No idea about 'off'. 
Comment 48 Jonathan Heaney 2004-01-30 03:04:48 UTC
Confirm pre8 fixes Alsa issue but still FATAL: errors as indicated above.  These are not actually a problem, it's just 'noisy' output.
Comment 49 Rafael Pinto 2004-01-30 04:01:38 UTC
Although its already fixed, something passed on my mind. What if the noisy output is, in fact, caused by a broken dependencies check in depmod? 

Assume, for example, that depmod is guessing that a alsa driver needs scsi tape for some reason. Maybe you guys could take a look at that!! 
Comment 50 FieldySnuts 2004-01-30 05:59:24 UTC
Curiously when installing pre8, mind you this is BEFORE rebooting:

*** /var/log/syslog ***
Jan 30 08:56:31 localhost modprobe: FATAL: Module off not found.
Jan 30 08:56:31 localhost modprobe: FATAL: Module ide_probe_mod not found.
Jan 30 08:56:31 localhost modprobe: FATAL: Module ide_tape not found.
Jan 30 08:56:31 localhost modprobe: FATAL: Module off not found.
Jan 30 08:56:31 localhost modprobe: FATAL: Module ide_probe_mod not found.
Jan 30 08:56:31 localhost modprobe: FATAL: Module ide_tape not found.

I got the same errors on boot.
Comment 51 Jonathan Heaney 2004-01-30 07:46:14 UTC
Should this have been marked as 'Resolved Fixed'?  Here's the original bug report -

"I'm getting these errors when booting with module-init-tools-3.0pre6:
FATAL: Module off not found.
FATAL: Module st not found.
FATAL: Module ide_probe_mod not found.
FATAL: Module ide_tape not found.
FATAL: Module off not found.
FATAL: Module st not found.
FATAL: Module ide_probe_mod not found.
FATAL: Module ide_tape not found. 

I've confirmed this with one other user.  Also, pre7 is out, I'm going to reboot right now and see if the problem is fixed.  

Reproducible: Always
Steps to Reproduce:

This part of it hasn't been fixed - only the Alsa breakage that was brought up later has been fixed with pre8.
Comment 52 fatty 2004-01-30 07:59:38 UTC
I didn't have problems with ALSA while pre6 or pre7 where installed, but this strange FATAL-output on module dependencie checking has been on both, my laptop and my desktop, PCs.

I could confirm the problems while loading the orinoco modules.

ATM I'm merging pre8, I will answer again, if the orinoco-problem still isn't solved.
Comment 53 Jeff Stuart 2004-01-31 07:54:04 UTC
I can also confirm that I have the "FATAL: Module xxx not found" problem.  And of course, any of the modules it WANTS to load are not there cause I have no modules compiled for my kernel.  The only modules I use are 3rd party (nvidia and vmware).  So of course, 
Comment 54 André Terpstra 2004-01-31 15:11:58 UTC
I had the same problem too (with pre8), so I also had to downgrade to pre5. Just for the uninitiated (like me) I would add the code to do this:
==>    emerge =module-init-tools-3.0_pre5

and don't forget the leading "="!
Comment 55 Martin Schlemmer (RETIRED) gentoo-dev 2004-01-31 17:09:07 UTC
Please post you /etc/modprobe.* files.
Comment 56 M Guzman 2004-01-31 19:10:38 UTC
Created attachment 24714 [details]
My /etc/modprobe.*

I'm having this bug as well, and as requested, here is my /etc/modprobe.*

Note that for this tar-gz file, I made a mistake and the archive will extract
to ./etc/modprobe.* .  So, don't extract this in / for whatever reason ;)
Comment 57 Jonathan Heaney 2004-02-01 06:50:22 UTC
Created attachment 24738 [details]

As requested

The sequence of FATL: errors I get after *Calculating modules dependencies...
FATAL: Module off not found

The only module I would be interested in would be sg, but that is already
compiled straight into the kernel (I have a scsi writer).
Comment 58 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-01 08:07:34 UTC
Where do you get these from:

alias block-major-88-* ide-probe-mod
alias block-major-89-* ide-probe-mod
alias block-major-90-* ide-probe-mod
alias block-major-91-* ide-probe-mod
Comment 59 Roy Marples (RETIRED) gentoo-dev 2004-02-01 11:46:47 UTC
Created attachment 24770 [details]
UberLords modprobe
Comment 60 M Guzman 2004-02-01 11:51:08 UTC
I don't know (I've never had a cause to edit/view this file before) - it seems to be grouped with a few modules I had enabled for connecting my digital camera to my computer (scsi stuff).  But I'm not really sure, as a few of the lines in there don't look familiar to me at all
Comment 61 Jonathan Heaney 2004-02-01 13:32:46 UTC

If your question was to me (I see I have those entries in /etc/modprobe.conf), I have no idea, I've never edited this file by hand, I've only ever edited the files in /etc/modules.d, which is what you're supposed to do, isn't it?

I had a quick look at the files in modules.d (aliases, i386 etc), and none of those files contain the entries that are in /etc/modprobe.conf

How is this file generated btw?  I know /etc/modules.conf is generated by running update-modules.
Comment 62 M Guzman 2004-02-01 22:59:57 UTC
Just as a note - pre9 (new today in portage) does not seem to fix the FATAL: Module xx not found bug for me.
Comment 63 André Terpstra 2004-02-02 03:01:46 UTC
Same here: pre9 does not fix the FATAL bug. I've downgraded to pre5 again.
Comment 64 Benoit Boissinot 2004-02-02 03:21:06 UTC
The problem with 'module off' disappeared with pre9. I still have the others errors (st, ide_prob_mod,...).

I know it is just noisy output, but i still think this is not the expected behaviour.
Comment 65 Jonathan Heaney 2004-02-02 09:32:33 UTC
The FATAL entry for module off has disappeared here too with pre9.  I still get entries for st, ide_probe_mod,ide_tape, and sg.
Comment 66 Jonathan Heaney 2004-02-02 12:06:57 UTC
Apparently there is a workaround, although I have not tried it myself yet
Comment 67 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-06 11:47:22 UTC
Do you guys have ide modular?
Comment 68 Benoit Boissinot 2004-02-06 11:58:00 UTC
I have ide modular (except ide-disk).

If necessary, i can post my kernel config.
Comment 69 Jarkko Haapalainen 2004-02-07 04:06:20 UTC
Just switched to UDEV, and no more those messages. Using now module-init-tools-3.0_pre9 and everything is fine.
Comment 70 Jonathan Heaney 2004-02-07 04:31:27 UTC
Created attachment 25129 [details]
Kernel config for 2.6.2

All the IDE stuff is compiled straight into the kernel.  I only have one IDE
device, a DVD drive, everything else is SCSI.  The only changes to the kernel
was the bk-alsa.patch from Andrew Morton's space.
Comment 71 Markus Liebl 2004-02-09 16:26:08 UTC
only one question?

in modprobe.c we have

          case 'q':
                   silent = 1;


          case 'q':
                   unknown_ok = 1;

Why is "add_to_env_var" missing?
Isn't it needed for the -C parameter above?
There are comments like /* Fall thru to -q */
If I add the line to pre9, i don't find errors in syslog.
Comment 72 Wilbur Pan 2004-02-11 07:43:56 UTC
I would like to confirm that moving to udev and getting rid of devfs solves this problem.  I posted the details in the "module-init-tools-3.0_pre6 & pre7 & pre8 are BUGGY" thread in the forums.

Here's the url:
Comment 73 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-11 14:21:28 UTC
Rusty, please have a look at comment #71.
Comment 74 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-15 12:31:17 UTC
I rusty mailed back, and aparently the debugging messages will be removed from
the kernel.  I already saw the patches posted to LKML.