Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 373521 - libpng-1.5 fix for x11-libs/fltk-1.10.1-r2
Summary: libpng-1.5 fix for x11-libs/fltk-1.10.1-r2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Desktop Misc. Team
URL: http://www.fltk.org/strfiles/2542/lib...
Whiteboard:
Keywords:
: 384257 385095 (view as bug list)
Depends on: 373453
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-06-30 00:15 UTC by Stuart Longland (RETIRED)
Modified: 2011-09-30 22:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fltk-1.1.10-libpng1.5.patch (fltk-1.1.10-libpng1.5.patch,1.95 KB, patch)
2011-06-30 00:15 UTC, Stuart Longland (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart Longland (RETIRED) gentoo-dev 2011-06-30 00:15:21 UTC
Created attachment 278653 [details, diff]
fltk-1.1.10-libpng1.5.patch

fltk-1.10.1-r2 presently does not compile when libpng-1.5 is installed.  The following compiler errors are instead shown:

Compiling Fl_PNG_Image.cxx...
Fl_PNG_Image.cxx: In constructor ‘Fl_PNG_Image::Fl_PNG_Image(const char*)’:
Fl_PNG_Image.cxx:90: error: invalid use of incomplete type ‘struct png_info_def’
/usr/include/png.h:678: error: forward declaration of ‘struct png_info_def’
Fl_PNG_Image.cxx:93: error: invalid use of incomplete type ‘struct png_info_def’
/usr/include/png.h:678: error: forward declaration of ‘struct png_info_def’
Fl_PNG_Image.cxx:98: error: invalid use of incomplete type ‘struct png_info_def’
/usr/include/png.h:678: error: forward declaration of ‘struct png_info_def’
Fl_PNG_Image.cxx:98: error: invalid use of incomplete type ‘struct png_info_def’
/usr/include/png.h:678: error: forward declaration of ‘struct png_info_def’
Fl_PNG_Image.cxx:101: error: invalid use of incomplete type ‘struct png_info_def’
/usr/include/png.h:678: error: forward declaration of ‘struct png_info_def’
Fl_PNG_Image.cxx:102: error: invalid use of incomplete type ‘struct png_info_def’
/usr/include/png.h:678: error: forward declaration of ‘struct png_info_def’
Fl_PNG_Image.cxx:105: error: invalid use of incomplete type ‘struct png_info_def’
/usr/include/png.h:678: error: forward declaration of ‘struct png_info_def’
Fl_PNG_Image.cxx:110: error: invalid use of incomplete type ‘struct png_info_def’
/usr/include/png.h:678: error: forward declaration of ‘struct png_info_def’

Attached is a patch that corrects fltk for libpng-1.5.  It, in addition to re-instating the patch in bug# 373453, permits fltk-1.1.10-r2 to build.  I'm in the process of building fldigi and will soon know if it works or not, but mucking around with fluid (FLTK UI builder) suggests it is able to display PNG images.
Comment 1 Stuart Longland (RETIRED) gentoo-dev 2011-06-30 01:17:16 UTC
Actually... should have checked upstream first.  See the URL attached.
Comment 2 Samuli Suominen gentoo-dev 2011-09-14 13:28:03 UTC
fltk-1.3.0 in the same SLOT builds fine, closing as OBSOLETE
Comment 3 Samuli Suominen gentoo-dev 2011-09-24 07:37:58 UTC
*** Bug 384257 has been marked as a duplicate of this bug. ***
Comment 4 Samuli Suominen gentoo-dev 2011-09-30 22:05:48 UTC
*** Bug 385095 has been marked as a duplicate of this bug. ***
Comment 5 Samuli Suominen gentoo-dev 2011-09-30 22:12:17 UTC
Oh well, seems people still need 1.1.10 as fltk-1.3.0 addition to tree was poorly handled.

+  30 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> fltk-1.1.10-r2.ebuild,
+  +files/fltk-1.1.10-libpng15.patch:
+  Fix building with libpng15 wrt #373521 by Stuart Longland