Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385095 - x11-libs/fltk-1.1.10-r2 fails to build with media-libs/libpng-1.5.5
Summary: x11-libs/fltk-1.1.10-r2 fails to build with media-libs/libpng-1.5.5
Status: RESOLVED DUPLICATE of bug 373521
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-30 15:45 UTC by Andrey Grozin
Modified: 2011-09-30 22:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Grozin gentoo-dev 2011-09-30 15:45:02 UTC
Several programs I use (both from the main tree and from my local overlay) don't compile with fltk-1.3, so, I've masked it, and am using 1.1.10-r2.

Compiling Fl_PNM_Image.cxx...
Fl_PNM_Image.cxx: In constructor ‘Fl_PNM_Image::Fl_PNM_Image(const char*)’:
Fl_PNM_Image.cxx:162:35: warning: ignoring return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared with attribute warn_unused_result
Fl_PNG_Image.cxx: In constructor ‘Fl_PNG_Image::Fl_PNG_Image(const char*)’:
Fl_PNG_Image.cxx:78:7: error: invalid use of incomplete type ‘struct png_struct’
/usr/include/png.h:830:16: error: forward declaration of ‘struct png_struct’
Fl_PNG_Image.cxx:90:11: error: invalid use of incomplete type ‘struct png_info’
/usr/include/png.h:699:16: error: forward declaration of ‘struct png_info’
Fl_PNG_Image.cxx:93:11: error: invalid use of incomplete type ‘struct png_info’
/usr/include/png.h:699:16: error: forward declaration of ‘struct png_info’
Fl_PNG_Image.cxx:98:12: error: invalid use of incomplete type ‘struct png_info’
/usr/include/png.h:699:16: error: forward declaration of ‘struct png_info’
Fl_PNG_Image.cxx:98:56: error: invalid use of incomplete type ‘struct png_info’
/usr/include/png.h:699:16: error: forward declaration of ‘struct png_info’
Fl_PNG_Image.cxx:101:15: error: invalid use of incomplete type ‘struct png_info’
/usr/include/png.h:699:16: error: forward declaration of ‘struct png_info’
Fl_PNG_Image.cxx:102:15: error: invalid use of incomplete type ‘struct png_info’
/usr/include/png.h:699:16: error: forward declaration of ‘struct png_info’
Fl_PNG_Image.cxx:105:11: error: invalid use of incomplete type ‘struct png_info’
/usr/include/png.h:699:16: error: forward declaration of ‘struct png_info’
Fl_PNG_Image.cxx:110:16: error: invalid use of incomplete type ‘struct png_info’
/usr/include/png.h:699:16: error: forward declaration of ‘struct png_info’
make[1]: *** [Fl_PNG_Image.o] Error 1


Reproducible: Always




elrond ~ # emerge --info
Portage 2.2.0_alpha59 (default/linux/x86/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 2.6.36-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.36-gentoo-r1-i686-Pentium-R-_Dual-Core_CPU_E5300_@_2.60GHz-with-gentoo-2.0.3
Timestamp of tree: Thu, 29 Sep 2011 03:15:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo science sunrise lisp grozin
Installed sets: 
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=native -pipe"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="ru_RU.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/lisp /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa bash-completion berkdb blas boehm-gc branding browserplugin bzip2 cairo cdda cdr consolekit cracklib crypt css cups curl cxx dbus declarative dirac doc dri dvd dvdnav dvdr emacs enca encode exif fam ffmpeg fftw firefox flac fltk fortran gd gdbm gdu gif gmp gpm gsl gtk iconv imagemagick jpeg kde kipi kpathsea lapack latex lcms ldap leim libnotify lzma mad mmx mng modules mozilla mp3 mp4 mpeg mudflap mule ncurses nls nptl nptlonly nsplugin offensive ogg opengl openmp pam pango pcre pdf perl phonon plasma plotutils png policykit ppds pppd python qt3support qt4 readline schroedinger sdl session speex spell sse sse2 ssl startup-notification svg sysfs tcl tcpd theora tiff tk truetype udev umfpack unicode usb v4l2 vcd vorbis win32codecs wxwidgets x264 x86 xcb xcomposite xine xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Samuli Suominen gentoo-dev 2011-09-30 22:05:48 UTC

*** This bug has been marked as a duplicate of bug 373521 ***