Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 369549 - dev-lua/luaposix-33.0.0 - Lua bindings for POSIX APIs
Summary: dev-lua/luaposix-33.0.0 - Lua bindings for POSIX APIs
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Justin Lecher
URL: https://github.com/rrthomas/luaposix
Whiteboard:
Keywords: EBUILD
Depends on: 532946 532948 512260 532936
Blocks: 358969
  Show dependency tree
 
Reported: 2011-05-31 17:15 UTC by David Valentim Dias
Modified: 2018-04-05 18:44 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
luaposix-5.1.11.ebuild (luaposix-5.1.11.ebuild,513 bytes, text/plain)
2011-05-31 17:16 UTC, David Valentim Dias
Details
luaposix-31.ebuild (luaposix-31.ebuild,872 bytes, text/plain)
2013-11-07 23:29 UTC, Dennis Schridde
Details
luaposix-31.ebuild (luaposix-31.ebuild,1.18 KB, text/plain)
2014-05-14 16:36 UTC, equeim
Details
dev-lua/luaposix-9999.ebuild (luaposix-9999.ebuild,1.37 KB, text/plain)
2014-06-03 06:45 UTC, Dennis Schridde
Details
dev-lua/luaposix-33.0.0.ebuild (luaposix-33.0.0.ebuild,1.39 KB, text/plain)
2014-12-18 15:07 UTC, Dennis Schridde
Details
metadata.xml (metadata.xml,338 bytes, text/xml)
2014-12-18 15:08 UTC, Dennis Schridde
Details
luaposix-33.0.0.ebuild (luaposix-33.0.0.ebuild,1.39 KB, text/plain)
2014-12-18 15:31 UTC, Dennis Schridde
Details
dev-lua/luaposix-33.2.1.ebuild (luaposix-33.2.1.ebuild,1.46 KB, text/plain)
2015-01-21 13:46 UTC, Dennis Schridde
Details
luaposix-33.3.1.ebuild (luaposix-33.3.1.ebuild,1.41 KB, text/plain)
2015-06-03 09:13 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Valentim Dias 2011-05-31 17:15:32 UTC
Lua Bindings for POSIX.
Implement some POSIX functions who are not standard in Lua (setenv and others).

Reproducible: Always
Comment 1 David Valentim Dias 2011-05-31 17:16:31 UTC
Created attachment 275385 [details]
luaposix-5.1.11.ebuild
Comment 2 Dennis Schridde 2013-11-07 21:59:33 UTC
Version 31 was released in the meantime.

Also note the NEWS for v29:
** luaposix is compatible with Lua 5.1, Lua 5.2 and luajit 2.0, so the
   5.1 prefix to the release version has become an anachronism and has
   been dropped from this release onwards.
Comment 3 Dennis Schridde 2013-11-07 21:59:55 UTC
P.S: The project homepage has also changed: https://github.com/luaposix/luaposix
Comment 4 Dennis Schridde 2013-11-07 23:29:25 UTC
Created attachment 362762 [details]
luaposix-31.ebuild

This is an ebuild that builds the latest version successfully.

But be warned: The buildsystem is weird and downloads additional repositories via git during bootstrap. It also ignores or automagically enables the --with-ncurses{,w} configure flags. I did not invest any time to fix these issues.
Comment 5 equeim 2014-05-14 16:36:37 UTC
Created attachment 376924 [details]
luaposix-31.ebuild

Based on live ebuild from lua-overlay.
Comment 6 Dennis Schridde 2014-06-03 06:45:56 UTC
Created attachment 378146 [details]
dev-lua/luaposix-9999.ebuild

Merged my previous ebuild with that from attachment #376924 [details] / comment #5
Comment 7 Dennis Schridde 2014-06-03 06:46:56 UTC
Please add Blocks+=358969
Comment 8 Dennis Schridde 2014-12-18 15:07:05 UTC
Created attachment 391932 [details]
dev-lua/luaposix-33.0.0.ebuild

Version 33.0.0 was released in the meantime (please update the Summary). Attached is an ebuild that successfully builds.

Features of the new ebuild:
* Works with version 33.0.0
* Builds using Slingshot
* Can run tests (but some fail)
* Dual live/stable ebuild

It requires several additional ebuilds to be added to the tree.
Comment 9 Dennis Schridde 2014-12-18 15:08:42 UTC
Created attachment 391934 [details]
metadata.xml
Comment 10 Dennis Schridde 2014-12-18 15:31:57 UTC
Created attachment 391958 [details]
luaposix-33.0.0.ebuild

Dependency fix.
Comment 11 Dennis Schridde 2015-01-21 13:46:50 UTC
Created attachment 394484 [details]
dev-lua/luaposix-33.2.1.ebuild

Version bump

Lua 5.3 is now supported.
Comment 12 Dennis Schridde 2015-06-03 08:49:37 UTC
(In reply to Dennis Schridde from comment #11)
> Created attachment 394484 [details]
> dev-lua/luaposix-33.2.1.ebuild

Version is now 33.3.1, renaming is sufficient.
Comment 13 Dennis Schridde 2015-06-03 09:13:43 UTC
Created attachment 404508 [details]
luaposix-33.3.1.ebuild

(In reply to Dennis Schridde from comment #12)
> (In reply to Dennis Schridde from comment #11)
> > Created attachment 394484 [details]
> > dev-lua/luaposix-33.2.1.ebuild
> 
> Version is now 33.3.1, renaming is sufficient.

… is NOT sufficient. Minor details in the directory layout changed. Attached ebuild addresses this.
Comment 14 Daniel M. Weeks 2016-04-19 14:55:06 UTC
There is a commit in slingshot that includes files from gnulib for dependent packages[1]. Unfortunately a release has not been tagged since that commit. I have an ebuild in the junkdrawer overlay that includes this patch and an ebuild for luaposix that will use those installed files rather than gnulib.

[1] b74b3a36825ccece31786c45a4e16b32fd58aa0