Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 532936 - dev-libs/gnulib-0.1 version bump
Summary: dev-libs/gnulib-0.1 version bump
Status: RESOLVED INVALID
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 369549
  Show dependency tree
 
Reported: 2014-12-18 14:22 UTC by Dennis Schridde
Modified: 2016-04-19 14:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2014-12-18 14:22:17 UTC
There is is a "recent" (compared to 2009) v0.1 tag in gnulib Git, from which a new version could be built.

Reproducible: Always
Comment 1 Dennis Schridde 2014-12-18 14:47:15 UTC
The following patch works surprisingly well:
--- /var/cache/portage/gentoo/dev-libs/gnulib/gnulib-9999-r1.ebuild     2014-11-12 12:31:06.000000000 +0100
+++ /var/cache/portage/local/dev-libs/gnulib/gnulib-0.1.ebuild  2014-12-18 15:24:44.990759716 +0100
@@ -4,15 +4,12 @@
 
 EAPI=5
 
-inherit eutils git-r3
+inherit eutils
 
 DESCRIPTION="Gnulib is a library of common routines intended to be shared at the source level"
 HOMEPAGE="http://www.gnu.org/software/gnulib"
+SRC_URI="http://git.savannah.gnu.org/cgit/gnulib.git/snapshot/${P}.tar.gz"
 
-EGIT_REPO_URI="
-       git://git.savannah.gnu.org/${PN}.git
-       http://git.savannah.gnu.org/r/${PN}.git
-"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
Comment 2 Jeroen Roovers gentoo-dev 2014-12-18 19:13:35 UTC
(In reply to Dennis Schridde from comment #1)
> The following patch works surprisingly well:

Probably because I committed a couple of fixes during the past months. :)
Comment 3 Fabian Groffen gentoo-dev 2014-12-27 20:11:26 UTC
Bumped, thanks!
Comment 4 Dennis Schridde 2015-06-03 07:10:53 UTC
(In reply to Fabian Groffen from comment #3)
> Bumped, thanks!

I see this commit:
  27 Dec 2014; Fabian Groffen <grobian@gentoo.org>
  +gnulib-2013.10.28.22.33.52.ebuild:
  Version bump, by Dennis Schridde in bug #532936

But I actually asked for an ebuild for the v0.1 tag. Is it possible to get that instead?
Comment 5 Michael Haubenwallner gentoo-dev 2016-04-19 08:47:21 UTC
The v0.1 tag of gnulib does not make any sense except for git-describe:
https://lists.gnu.org/archive/html/bug-gnulib/2013-10/msg00118.html

gnulib even is not intended to install as standalone library at all:
http://www.gnu.org/software/gnulib/

However, we've found it easier to provide gnulib as pre-built library on exotic platforms for packages not using gnulib, which would require lots of porting effort otherways.
Comment 6 Dennis Schridde 2016-04-19 13:03:40 UTC
(In reply to Michael Haubenwallner from comment #5)
> However, we've found it easier to provide gnulib as pre-built library on
> exotic platforms for packages not using gnulib, which would require lots of
> porting effort otherways.

Thanks for the explanation.

What's the path forward for e.g. bug #369549, where gnulib is necessary to build the package?
Comment 7 Daniel M. Weeks 2016-04-19 14:55:14 UTC
(In reply to Dennis Schridde from comment #6)
> (In reply to Michael Haubenwallner from comment #5)
> > However, we've found it easier to provide gnulib as pre-built library on
> > exotic platforms for packages not using gnulib, which would require lots of
> > porting effort otherways.
> 
> Thanks for the explanation.
> 
> What's the path forward for e.g. bug #369549, where gnulib is necessary to
> build the package?

In regards to bug #369549, gnulib is no longer necessary - see that bug for details.