Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 512260 - dev-lua/LDoc-1.4.3 - LuaDoc-compatible documentation generation system
Summary: dev-lua/LDoc-1.4.3 - LuaDoc-compatible documentation generation system
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Tomoya Tabuchi
URL: http://stevedonovan.github.io/ldoc
Whiteboard:
Keywords: EBUILD
: 603938 (view as bug list)
Depends on: 512262
Blocks: 532942 369549
  Show dependency tree
 
Reported: 2014-06-03 06:51 UTC by Dennis Schridde
Modified: 2017-01-21 21:52 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-lua/LDoc-1.4.2.ebuild (LDoc-1.4.2.ebuild,1.21 KB, text/plain)
2014-06-03 06:52 UTC, Dennis Schridde
Details
LDoc-1.4.3.ebuild (LDoc-1.4.3.ebuild,1.24 KB, text/plain)
2014-12-18 15:01 UTC, Dennis Schridde
Details
LDoc-1.4.3.ebuild (LDoc-1.4.3.ebuild,1.32 KB, text/plain)
2015-01-21 13:43 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2014-06-03 06:51:54 UTC
LuaDoc-compatible documentation generation system, required for dev-lua/luaposix.

Reproducible: Always
Comment 1 Dennis Schridde 2014-06-03 06:52:31 UTC
Created attachment 378150 [details]
dev-lua/LDoc-1.4.2.ebuild
Comment 2 Dennis Schridde 2014-12-18 15:00:02 UTC
Version 1.4.3 was released in the meantime.
Comment 3 Dennis Schridde 2014-12-18 15:01:49 UTC
Created attachment 391930 [details]
LDoc-1.4.3.ebuild

Updated ebuild with only minor changes in the metadata.
Comment 4 Jeroen Roovers gentoo-dev 2014-12-18 19:24:37 UTC
Comment on attachment 391930 [details]
LDoc-1.4.3.ebuild

Funny how you keep submitting ebuilds while not realising there is never such a thing as CAT/PKG-VERSION.ebuild.
Comment 5 Dennis Schridde 2015-01-21 13:43:05 UTC
Created attachment 394478 [details]
LDoc-1.4.3.ebuild

Some fixes in src_install

E.g. luajit does not define INSTALL_BIN, so it is now constructed from lua_prefix manually.
Comment 6 Jeroen Roovers gentoo-dev 2016-12-28 15:49:45 UTC
*** Bug 603938 has been marked as a duplicate of this bug. ***
Comment 7 Tomoya Tabuchi 2016-12-29 13:57:47 UTC
Hello, 
Since the PR referenced in bug 603938, which is a duplicate of this bug was merged, I believe this bug should be closed.
Comment 8 Amy Liffey gentoo-dev 2017-01-21 21:52:57 UTC
author	Tomoya Tabuchi <t@tomoyat1.com>	2016-12-28 11:25:46 (GMT)
committer	David Seifert <soap@gentoo.org>	2016-12-29 12:26:42 (GMT)

dev-lua/ldoc: New package
Package-Manager: portage-2.3.0
Closes: https://github.com/gentoo/gentoo/pull/3261