Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363039 - [gnome-overlay] gnome-base/gnome-keyring-3.0.0-r300 (and -3.0.0, -9999) fails to build due to bad sed in ebuild
Summary: [gnome-overlay] gnome-base/gnome-keyring-3.0.0-r300 (and -3.0.0, -9999) fails...
Status: RESOLVED DUPLICATE of bug 363075
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome3
  Show dependency tree
 
Reported: 2011-04-11 06:42 UTC by Alexandre Rostovtsev (RETIRED)
Modified: 2012-02-12 14:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-04-11 06:42:59 UTC
The gnome-keyring ebuilds in Gnome overlay were recently modified (see
http://git.overlays.gentoo.org/gitweb/?p=proj/gnome.git;a=commitdiff;h=7e110b9ed4633c50a86f9fa64b807116b140afb9)
to sed gcr/Makefile.am and gcr/Makefile.in in order to skip broken tests. Unfortunately, this sed results in an invalid makefile, and gnome-keyring fails to build:

# emerge gnome-keyring
[...]
make[4]: Entering directory `/var/tmp/portage/gnome-base/gnome-keyring-3.0.0-r300/work/gnome-keyring-3.0.0/gck'
  CC     gck-attributes.lo
  CC     gck-call.lo
  CC     gck-dump.lo
  CC     gck-enumerator.lo
  CC     gck-misc.lo
  CC     gck-module.lo
  CC     gck-modules.lo
  CC     gck-object.lo
  CC     gck-session.lo
  CC     gck-slot.lo
  CC     gck-uri.lo
  CC     gck-marshal.lo
  CCLD   libgck.la
cp gck.pc gck-0.pc
make[4]: Leaving directory `/var/tmp/portage/gnome-base/gnome-keyring-3.0.0-r300/work/gnome-keyring-3.0.0/gck'
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-keyring-3.0.0-r300/work/gnome-keyring-3.0.0/gck'
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-keyring-3.0.0-r300/work/gnome-keyring-3.0.0/gck'
Making all in gcr
make[2]: Entering directory `/var/tmp/portage/gnome-base/gnome-keyring-3.0.0-r300/work/gnome-keyring-3.0.0/gcr'
Makefile:379: *** recipe commences before first target.  Stop.
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-keyring-3.0.0-r300/work/gnome-keyring-3.0.0/gcr'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-keyring-3.0.0-r300/work/gnome-keyring-3.0.0'
make: *** [all] Error 2
emake failed


One correct way to skip the broken tests is to do the following sed:

sed -e 's/TESTS_DIR = tests/TESTS_DIR =/' \
	-i gcr/Makefile.am gcr/Makefile.in
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-04-11 09:19:53 UTC
I think this has already been fixed.
Comment 2 Gilles Dartiguelongue gentoo-dev 2011-04-11 09:21:18 UTC
verified all three ebuilds, it has been changed to make subdirs empty instead.
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-04-11 15:43:46 UTC
(In reply to comment #2)
> verified all three ebuilds, it has been changed to make subdirs empty instead.

I am still getting this bug at the current state of the overlay. When you say you "verified all three ebuilds", do you mean that you were able to complete the emerge for all three of them?
Comment 4 Gilles Dartiguelongue gentoo-dev 2011-04-11 16:39:23 UTC

*** This bug has been marked as a duplicate of bug 363075 ***