Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363075 - [gnome-overlay] gnome-base/gnome-keyring-3.0.0-r300 syntax error in Makefile
Summary: [gnome-overlay] gnome-base/gnome-keyring-3.0.0-r300 syntax error in Makefile
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 363039 363123 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-11 11:06 UTC by Albert W. Hopkins
Modified: 2011-04-11 22:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albert W. Hopkins 2011-04-11 11:06:31 UTC
gnome-keyring refuses to build.  The appear to be an error in 

$WORKDIR/gnome-keyring-3.0.0/gcr/Makefile:379:

SUBDIRS =
    $(TEST_DIR)

It errors out with "recipe specified before target".  I think the problem is the indentation on the second line.  If I instead change the 2 lines to:

SUBDIRS = $(TEST_DIR)

it builds fine.

I should note that this package built successfully before, but now errors after doing an "emerge -e world"

Also, building with or without the "test" USE flag doesn't make any difference.
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-04-11 11:46:25 UTC
argh, multiline subdirs suck
Comment 2 Gilles Dartiguelongue gentoo-dev 2011-04-11 16:39:13 UTC
*** Bug 363123 has been marked as a duplicate of this bug. ***
Comment 3 Gilles Dartiguelongue gentoo-dev 2011-04-11 16:39:23 UTC
*** Bug 363039 has been marked as a duplicate of this bug. ***
Comment 4 Gilles Dartiguelongue gentoo-dev 2011-04-11 22:24:15 UTC
Fixed in overlay. Thanks for reporting.