Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 352345 - [gnome-overlay] gnome-base/gnome-applets-2.32.1.1 build failure with libnotify-0.7
Summary: [gnome-overlay] gnome-base/gnome-applets-2.32.1.1 build failure with libnotif...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome3
  Show dependency tree
 
Reported: 2011-01-21 17:11 UTC by tman
Modified: 2012-02-12 14:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/log/portage/gnome-base:gnome-applets-2.32.1.1:20110121-170736.log (gnome-base:gnome-applets-2.32.1.1:20110121-170736.log,82.78 KB, text/plain)
2011-01-21 17:11 UTC, tman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2011-01-21 17:11:23 UTC
MD -MP -MF .deps/gweather-applet.Tpo -c -o gweather-applet.o gweather-applet.c
mv -f .deps/gweather-pref.Tpo .deps/gweather-pref.Po
sed \
            -e "s|\@LIBEXECDIR\@|/usr/libexec|" \
            -e "s|\@VERSION\@|2.32.1.1|" \
            org.gnome.applets.GWeatherApplet.panel-applet.in.in > org.gnome.applets.GWeatherApplet.panel-applet.in
sed \
            -e "s|\@LIBEXECDIR\@|/usr/libexec|" \
            org.gnome.panel.applet.GWeatherAppletFactory.service.in > org.gnome.panel.applet.GWeatherAppletFactory.service
/usr/bin/intltool-merge ../po org.gnome.applets.GWeatherApplet.panel-applet.in org.gnome.applets.GWeatherApplet.panel-applet -d -u -c ../po/.intltool-merge-cache
Found cached translation database
Merging translations into org.gnome.applets.GWeatherApplet.panel-applet.
gweather-applet.c:38:28: fatal error: dbus/dbus-glib.h: No such file or directory
compilation terminated.
make[3]: *** [gweather-applet.o] Error 1
make[3]: *** Waiting for unfinished jobs....
mv -f .deps/gweather-dialog.Tpo .deps/gweather-dialog.Po
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-applets-2.32.1.1/work/gnome-applets-2.32.1.1/gweather'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-applets-2.32.1.1/work/gnome-applets-2.32.1.1/gweather'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-applets-2.32.1.1/work/gnome-applets-2.32.1.1'
make: *** [all] Error 2


Reproducible: Always

Steps to Reproduce:




Portage 2.1.9.34 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.12.2-r0, 2.6.37-gentoo x86_64)
=================================================================
System uname: Linux-2.6.37-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P9700_@_2.80GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 21 Jan 2011 16:00:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7.1, 3.1.3
dev-util/cmake:      2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/X11/Sessions/awesome /etc/X11/Sessions/dwm /etc/X11/xorg.conf /etc/apache2/httpd.conf /etc/conf.d/hwclock /etc/conf.d/keymaps /etc/fstab /etc/make.conf /etc/xdg/openbox/autostart.sh /etc/xdg/openbox/menu.xml /etc/xdg/openbox/rc.xml /etc/xdg/openbox/start /usr/share/openvpn/easy-rsa /usr/share/xsessions/openbox.desktop /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en vi"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/bleeding-edge /usr/portage/local/layman/emacs /usr/portage/local/layman/gamerlay /usr/portage/local/layman/gnome /usr/portage/local/layman/gnome-live /usr/portage/local/layman/lorelei /usr/portage/local/layman/lxde /usr/portage/local/layman/mellon /usr/portage/local/layman/mpd /usr/portage/local/layman/nikai /usr/portage/local/layman/wirelay /usr/portage/local/layman/techwolf /usr/portage/local/layman/qting-edge /usr/portage/local/layman/roslin /usr/portage/local/layman/scarabeus /usr/portage/local/layman/science /usr/portage/local/layman/xfce-dev /usr/portage/local/layman/poly-c /usr/portage/local/layman/mgorny /usr/portage/local/local-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi adns afs aim alsa amd64 ao apache2 ass atm audio audiofile bash-completion beagle berkdb bidi bluetooth bzip2 cairo caps cdda cdio cdparanoia cdr cgi cjk clamdtop cli clisp consolekit cracklib crypt cscope css csv cups curl curlwrappers cvs cxx dbus dc1394 dga dhcp dhcpcd dia dirac directfb dmx dri dts dv dvd dvdr dvi emacs enca encode enscript exceptions exif expat extras faac faad fam fastcgi fbcon ffmpeg firefox flac flash fortran ftp fuse gcj gd gdbm geoip ggi gif gimp git glib gmp gnome gnome-keyring gnutls gphoto2 gpm graphviz gs gstreamer gtk gzip hal hash hddtemp highlight httpd iconv icq icu idn ieee1394 imagemagick imap imlib ipv6 ithreads jabber jack java java6 javascript jbig jingle joystick jpeg jpeg2k kerberos lame lapack latex lcms ldap libcaca libwww live logrotate lua lzo mad maildir matroska mbrola md5sum memlimit mercurial mhash midi mikmod milter mime mjpeg mmap mmx mmxext mng mono motif mp3 mp4 mpeg mplayer msn mudflap mule multilib musepack mysql nas nautilus ncurses netboot network networkmanager nfs nls nptl nptlonly nsplugin nvidia ogg ogg123 openal openexr opengl openmp oss pam pcap pcmcia pcre pdf perl php pic pidgin png policykit posix postgres ppds ps pulseaudio python qt3support qt4 quicktime radio rar raw rdesktop readline reflection rss rtsp ruby samba sasl savedconfig schroedinger sdl sdl-image session sip slang slp smp soap sockets sox spamassassin speex spell spl sqlite sse sse2 ssl ssse3 stream stun subversion svg swat sysfs syslog system-sqlite sysvipc tcl tcpd theora threads tidy tiff timidity tk tokenizer truetype udev unicode urandom usb userlocales v4l v4l2 vcd vhosts video vim-syntax vlm vnc vorbis wav wavpack webkit wifi wma wmf wxwidgets x264 xattr xcb xcomposite xft xinerama xinetd xml xmlrpc xorg xpm xscreensaver xsl xulrunner xv xvid xvmc yahoo zip zlib zsh-completion" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation php5 proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en vi" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 jruby" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa fbdev vga nouveau" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 tman 2011-01-21 17:11:34 UTC
Created attachment 260453 [details]
/var/log/portage/gnome-base:gnome-applets-2.32.1.1:20110121-170736.log
Comment 2 Gilles Dartiguelongue gentoo-dev 2011-01-21 20:25:39 UTC
do you have dbus-glib installed ?
Comment 3 tman 2011-01-21 21:22:23 UTC
yes i have it installed:

[I] dev-libs/dbus-glib
     Available versions:  0.88 (~)0.92 {bash-completion debug doc static-libs test}
     Installed versions:  0.92(20:12:53 29.12.2010)(bash-completion -debug -doc -static-libs -test)
     Homepage:            http://dbus.freedesktop.org/
     Description:         D-Bus bindings for glib
Comment 4 Pacho Ramos gentoo-dev 2011-01-25 14:08:53 UTC
Please post "ls -l /usr/include/dbus-1.0/dbus/dbus-glib.h"
Comment 5 Ben L. 2011-01-27 15:53:03 UTC
same problem here, ...

(16:52:24) host ~ # ls -l /usr/include/dbus-1.0/dbus/dbus-glib.h
-rw-r--r-- 1 root root 14378 27. Jan 16:50 /usr/include/dbus-1.0/dbus/dbus-glib.h
Comment 6 Ben L. 2011-01-27 18:05:18 UTC
ahh sorry, not the same, mine is quite different...




x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I. -I.. -DGWEATHER_MENU_UI_DIR=\""/usr/share/gnome-2.0/ui"\" -DORBIT2=1 -pthread -I/usr/include/gnome-panel-3.0/libpanel-applet -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/gtk-2.0 -I/usr/include/orbit-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm   -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libpng14   -pthread -DORBIT2=1 -I/usr/include/libxml2 -I/usr/include/libsoup-2.4 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gconf/2 -I/usr/include/libpng14 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/orbit-2.0       -march=native -O2 -pipe -MT gweather-applet.o -MD -MP -MF .deps/gweather-applet.Tpo -c -o gweather-applet.o gweather-applet.c
sed \
            -e "s|\@LIBEXECDIR\@|/usr/libexec|" \
            -e "s|\@VERSION\@|2.32.1.1|" \
            org.gnome.applets.GWeatherApplet.panel-applet.in.in > org.gnome.applets.GWeatherApplet.panel-applet.in
sed \
            -e "s|\@LIBEXECDIR\@|/usr/libexec|" \
            org.gnome.panel.applet.GWeatherAppletFactory.service.in > org.gnome.panel.applet.GWeatherAppletFactory.service
mv -f .deps/gweather-dialog.Tpo .deps/gweather-dialog.Po
/usr/bin/intltool-merge ../po org.gnome.applets.GWeatherApplet.panel-applet.in org.gnome.applets.GWeatherApplet.panel-applet -d -u -c ../po/.intltool-merge-cache
Found cached translation database
Merging translations into org.gnome.applets.GWeatherApplet.panel-applet.
gweather-applet.c: In Funktion »update_finish«:
gweather-applet.c:475:7: Fehler: zu viele Argumente für Funktion »notify_notification_new«
/usr/include/libnotify/notification.h:114:21: Anmerkung: declared here
make[3]: *** [gweather-applet.o] Fehler 1
Comment 7 Gilles Dartiguelongue gentoo-dev 2011-01-27 19:34:27 UTC
that looks like a libnotify-0.7 API change. Please don't use libnotify 0.7 if you want a gnome 2.32 desktop. Actually don't use the overlay if you want a stable desktop.
Comment 8 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-02-20 00:36:54 UTC
All problems with gnome-applets should be fixed with the live version added to the overlay.

I guess upstream will make a release sometime soon. Till then, use the live ebuild.
Comment 9 Juergen Rose 2011-03-09 11:35:34 UTC
I have the same error without using the gnome-overlay.
Comment 10 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-03-09 16:54:08 UTC
(In reply to comment #9)
> I have the same error without using the gnome-overlay.

This has already been fixed in the tree in bug 354117 by samuli
Comment 11 Victor 2011-03-10 06:06:30 UTC
I have the same error
gnome-base/gnome-applets-2.32.1.1
x11-libs/libnotify-0.7.1
error:
Merging translations into org.gnome.applets.GWeatherApplet.panel-applet.
weather-applet.c:41:28: fatal error: dbus/dbus-glib.h: No such file or directory
Comment 12 Victor 2011-03-10 06:24:37 UTC
(In reply to comment #4)
> Please post "ls -l /usr/include/dbus-1.0/dbus/dbus-glib.h"

# ls -l /usr/include/dbus-1.0/dbus/dbus-glib.h
-rw-r--r-- 1 root root 14378 Mar  9 16:18 /usr/include/dbus-1.0/dbus/dbus-glib.h

# eix dev-libs/dbus-glib
[I] dev-libs/dbus-glib
     Available versions:  0.88 0.92 {bash-completion debug doc static-libs test}
     Installed versions:  0.92(16:18:20 03/09/11)(bash-completion -debug -doc -static-libs -test)
     Homepage:            http://dbus.freedesktop.org/
     Description:         D-Bus bindings for glib
Comment 13 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-03-10 09:34:27 UTC
(In reply to comment #11)
> I have the same error
> gnome-base/gnome-applets-2.32.1.1
> x11-libs/libnotify-0.7.1
> error:
> Merging translations into org.gnome.applets.GWeatherApplet.panel-applet.
> weather-applet.c:41:28: fatal error: dbus/dbus-glib.h: No such file or
> directory

That problem is being handled in bug 358043