Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 358043 - gnome-base/gnome-applets-2.32.1.1 - gweather-applet.c:41:28: error: dbus/dbus-glib.h: No such file or directory with libnotify-0.7.1
Summary: gnome-base/gnome-applets-2.32.1.1 - gweather-applet.c:41:28: error: dbus/dbus...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-09 12:20 UTC by water
Modified: 2011-03-14 09:47 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge.log (log,81.01 KB, text/plain)
2011-03-09 12:20 UTC, water
Details

Note You need to log in before you can comment on or make changes to this bug.
Description water 2011-03-09 12:20:40 UTC
Created attachment 265281 [details]
emerge.log

I can not emerge gnome-base/gnome-applets-2.32.1.1 .

# emerge --info =gnome-base/gnome-applets-2.32.1.1
Portage 2.1.9.42 (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.4, glibc-2.13-r1, 2.6.36-gentoo-r7 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.36-gentoo-r7-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9600_@_2.80GHz-with-gentoo-1.12.14
Timestamp of tree: Wed, 09 Mar 2011 11:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.2_p7
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 3.1.3-r1
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirrors.xmu.edu.cn/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en zh zh_CN zh_TW en_US"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/science /usr/portage/local/layman/sunrise /usr/portage/local/layman/gentoo-china /usr/portage/local/layman/enlightenment /usr/portage/local/layman/devnull /usr/portage/local/myebuild /usr/portage"
SYNC="rsync://mirrors.xmu.edu.cn/gentoo-portage"
USE="X a52 aac aalib acl acpi aim alsa amd64 asf avahi bash-completion berkdb bitmap-fonts blas bluetooth branding bzip2 cairo cdparanoia cdr chm cjk cleartype cli consolekit corefonts cracklib crypt cups cxx dbus divx4linux dri dts dv dvd dvdr dvdread eds emacs emboss encode evo examples exif fam ffmpeg firefox flac foomaticdb fortran gd gdbm gdu gif gnome gnome-keyring gphoto2 gpm gstreamer gtk hal hdaps iconv ieee1394 java jpeg lame laptop lcms ldap libnotify lm_sensors mad midi mikmod mjpeg mmx mng modules mp3 mp4 mpeg msn mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl pic png policykit ppds pppd python qq qt3support quicktime rar readline sdl session spell sse sse2 sse3 ssl startup-notification svg sysfs tcpd threads tiff truetype type1 udev unicode usb vorbis wifi x264 xcb xft xine xinerama xml xorg xscreensaver xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en zh zh_CN zh_TW en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa intel fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

gnome-base/gnome-applets-2.32.1.1 was built with the following:
USE="battstat gnome gstreamer hal (multilib) policykit -ipv6 -networkmanager"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-03-09 15:48:02 UTC
Which version of dev-libs/dbus-glib is installed?
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2011-03-09 15:55:03 UTC
Actually, nothing in gnome-applets-2.32.1.1/gweather seems to set -I/usr/include/dbus-glib-1.0 when it looks like it should -- assigning.
Comment 3 Gilles Dartiguelongue gentoo-dev 2011-03-09 15:57:19 UTC
what version of dbus do you have ?
Comment 4 andrew swartz 2011-03-09 17:49:41 UTC
I am having the same problem.
dev-libs/dbus-glib-0.92
sys-apps/dbus-1.4.6

# emerge --info =gnome-base/gnome-applets-2.32.1.1
Portage 2.2.0_alpha26 (default/linux/amd64/10.0/no-multilib, gcc-4.5.2, glibc-2.13-r1, 2.6.38-rc7+ x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.38-rc7+-x86_64-AMD_Phenom-tm-_9500_Quad-Core_Processor-with-gentoo-2.0.1
Timestamp of tree: Wed, 09 Mar 2011 16:30:01 +0000
ccache version 3.1.4 [enabled]
app-shells/bash:     4.2_p7
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo x11 desktop-effects andrewthomas
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo/ rsync://mirror.mcs.anl.gov/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ rsync://gentoo.chem.wisc.edu/gentoo/ http://gentoo.chem.wisc.edu/gentoo/ http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://gentoo.osuosl.org/ rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo cdda cddb cdparanoia cdr cli compiz consolekit cracklib crypt css curl curlwrappers cvs cxx dbus device-mapper dga directfb dri drm dts dvb dvd dvdr encode ffmpeg firefox flac fontconfig fortran ftp gconf gdbm gif gimp git glitz glut gnome gnome-keyring gnutls gpm gstreamer gtk gzip hddtemp iconv imagemagick imap ipv6 java java6 jpeg lame libnotify lm_sensors logrotate lua lzma lzo mad mce mmap mmx mng modules mp3 mp4 mpeg mplayer mudflap multimedia mysql ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png policykit pppd pulseaudio python qt3support qt4 quicktime readline semantic-desktop session sndfile sockets sound speex spell sql sse sse2 sse4a ssl svg symlink sysfs syslog tcpd theora tk toolame truetype twolame udev unicode usb vcd vcdinfo vorbis webkit websockets win64codecs x264 xine xinerama xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

gnome-base/gnome-applets-2.32.1.1 was built with the following:
USE="gnome gstreamer ipv6 networkmanager policykit -battstat -hal"
Comment 5 water 2011-03-10 06:49:13 UTC
(In reply to comment #1)
> Which version of dev-libs/dbus-glib is installed?

I installed dev-libs/dbus-glib 0.92 .
Thanks
Comment 6 water 2011-03-10 06:51:32 UTC
(In reply to comment #3)
> what version of dbus do you have ?

I installed sys-apps/dbus 1.4.6 .
Thanks
Comment 7 Victor 2011-03-10 09:12:32 UTC
the same problem at me.
I written in http://bugs.gentoo.org/show_bug.cgi?id=352345
Comment 8 Pacho Ramos gentoo-dev 2011-03-10 09:41:46 UTC
Water, do you have libnotify-0.7 also?
Comment 9 water 2011-03-10 09:55:44 UTC
(In reply to comment #8)
> Water, do you have libnotify-0.7 also?

I installed x11-libs/libnotify 0.7.1 .
I also can not emerge www-client/epiphany-2.30.6 , media-sound/banshee-1.8.1 , media-video/avidemux-2.5.4-r1 , net-voip/telepathy-gabble-0.10.5 .
I think those are because of the same causes .
thanks
Comment 10 Rick Harris 2011-03-10 11:09:11 UTC
>=libnotify-0.7.1 no longer depends on dbus.

But many packages that depend on libnotify are relying on that old libnotify dbus dependency to fill in their compile time CFLAGS.

Check this out:
~ #  diff -u libnotify-0.5.2.pc libnotify-0.7.1.pc

-Requires: gtk+-2.0 >= 2.18, glib-2.0 >= 2.6, dbus-1 >= 0.76, dbus-glib-1 >= 0.76
+Requires: gdk-pixbuf-2.0 glib-2.0 >= 2.26.0 gio-2.0 >= 2.26.0

This is why at ./configure time the right dbus CFLAGS don't make it into the relevant Makefile's.
Comment 11 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-03-10 11:47:57 UTC
Comment 10 is correct, and according to the archlinux folks (hello ionut!), there's at least two packages in the tree that are broken: epiphany and gnome-applets. Here are the patches to fix them:

http://projects.archlinux.org/svntogit/packages.git/tree/gnome-applets/repos/testing-i686/add-dbus-glib.patch

http://projects.archlinux.org/svntogit/packages.git/tree/epiphany/repos/testing-x86_64/add-dbus-glib.patch

media-video/handbrake is also broken, but we don't have that in the tree.
Comment 12 water 2011-03-10 13:09:36 UTC
How to do with it now ? 
Downgrade x11-libs/libnotify ?
Thanks
Comment 13 Tilo Prütz 2011-03-10 13:18:08 UTC
I was able to compile with:

CFLAGS='-I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include' emerge -1 gnome-base/gnome-applets


libnotify 0.7.1
dbus 1.4.1
dbus-glib 0.92
Comment 14 Victor 2011-03-10 17:49:32 UTC
(In reply to comment #13)
> I was able to compile with:
> 
> CFLAGS='-I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include' emerge -1
> gnome-base/gnome-applets

with this CFLAGS:
gweather-applet.o: In function `setup_network_monitor':
gweather-applet.c:(.text+0x13e0): undefined reference to `dbus_g_bus_get'
gweather-applet.c:(.text+0x1434): undefined reference to `dbus_g_connection_get_connection'
Comment 15 Sander Sweers 2011-03-10 20:50:04 UTC
(In reply to comment #11)
> Comment 10 is correct, and according to the archlinux folks (hello ionut!),
> there's at least two packages in the tree that are broken: epiphany and
> gnome-applets. Here are the patches to fix them:
> 
> http://projects.archlinux.org/svntogit/packages.git/tree/gnome-applets/repos/testing-i686/add-dbus-glib.patch

I can confirm the patch for gnome applets corrects the problem.
Greets
Sander
Comment 16 fkhp 2011-03-11 02:10:38 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > I was able to compile with:
> > 
> > CFLAGS='-I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include' emerge -1
> > gnome-base/gnome-applets
> 
> with this CFLAGS:
> gweather-applet.o: In function `setup_network_monitor':
> gweather-applet.c:(.text+0x13e0): undefined reference to `dbus_g_bus_get'
> gweather-applet.c:(.text+0x1434): undefined reference to
> `dbus_g_connection_get_connection'

libtool: link: x86_64-pc-linux-gnu-gcc -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -Wl,-O1 -o gweather-applet-2 main.o gweather-about.o gweather-pref.o gweather-dialog.o gweather-applet.o -pthread -pthread -pthread  -Wl,--as-needed -lnotify -lpanel-applet-3 /usr/lib64/libgweather.so /usr/lib64/libgtk-x11-2.0.so /usr/lib64/libgconf-2.so /usr/lib64/libgdk-x11-2.0.so /usr/lib64/libatk-1.0.so /usr/lib64/libgio-2.0.so /usr/lib64/libpangoft2-1.0.so /usr/lib64/libpangocairo-1.0.so /usr/lib64/libgdk_pixbuf-2.0.so -lm /usr/lib64/libcairo.so /usr/lib64/libpng14.so /usr/lib64/libpango-1.0.so /usr/lib64/libfreetype.so /usr/lib64/libfontconfig.so /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so /usr/lib64/libgthread-2.0.so -lrt /usr/lib64/libglib-2.0.so -pthread
gweather-applet.o: In function `setup_network_monitor':
gweather-applet.c:(.text+0x13e0): undefined reference to `dbus_g_bus_get'
gweather-applet.c:(.text+0x1434): undefined reference to `dbus_g_connection_get_connection'
Comment 17 Pacho Ramos gentoo-dev 2011-03-11 08:19:37 UTC
+  11 Mar 2011; Pacho Ramos <pacho@gentoo.org> gnome-applets-2.32.1.1.ebuild,
+  +files/gnome-applets-2.32.1.1-dbus-fix.patch:
+  Fix building with latest libnotify (bug #358043).
+
Comment 18 andrew swartz 2011-03-11 17:54:42 UTC
I can confirm that the dbus patch fixes the issue for me.
Comment 19 Victor 2011-03-11 22:09:24 UTC
(In reply to comment #18)
> I can confirm that the dbus patch fixes the issue for me.

confirm too.
After rm /usr/portage/distfiles/gnome-applets-2.32.1.1.tar.bz2 and emerge again.
Comment 20 water 2011-03-12 03:49:49 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > I can confirm that the dbus patch fixes the issue for me.
> 
> confirm too.
> After rm /usr/portage/distfiles/gnome-applets-2.32.1.1.tar.bz2 and emerge
> again.

Thanks 
I do like what you said.
Now It is ok.
Comment 21 Gilles Dartiguelongue gentoo-dev 2011-03-14 09:47:51 UTC
Verified it now builds fine here too. Thanks.