Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 350093 - Introspection data needs to be rebuilt when gobject-introspection bumps the repository version number
Summary: Introspection data needs to be rebuilt when gobject-introspection bumps the r...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High trivial (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
Depends on:
Blocks: 324989 gnome2.32 gnome3.2 gnome3.6
  Show dependency tree
 
Reported: 2010-12-29 22:28 UTC by Joe Sapp (RETIRED)
Modified: 2013-08-25 16:53 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Sapp (RETIRED) gentoo-dev 2010-12-29 22:28:31 UTC
Compile of gtk+-2.22.1 fails with the error:
/usr/share/gir-1.0/Atk-1.0.gir: Incompatible version 1.1 (supported: 1.2)

when dev-libs/atk-1.30.0 is installed.

Reproducible: Always

Steps to Reproduce:




Upgrading to >=dev-libs/atk-1.32.0 allows the compilation to complete.
Comment 1 Mart Raudsepp gentoo-dev 2011-01-01 16:16:50 UTC
But this is only with USE=introspection, right?
And doesn't recompiling atk rebuild the .gir to the new version, or it just uses the one in the tarball, that happens to be built with 1.1?
Comment 2 Joe Sapp (RETIRED) gentoo-dev 2011-01-03 01:35:27 UTC
(In reply to comment #1)
> But this is only with USE=introspection, right?
> And doesn't recompiling atk rebuild the .gir to the new version, or it just
> uses the one in the tarball, that happens to be built with 1.1?

Oops, you're right on both accounts.  dev-libs/gobject-introspection had been updated beyond version 0.9.0-r1 and atk hadn't been rebuilt since then.

On a different subject, this doesn't seem trivial - I was updating 'world' and I hit this bug.  Perhaps it's something that the atk or gobject-introspection package will need to address.
Comment 3 Mart Raudsepp gentoo-dev 2011-01-11 03:26:32 UTC
From profiles/base/use.mask:


# Nirbheek Chauhan <nirbheek@gentoo.org> (30 Dec 2009)
# gobject-introspection USE-flag
# introspection is not mature yet. 
# gir-repository especially is a big pile of junk
introspection


The hope is that the gir format is fully stabilized by the time we need to remove this use.mask (primarily for gnome-shell purposes, iirc).
This use.mask quoting is another way of saying - if it breaks, you get to keep both pieces for now :)
Comment 4 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-02-12 12:55:56 UTC
This issue is not specific to Atk or Gtk. When gobject-introspection bumps the repository version number:

<repository version="$VERSION_NUMBER"

All introspection data needs to be rebuilt. This is similar to soname bumps in libraries.

The user should be told to run scripts/gir-rebuilder.py after updating gobject-introspection so that the rebuilding is done.
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-02-18 02:58:40 UTC
(In reply to comment #4)
> The user should be told to run scripts/gir-rebuilder.py after updating
> gobject-introspection so that the rebuilding is done.
> 

*cough* I forgot to mention that this script is in the gnome.git overlay: http://git.overlays.gentoo.org/gitweb/?p=proj/gnome.git;a=blob;f=scripts/gir-rebuilder.py
Comment 6 Pacho Ramos gentoo-dev 2011-12-08 10:45:09 UTC
How will this be finally handled in main tree? (maybe this should be added to gnome3 trackers :-/)
Comment 7 Gilles Dartiguelongue gentoo-dev 2013-08-25 16:53:16 UTC
As I explained on IRC last time someone brought up this issue, the problem is that there is currently no way to tell if any solution we came up with right now will have any benefit when the next change happens. It's now been a while since situation stabilized and I think we better close this bug now, and eventually reopen it the day it actually hits us.

Hopefully things would then be tested in overlay so gentoo-x86 uses would never have to know about the problems that could have happened.