Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 324989 - Remove introspection use mask from profiles
Summary: Remove introspection use mask from profiles
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on: 350093 360073
Blocks:
  Show dependency tree
 
Reported: 2010-06-21 23:28 UTC by Luis Medinas
Modified: 2011-08-16 15:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Medinas 2010-06-21 23:28:26 UTC
I was trying to build Brasero from git master using introspection and i noticed introspection use flag is masked. From 2009 you say it's not mature i'd say 6 months after it's mature and people need it to build some GNOME packages from git (mostly generate tarballs).

So consider unmasking this use flag even if it doesn't work as you expected!


Reproducible: Always
Comment 1 Gilles Dartiguelongue gentoo-dev 2010-07-19 10:45:34 UTC
The tree was not ready for it in 2.28, now that we are at 2.30, we still have a lack of manpower to check that it is actually in a usable state.

iirc you can unmask it locally in the meantime.
Comment 2 Daniel Gryniewicz (RETIRED) gentoo-dev 2010-07-20 18:53:01 UTC
The big issue in my mind, which isn't fixed yet as far as I know, is that we need a decent transition strategy.  Since introspection is automagic, generally, just having goi installed will break the builds of anything using it that doesn't have it enabled on *all* it's dependencies.  We'd need some way to force a full rebuild of dependencies, or random upgrades will break right and left.
Comment 3 Mart Raudsepp gentoo-dev 2010-08-02 16:42:15 UTC
I don't feel like having introspection for 2.30 stuff either, as I keep hearing about ABI changes in the introspection data in gobject-introspection, so we'd have to go through yet another transition if we let common users have introspection in 2.30 stuff as well...
Nothing really needs it for 2.30, to my knowledge, though for 2.32 the story might be different, hopefully they've stabilize their API/ABI fully by then.
Of course I might be wrong on the API changes part, but so I've heard from somewhere...
Comment 4 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-08-03 06:50:55 UTC
Another serious problem is that gobject-introspection itself provides typelibs/girs for glib, and whenever glib adds new API, gobject-introspection needs to be recompiled to take advantage of that new API. This is seriously broken behaviour. We'll need to start shipping pre-built typelibs/girs with glib.
Comment 5 Pacho Ramos gentoo-dev 2011-04-25 13:45:45 UTC
Looks like the mask was dropped, how was bug 350093 handled finally?
Comment 6 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-04-25 16:07:13 UTC
(In reply to comment #5)
> Looks like the mask was dropped, how was bug 350093 handled finally?

It was not removed. See bug 364693 .

We'll look at bug 350093 when gobject-introspection changes its version number again (won't happen for a very long time now). It's a simple matter of shipping gir-rebuilder.py with gobject-introspection, or gentoolkit.

The bigger problem is the fact that (afaiui) gobject-introspection needs to be rebuilt after glib upgrades that add new API, but that problem already exists in the tree since gobject-introspection is pulled in for vala by a number of packages.

This could easily be solved by (rev)bumping gobject-introspection and glib together.
Comment 7 Pacho Ramos gentoo-dev 2011-04-25 16:16:20 UTC
Ah, it's true, I have just seen you unmasked it for a few packages in base/package.use.mask
Comment 8 Gilles Dartiguelongue gentoo-dev 2011-04-26 08:37:05 UTC
(In reply to comment #6)
> The bigger problem is the fact that (afaiui) gobject-introspection needs to be
> rebuilt after glib upgrades that add new API, but that problem already exists
> in the tree since gobject-introspection is pulled in for vala by a number of
> packages.

Note that this also applies to a couple of packages in tree, such as dbus+dbus-glib, and most likely others.
Comment 9 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-08-16 15:58:04 UTC
This is now fixed. Please see the mail on gentoo-dev for details (hasn't hit archives yet, so no link).