Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 349844 - [gnome overlay] net-libs/webkit-gtk-1.3.8 +introspection failed to build
Summary: [gnome overlay] net-libs/webkit-gtk-1.3.8 +introspection failed to build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: InOverlay
: 350441 (view as bug list)
Depends on:
Blocks: gnome3
  Show dependency tree
 
Reported: 2010-12-27 10:25 UTC by LeDabe
Modified: 2012-02-12 14:11 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full log +gstreamer -introspection (build.log,159.09 KB, text/plain)
2010-12-27 11:29 UTC, LeDabe
Details
Full log +introspection -gstreamer (build.log.2,250.78 KB, text/plain)
2010-12-27 11:31 UTC, LeDabe
Details
Full log (build.log.3,252.97 KB, text/plain)
2010-12-28 14:56 UTC, LeDabe
Details
Build log for 1.4.1-r200 (build.log,518.51 KB, text/plain)
2011-06-17 20:01 UTC, georgi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LeDabe 2010-12-27 10:25:04 UTC
CXX    WebCore/platform/graphics/gstreamer/libwebkitgtk_1_0_la-VideoSinkGStreamer.lo
  CXX    WebCore/platform/graphics/gstreamer/libwebkitgtk_1_0_la-WebKitWebSourceGStreamer.lo
  CXX    WebCore/platform/graphics/gtk/libwebkitgtk_1_0_la-ColorGtk.lo
  CXX    WebCore/platform/graphics/gtk/libwebkitgtk_1_0_la-FontGtk.lo
WebCore/platform/graphics/gstreamer/GStreamerGWorld.cpp: In member function ‘void WebCore::GStreamerGWorld::setWindowOverlay(GstMessage*)’:
WebCore/platform/graphics/gstreamer/GStreamerGWorld.cpp:214: erreur: ‘gst_x_overlay_set_window_handle’ was not declared in this scope
make[1]: *** [WebCore/platform/graphics/gstreamer/libwebkitgtk_1_0_la-GStreamerGWorld.lo] Erreur 1
make[1]: *** Attente des tâches non terminées....
make[1] : on quitte le répertoire « /var/tmp/portage/net-libs/webkit-gtk-1.3.8/work/webkit-1.3.8 »
make: *** [all] Erreur 2
emake failed
 * ERROR: net-libs/webkit-gtk-1.3.8 failed:
 *   Compile failed


Reproducible: Always




emerge --info
Portage 2.1.9.26 (default/linux/x86/10.0/desktop/gnome, gcc-4.4.4, glibc-2.12.1-r3, 2.6.35-gentoo-r12 i686)
=================================================================
System uname: Linux-2.6.35-gentoo-r12-i686-Intel-R-_Core-TM-_i3_CPU_540_@_3.07GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 27 Dec 2010 07:15:01 +0000
ccache version 3.1.3 [disabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7.1, 3.1.3
dev-util/ccache:     3.1.3
dev-util/cmake:      2.8.3
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.4-r2, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula PUEL AdobeFlash-10.1 Q3AEULA ut2003"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/gnome /var/lib/layman/suka"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa avahi bash-completion berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode esd evo exif fam ffmpeg firefox flac fortran gdbm gdu gif gnome gnome-keyring gpm gstreamer gtk hal iconv jpeg lcms libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd pulseaudio python qt3support readline sdl session spell sse sse2 sse4 ssl ssse3 startup-notification svg sysfs tcpd tiff truetype udev unicode usb virtualbox vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2010-12-27 10:29:45 UTC
I'm not sure this is related to introspection at all given the error message. Could you try without introspection and provide a full build.log next time ?
Comment 2 LeDabe 2010-12-27 11:27:02 UTC
Trying +introspection +gstreamer: failed
Trying -introspection +gstreamer: failed
Trying +introspection -gstreamer: failed (Perhaps in this case introspection was missing for gtk+:2 ?)
Trying -introspection -gstreamer: SUCCESS

I create an Attachement with the full build logs

Note that this package was correctly merged, (+gstreamer -introspection) but after updates, emerge -DNau world wants to rebuild him, and now it won't
I suppose the rebuild was due to a new USE (probably introspection I've added because of a dependency ?)

So with the same USE, and same version, it doesn't want to rebuild
Comment 3 LeDabe 2010-12-27 11:29:10 UTC
Created attachment 258160 [details]
full log +gstreamer -introspection
Comment 4 LeDabe 2010-12-27 11:31:00 UTC
Created attachment 258162 [details]
Full log +introspection -gstreamer
Comment 5 Gilles Dartiguelongue gentoo-dev 2010-12-27 11:48:12 UTC
you indeed most likely need gtk+[introspection] for the second build.log.
The first one seems to be the genuine bug.
Comment 6 LeDabe 2010-12-28 14:56:16 UTC
Created attachment 258261 [details]
Full log
Comment 7 LeDabe 2010-12-28 14:57:17 UTC
Comment on attachment 258261 [details]
Full log 

Log with +introspection -gstreamer

GTK+:2 +introspection and libsoud +introspection was needed and builded

still fails
Comment 8 Alexander 2010-12-29 11:54:29 UTC
Confirm bug.

emerge --info
Portage 2.1.9.26 (default/linux/amd64/10.0, gcc-4.5.2, glibc-2.12.1-r3, 2.6.36-zen1 x86_64)
=================================================================
System uname: Linux-2.6.36-zen1-x86_64-Intel-R-_Atom-TM-_CPU_330_@_1.60GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 28 Dec 2010 11:30:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.5-r3, 2.7.1, 3.1.3
dev-util/cmake:      2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.4-r2, 4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -funroll-all-loops -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -funroll-all-loops -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ ftp://mirror.yandex.ru/gentoo-distfiles/distfiles/"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/gnome"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X aac acl acpi alsa amd64 amr ass audio automount bash-completion battstat bazaar berkdb bfq bluetooth bzip2 cairo cdda cli connection-sharing consolekit corefonts cpio cpudetection cracklib crypt cups cxx cyrillic dbus device-mapper dhcpcd djvu dri dvd dvdnav dvdr encode exif extras faac faad fat ffmpeg firefox3 flac flash fortran fuse gconf gdbm gdm gdu gif gimp git gnome gnome-keyring gnutls gphoto2 gpm gstreamer gtk gzip h224 h281 h323 hddtemp iconv id3tag iphone ipod iproute2 iptables ipv6 jabber jack java jpeg jpeg2k kvm lame laptop libmpeg2 libnotify mac mercurial mmx modules mouse mp3 mp4 mpeg mpg123 mplayer mudflap multilib musicbrainz nautilus ncurses networkmanager nls nptl nptlonly nvidia ogg opengl openmp pam pcre perl png policykit pppd pulseaudio python qt4 rar raw rdesktop readline reiser4 reiserfs samba session sox sqlite sse sse2 ssl startup-notification subversion sudo symlink sysfs tcpd tga theora tiff udev unicode unzip upnp usb v4l vdpau vim vim-syntax vnc wav wavpack wifi x264 xinerama xml xorg xulrunner zip zlib" ALSA_CARDS="hda-nvidia hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Guillaume ZITTA 2010-12-31 07:14:52 UTC
Same Here:

# emerge --info
Portage 2.1.9.26 (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.5, glibc-2.12.1-r3, 2.6.36-gentoo-r5-lxc-bt x86_64)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-lxc-bt-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9450_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 31 Dec 2010 06:30:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7.1, 3.1.3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.7.9-r2, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.5, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages installsources news nostrip parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.free.fr/mirrors/ftp.gentoo.org http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/gnome /var/lib/layman/jensp /usr/local/portage /home/gza/Dev/lxc-provider/gentoo-overlay /home/gza/Dev/mondorescue"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="32bit 64bit X Xaw3d a52 aac aalib acl acpi aio alsa amd64 amr amrnb analogtv animgif applet archive audacious avahi bash-completion berkdb bluetooth branding bzip2 cairo caps cdaudio cdda cddax cddb cdparanoia cdr cdrom cleartype cli consolekit cover coverage cpudetection cracklib crypt css cups curl cursors custom-cflags custom-cpuopts custom-optimization cxx dbus dc1394 device-mapper dirac disk-partition djvu dlna dmraid dri dts dvd dvdr eap-sim eds emboss encode evo exif expat extras faac faad fam fasttrack fat ffmpeg firefox flac flickr fontconfig fortran fts3 fuse gconf gd gdbm gdm gdu geoip gif gimp git glitz glut gmp gnome gnome-keyring gnutella gnutls google google-gadgets gpac gphoto2 gpm graphviz gs gsm gstreamer gtk h224 h281 h323 hal hbci hfs hpcups hpijs httpd ical icons iconv id3 id3tag ieee1394 imagemagick inotify iphone ipod iptc ipv6 iscsi jabber java javascript jbig jfs jpeg jpeg2k kvm lame lcms libass libcaca libextractor libnotify libproxy libssh2 libtiger libv4l libv4l2 lm_sensors logwatch lua lvm lxc lzma lzo mad madwifi magic matroska mikmod mmx mmxext mng modplug modules moonlight mp3 mp4 mpeg mplayer msn mtp mudflap multilib musepack musicbrainz nautilus ncurses network network-cron new-hpcups nls nptl nptlonly ntfs ofx ogg ogm openal opencore-amr openexr opengl openmp openssl pam pango pch pcre pdf perl pidgin pkcs11 png pnm policykit ppds pppd profile projectm pulseaudio pvr python qemu qt3support qt4 quicktime rar raw readline reiser4 reiserfs rtsp samba scanner schroedinger sdl secure-delete session shine shout sip smp sms sox spell sqlite srt sse sse2 sse3 sse4 ssh ssl startup-notification stream subversion svg sysfs taglib theora threads thumbnail tiff toolbar truetype twolame udev udev-acl unicode unzip upnp usb v4l v4l2 vaapi vcdx vde vdpau vim vim-pager vim-syntax vim-with-x vlm vorbis vpx wav webkit wma wma-fixed wmf wps wxwidgets wxwindows x264 xattr xcb xcomposite xfs xinerama xml xorg xosd xpm xrandr xrender xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon nouveau nv nvidia vesa vga ati" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 10 Guillaume ZITTA 2010-12-31 08:37:03 UTC
this bug depends on 
http://bugs.gentoo.org/show_bug.cgi?id=349855

I uploaded an ebuild on 349855 that actualy corrects the problem
Comment 11 Priit Laes (IRC: plaes) 2011-01-03 10:08:09 UTC
I've pushed patch that *should* fix it, so please test and close this issue when it works ;)
Comment 12 Gilles Dartiguelongue gentoo-dev 2011-01-03 10:38:06 UTC
Feel free to reopen if the current fix does not work. Thanks for reporting.
Comment 13 Gilles Dartiguelongue gentoo-dev 2011-01-03 13:13:26 UTC
*** Bug 350441 has been marked as a duplicate of this bug. ***
Comment 14 georgi 2011-06-17 20:01:12 UTC
Created attachment 277411 [details]
Build log for 1.4.1-r200

Maybe I'm missing something, but I've run into the same problem with webkit-gtk-1.4.1-r200:

  GEN    WebKit-1.0.gir
Source/WebKit/gtk/webkit/webkitversion.h:33: Warning: WebKit: symbol='WEBKITGTK_API_VERSION': Unknown namespace for symbol 'WEBKITGTK_API_VERSION'
g-ir-scanner: compile: gcc -Wall -pthread -DQT_SHARED -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -march=core2 -O2 -pipe -I./Source -I./Source/WebKit/gtk -I./DerivedSources -I./DerivedSources/webkit -I./Source/WebKit/gtk -I./Source/JavaScriptCore/ForwardingHeaders -I. -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/gio-unix-2.0/ -I/usr/include/atk-1.0 -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/libpng14 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -c -o /tmp/portage/net-libs/webkit-gtk-1.4.1-r200/work/webkit-1.4.1/tmp-introspectgH7d4O/WebKit-1.0.o /tmp/portage/net-libs/webkit-gtk-1.4.1-r200/work/webkit-1.4.1/tmp-introspectgH7d4O/WebKit-1.0.c
g-ir-scanner: link: ./doltlibtool --mode=link --tag=CC --silent gcc -o /tmp/portage/net-libs/webkit-gtk-1.4.1-r200/work/webkit-1.4.1/tmp-introspectgH7d4O/WebKit-1.0 -export-dynamic -march=core2 -O2 -pipe -L. -lwebkitgtk-1.0 -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lm -lcairo -lpng14 -lpango-1.0 -lfreetype -lfontconfig -lsoup-2.4 -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 /tmp/portage/net-libs/webkit-gtk-1.4.1-r200/work/webkit-1.4.1/tmp-introspectgH7d4O/WebKit-1.0.o
/tmp/portage/net-libs/webkit-gtk-1.4.1-r200/work/webkit-1.4.1/tmp-introspectgH7d4O/WebKit-1.0.o:(.data+0x2e8): undefined reference to `webkit_dom_html_media_element_get_type'
/tmp/portage/net-libs/webkit-gtk-1.4.1-r200/work/webkit-1.4.1/tmp-introspectgH7d4O/WebKit-1.0.o:(.data+0x3c0): undefined reference to `webkit_dom_media_error_get_type'
/tmp/portage/net-libs/webkit-gtk-1.4.1-r200/work/webkit-1.4.1/tmp-introspectgH7d4O/WebKit-1.0.o:(.data+0x450): undefined reference to `webkit_dom_time_ranges_get_type'
collect2: ld returned 1 exit status

My USE flags: USE="(-aqua) -coverage -debug -doc -gstreamer introspection* jit spell -test"

With -introspection, the build succeeds. I recommend reopening the bug.

emerge --info:
Portage 2.1.10.3 (default/linux/amd64/10.0, gcc-4.5.2, glibc-2.13-r2, 2.6.39-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.39-gentoo-r1-x86_64-Intel-R-_Core-TM-2_CPU_6700_@_2.66GHz-with-gentoo-2.0.2
Timestamp of tree: Fri, 17 Jun 2011 17:30:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21
sys-devel/gcc:            4.5.2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r2
Repositories: gentoo oss-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1 PUEL skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/tmp"
EMERGE_DEFAULT_OPTS="--nospinner --with-bdeps y --alphabetical"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/oss-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acpi adns aesicm akonadi alisp alsa amd64 amr amrnb amrwb apng archive assistant asyncns attica audiofile avx bash-completion bios bittorrent bluetooth boost branding bzip2 cairo calendar captury cdda cdinstall cdio celt cgraph chm cli consolekit context cracklib crypt css cups curl cxx cyrillic dbus declarative development device-mapper dhcp dia dirac djbfft djvu dri dts dvd dvdr dvdread dvipdfm dynamic eap-tls ebook embedded emovix encode exif expat extensions extra extrafilters extras faac faad fam fame fbcondecor ffmpeg fftw firefox fits flac fluidsynth fontconfig fontforge fpx fts3 games gcrypt gd gdbm gif gimp git glib gme gmm gnuplot gnutls gpg graphics graphviz gs gtk hdf5 hdri hpn http humanities hwdb hyperestraier ical iconv icu id3tag idea idn ilbc imagemagick inkjar inotify iproute2 ithreads jabber jadetex java java6 javascript jbig jce jingle joystick jpeg jpeg2k jsapi kde keymap kig-scripting kipi konqueror kpathsea ktts ladspa lame latex latex3 lcdfilter lcms libass libedit libffi libgcrypt libnotify libssh2 libtiger libwww lm_sensors lto lzma lzo mad matroska mbrola mem-scramble mercurial midi mjpeg mmap mmx mmxext mng mod modplug modules mp3 mp4 mpeg mtp mudflap multilib multimedia musepack music natspec ncurses network network-cron nfs nls nptl nptlonly nsplugin nuv offensive ogg omega openal openexr opengl openmp optimized-qmake oscar pam pango paste64 pcre pdf pg-intdatetime pgf phonon pic plasma plotutils png policykit postproc ppds pppd private-headers projectm pstricks pth publishers pulseaudio python python2 qemu qt3support qt4 qtscript quicktime rdesktop readline realtime reports rle rss rtmp rtsp sasl scanner schroedinger science script sdk sdl sdl-image sdlgfx secure-delete semantic-desktop session sip sipim slang smp sndfile sound soundtouch speex spell sql sqlite sqlite3 srtp sse sse2 sse3 ssl ssse3 startup-notification stats stream subversion svg symlink sysfs system-sqlite szip taglib theora threads tidy tiff toolbar truetype udev unicode unlock-notify usb utempter vaapi vamp vcd vde vdpau video vlc vlm vorbis vorbis-psy vpx wav wavpack webkit wideband wmf x264 xcb xcomposite xetex xforms xml xmlpatterns xmp xorg xulrunner xv xvid xvmc zip zlib zrtp" ALSA_CARDS="virtuoso" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="none" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 15 Per Pomsel 2011-06-28 07:08:24 UTC
ping?
Comment 16 Pacho Ramos gentoo-dev 2011-06-28 13:02:56 UTC
Maybe you are suffering bug 372493