Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 321913 (gettext-0.18) - [TRACKER] Packages failing with sys-devel/gettext-0.18
Summary: [TRACKER] Packages failing with sys-devel/gettext-0.18
Status: RESOLVED FIXED
Alias: gettext-0.18
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: Tracker
Depends on: 321721 321915 322587 323743 330879 336119 409583
Blocks: 338654
  Show dependency tree
 
Reported: 2010-05-28 21:41 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2017-01-19 18:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for convert-archive.in to fix invocation of /bin/sh vs. linked bash (gettext-0.18.1.1-convert-archive.patch,199 bytes, patch)
2010-08-29 23:36 UTC, velociraptor
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-05-28 21:41:40 UTC
For once comments welcome from developers, on how to solve this; I guess the problem is that we're updating the gettext macros, but we obviously don't run autopoint (and we shouldn't, it's most definitely *not* a safe thing to do), but that's going to be problematic.

Please no comments from users reporting trouble, file a new bug for that!
Comment 1 velociraptor 2010-08-26 15:29:02 UTC
On Solaris x86 prefix, all packages depending on gettext-0.18 fail to build, as does gettext-0.18 if emerge is invoked for it only.
Comment 2 velociraptor 2010-08-29 23:34:50 UTC
(In reply to comment #1)
> On Solaris x86 prefix, all packages depending on gettext-0.18 fail to build, as
> does gettext-0.18 if emerge is invoked for it only.
> 

I was able to build gettext-0.18.1.1 with the attached patch.  It was failing due to invoking '/bin/sh' which is Bourne shell on Solaris 10, rather than '{$prefix}/bin/sh', a link to bash.
Comment 3 velociraptor 2010-08-29 23:36:12 UTC
Created attachment 245280 [details, diff]
patch for convert-archive.in to fix invocation of /bin/sh vs. linked bash
Comment 4 Christopher Warrington (c45207) 2010-08-29 23:41:27 UTC
(In reply to comment #3)
> Created an attachment (id=245280) [details]
> patch for convert-archive.in to fix invocation of /bin/sh vs. linked bash
> 

Why is this hardcoded to /opt/gentoo? My prefix is /Gentoo.
Comment 5 SpanKY gentoo-dev 2010-08-30 02:11:12 UTC
this is a tracker.  do not post random comments/patches here.  file a real bug.
Comment 6 Peter Volkov (RETIRED) gentoo-dev 2010-09-27 06:01:45 UTC
What are best practice to fix for this issues? Does `cp /usr/share/gettext/po/Makefile.in.in <appropriate location>` is a good fix? Or may be we need some more general function into eclass?
Comment 7 SpanKY gentoo-dev 2010-09-27 06:37:03 UTC
i have no idea what issue you're referring to
Comment 8 Samuli Suominen gentoo-dev 2010-09-27 08:10:07 UTC
(In reply to comment #7)
> i have no idea what issue you're referring to
> 

The one that has following output:

make[...]: Entering directory
`/tmp/foobar-1.0/po'
*** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext
version 0.17 but the autoconf macros are from gettext version 0.18

In which case it's enough to overwrite po/Makefile.in.in with the copy gettext installs to system.

This should not be done based on USE="nls" but rather simply checking if the file exists, because `make` will enter the directory regardless if you asked for nls or not. So I suggest:

local x=/usr/share/gettext/po/Makefile.in.in
[[ -e $x ]] && cp -f $x po/

or something similar in the problematic packages src_prepare()
Comment 9 SpanKY gentoo-dev 2010-09-27 09:12:35 UTC
that output appears nowhere in this report, so Peter's comment lacks any sort of context.  but at any rate ...

does `autoreconf` not work ?  it should run autopoint for you which should regenerate the gettext files.
Comment 10 Samuli Suominen gentoo-dev 2010-09-29 05:53:56 UTC
(In reply to comment #9)
> does `autoreconf` not work ?  it should run autopoint for you which should
> regenerate the gettext files.
> 

no, it doesn't work (bug 336119). zaz runs eautoreconf, starts configure, and fails at the end... outdated Makefile.in.in