Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 311563 - gnome-base/eel-2.24.1 does not compile against gnome-base/gnome-desktop-2.30.0
Summary: gnome-base/eel-2.24.1 does not compile against gnome-base/gnome-desktop-2.30.0
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard: Pending Removal: 2010-08-12
Keywords: PMASKED
: 320249 323979 (view as bug list)
Depends on: 324109 324165 326159
Blocks: gnome2.30
  Show dependency tree
 
Reported: 2010-03-27 01:07 UTC by Michael Weber (RETIRED)
Modified: 2010-09-02 11:42 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
see lines 230 and 231 for the error (build.log,37.99 KB, text/plain)
2010-03-27 01:08 UTC, Michael Weber (RETIRED)
Details
build environment (environment,59.39 KB, text/plain)
2010-03-27 01:08 UTC, Michael Weber (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weber (RETIRED) gentoo-dev 2010-03-27 01:07:17 UTC
I had to recompile gnome-base/eel because of a missing linked library named libgnome-desktop-2.so.11 in the file /usr/lib64/libeel-2.so.2.24.1.

The compile failed due to wrong argument count in a invocation of gnome_bg_is_dark ( http://library.gnome.org/devel/gnome-desktop/stable/GnomeBG.html#gnome-bg-is-dark ) in /var/tmp/portage/gnome-base/eel-2.24.1/work/eel-2.24.1/eel/eel-background.c:846 included from /usr/include/gnome-desktop-2.0/libgnomeui/gnome-bg.h (gnome-base/gnome-desktop-2.29.92).

There were new (?) argument int dest_width and int dest_height . 

Maybe a newer version should included into the overlay or a patch. But I don't know witch variables to pass to the function.

Reproducible: Always

Steps to Reproduce:
1. have gnome-base/gnome-desktop-2.29.92 from gnome-overlay
2. emerge gnome-base/eel-2.24.1 from tree

Actual Results:  
compile failure

Expected Results:  
successful emerge 

io ~ # emerge --info    
Portage 2.1.7.17 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11-r1, 2.6.33-gentoo-io.0 x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-io.0-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 26 Mar 2010 17:00:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1
dev-python/pycrypto: 2.1.0_beta1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.3.4, 4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mfpmath=sse -mieee-fp -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mfpmath=sse -mieee-fp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 4"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://nash.fs.lmu.de/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--ipv6"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/sunrise /usr/local/portage/layman/xmw /usr/local/portage/layman/gnome"
SYNC="rsync://nash.fs.lmu.de/gentoo-portage/"
USE="X a52 aac aalib acl acpi alsa amd64 ao bash-completion berkdb bluetooth bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt cups cxx dbus dga djvu dri dts dv dvb dvd dvdr dvdread encode exif faac faad fbcon ffmpeg fftw flac fontconfig fortran gdbm gif gimp glut gnome gnome-keyring gnutls gphoto2 gpm gs gstreamer gtk hal iconv id3tag imagemagick ipod ipv6 java java6 jbig joystick jpeg jpeg2k lame latex lcms libnotify libsamplerate lm_sensors lzma lzo mad mikmod mmap mmx mng modules mp3 mpeg mpi mplayer mudflap multilib nas nautilus ncurses nls nptl nptlonly nsplugin ogg openal openexr opengl openmp pam pch pcmcia pcre pdf perl png policykit pppd python quicktime raw readline reflection rle samba sdl session smp speex spell spl sqlite sse sse2 ssl subversion svg symlink sysfs syslog taglib tcl tcpd theora threads tiff tk truetype unicode upnp usb vim-syntax vorbis wavpack webkit x264 xcb xine xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="intel-hda" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" 
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Michael Weber (RETIRED) gentoo-dev 2010-03-27 01:08:16 UTC
Created attachment 225401 [details]
see lines 230 and 231 for the error
Comment 2 Michael Weber (RETIRED) gentoo-dev 2010-03-27 01:08:44 UTC
Created attachment 225403 [details]
build environment
Comment 3 Mart Raudsepp gentoo-dev 2010-03-27 01:24:23 UTC
eel was merged into nautilus package a while ago and is deprecated as a separate package.
Do you actually need eel for anything else? I think there are a few old packages in tree and we need to do something about that then (patch or getting rid of all eel users in tree). But maybe meanwhile you don't need eel on your machine, as there are and will be no newer eel releases as far as I know, so no new releases to include.
Comment 4 Michael Weber (RETIRED) gentoo-dev 2010-03-27 01:54:20 UTC
(In reply to comment #3)
> eel was merged into nautilus package a while ago and is deprecated as a
> separate package.
ok

> Do you actually need eel for anything else? ... But maybe meanwhile you don't need eel
only dependent package is gnome-extra/nautilus-cd-burner-2.24.0, which I've installed as +cdr for nautilus-sendto and rhythmbox (have brasero, too).

> as there are and will be no newer eel releases as far as I know, so no
> new releases to include.
There is 2.26.0 version ftp://ftp.gnome.org/pub/gnome/sources/eel/2.26/

An modified ebuild (cope of 2.24 tree version) with at least questionable patch is in my overlay at http://svn.xmw.de/gentoo-overlay/gnome-base/eel/
The patch just adds zero arguments and the references to the removed (?) gnome_bg_changes_with_size , leaving background->details->background_changes_with_size undefined.

Well, the package itself and gnome-extra/nautilus-cd-burner compiles and /usr/bin/nautilus-cd-burner runs (havn't burned a cdr, jet).
Comment 5 Michael Weber (RETIRED) gentoo-dev 2010-03-27 02:12:38 UTC
(In reply to comment #4)
> An modified ebuild (cope of 2.24 tree version) with at least questionable patch
> is in my overlay at http://svn.xmw.de/gentoo-overlay/gnome-base/eel/
> The patch just adds zero arguments and the references to the removed (?)
> gnome_bg_changes_with_size , leaving
> background->details->background_changes_with_size undefined.
the definition of background->details->background_changes_with_size gets removed. 3am on a Saturday w/ bottle of wine is bad time to for grammar.

There is a version 2.25.3 of nautilus-cd-burner at http://ftp.gnome.org/pub/GNOME/sources/nautilus-cd-burner/2.25/ . The CHANGELOG states "Remove tenious eel dependency".

A renamed copy of nautilus-cd-burner-2.24.0 ebuild with removed eel DEPEND compiles and will be in my overlay in the minute.

I hope that nautilus-cd-burner isn't deprecated, too.
Comment 6 Mart Raudsepp gentoo-dev 2010-03-27 02:46:23 UTC
It sort of is deprecated in favour of brasero[nautilus] :)
Comment 7 Michael Weber (RETIRED) gentoo-dev 2010-03-27 02:51:46 UTC
(In reply to comment #3)
> ... we need to do something about that then (patch or getting
> rid of all eel users in tree).

I see following:
app-editors/mlview-0.8-r1: Theres a newer 0.9.0 w/o direct eel dep from 2005 on http://ftp.gnome.org/pub/GNOME/sources/mlview/0.9/ , ebuild is at http://svn.xmw.de/gentoo-overlay/ but does not compile due to an internal problem. dev-cpp/glademm:2.4 was added.

dev-python/nautilus-python-0.6.1: does state =gnome-base/eel-2.6 dep in ebuild, but was removed upstream as http://git.gnome.org/browse/nautilus-python/commit/?id=bbfd1edcafadded353e8636a9a7759558205ee49 reads.

That's it.
Comment 8 Michael Weber (RETIRED) gentoo-dev 2010-03-27 04:11:37 UTC
(In reply to comment #7)
> app-editors/mlview-0.8-r1: Theres a newer 0.9.0 w/o direct eel dep from 2005 on
> http://ftp.gnome.org/pub/GNOME/sources/mlview/0.9/ , ebuild is at
> http://svn.xmw.de/gentoo-overlay/ but does not compile due to an internal
> problem. dev-cpp/glademm:2.4 was added.
fixed and reported as  http://bugs.gentoo.org/show_bug.cgi?id=311573

> dev-python/nautilus-python-0.6.1: does state =gnome-base/eel-2.6 dep in ebuild,
> but was removed upstream
posted to http://bugs.gentoo.org/show_bug.cgi?id=301922#c2

n8
Comment 9 David Abbott gentoo-dev 2010-04-12 23:34:44 UTC
For revdep-rebuild to stop attempting to install gnome-base/eel I had to uninstall gnome-extra/nautilus-cd-burner and dev-python/nautilus-cd-burner-python
Comment 10 Pacho Ramos gentoo-dev 2010-05-17 19:22:57 UTC
*** Bug 320249 has been marked as a duplicate of this bug. ***
Comment 11 Gilles Dartiguelongue gentoo-dev 2010-06-09 08:02:36 UTC
the bug is not solved and nobody stated that it wont be fixed.
Comment 12 Pacho Ramos gentoo-dev 2010-06-14 19:43:09 UTC
*** Bug 323979 has been marked as a duplicate of this bug. ***
Comment 13 Fred Krogh 2010-06-14 21:45:06 UTC
equery depends eel shows nothing depending on eel, but revdep-rebuild still wants to bring it in -- and fails.
Comment 14 Michael Weber (RETIRED) gentoo-dev 2010-06-15 10:30:38 UTC
(In reply to comment #13)
> equery depends eel shows nothing depending on eel, but revdep-rebuild still
> wants to bring it in -- and fails.

This must be because an ELF file installed by eel is broken (missing needed lib) and revdep tries to fix eel by recompiling. Pleas run `quickpkg eel` to preserve you current installed version of eel, thenn remove it via `equery -a -depclean` or if that lists to much packages, just `emerge -aC eel`. Then run `revdep-rebuild --ignore --pretend` and it should be gone.

Comment 15 Helmut Jarausch 2010-06-15 10:55:17 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > equery depends eel shows nothing depending on eel, but revdep-rebuild still
> > wants to bring it in -- and fails.
> 
> This must be because an ELF file installed by eel is broken (missing needed
> lib) and revdep tries to fix eel by recompiling. Pleas run `quickpkg eel` to
> preserve you current installed version of eel, thenn remove it via `equery -a
> -depclean` or if that lists to much packages, just `emerge -aC eel`. Then run
> `revdep-rebuild --ignore --pretend` and it should be gone.
> 
BUT, gnome-extra/nautilus-cd-burner-2.24.0 still depends on eel, so it will
be pulled in again!

Comment 16 Michael Weber (RETIRED) gentoo-dev 2010-06-15 11:50:41 UTC
Please keep in mind that there are 3 release steps between nautilus-cd-burner-2.24 and Gnome 2.30.
(in general mixes between stable versions and bleeding edge version were not supported)

If you truly want to use nautilus-cd-burner, the 2.25.3 w/o eel and eel-2.26.0 is in my overlay at http://svn.xmw.de/websvn/gentoo-overlay/ . I really don't think gnome herd will bump the (in their opinion deprecated) nautilus-cd-burner or the moved-into-nautilus eel.
Comment 17 Michael Weber (RETIRED) gentoo-dev 2010-06-15 11:51:47 UTC
forgot to mention bug 324109 , the bump request on nautilus-cd-burner
Comment 18 Pacho Ramos gentoo-dev 2010-06-15 16:22:33 UTC
(In reply to comment #16)
> I really don't
> think gnome herd will bump the (in their opinion deprecated) nautilus-cd-burner
> or the moved-into-nautilus eel.
> 

It's not only an "opinion" ;-), everybody can check that it's no longer developed:
http://git.gnome.org/browse/nautilus-cd-burner/log/

People should upgrade to brasero
Comment 19 Michael Weber (RETIRED) gentoo-dev 2010-06-15 17:19:29 UTC
(In reply to comment #15)
> BUT, gnome-extra/nautilus-cd-burner-2.24.0 still depends on eel, so it will
> be pulled in again!


(In reply to comment #18)
> People should upgrade to brasero

Can we please treeclean gnome-extra/nautilus-cd-burner and some of the gnome versions <2.28?

Comment 20 Pacho Ramos gentoo-dev 2010-06-15 17:34:56 UTC
(In reply to comment #19)
> Can we please treeclean gnome-extra/nautilus-cd-burner and some of the gnome
> versions <2.28?
> 

I would like to see them masked for removal, but brasero is still not keyworded for sh and not stable on arm, while nautilus-cd-burner has versions with "arm sh" :-/
Comment 21 Fred Krogh 2010-06-15 20:25:58 UTC
(In reply to comment #13)
> equery depends eel shows nothing depending on eel, but revdep-rebuild still
> wants to bring it in -- and fails.
> 
Sorry, after my latest update, eel has been totally forgotten -- good!
Comment 22 Gilles Dartiguelongue gentoo-dev 2010-06-29 13:39:44 UTC
@herd, we should just remove all keywords on eel and rrdeps, maybe except for arm and sh.
Comment 23 Pacho Ramos gentoo-dev 2010-09-02 11:42:55 UTC
Dropped