Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 303375 - Document the desktop environment component handling in gnome-base/gnome-session-3.0
Summary: Document the desktop environment component handling in gnome-base/gnome-sessi...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High enhancement with 2 votes (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 436392 (view as bug list)
Depends on:
Blocks: gnome3 gnome3-upgrade-guide gnome3.6
  Show dependency tree
 
Reported: 2010-02-03 19:10 UTC by mike johnson
Modified: 2013-08-17 13:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mike johnson 2010-02-03 19:10:14 UTC
I have emerged world and now GNOME is not allowing enlightenment to start. I normally use startx with the WINDOW_MANAGER variable set to /usr/bin/e16 and it has always worked fine. I tried the gnome-e16 session selection using the gui login xdm/gdm, and the result was still no enlightenment and disfunctional gnome menu items, as if no window manager was running at all, but I couldn't confirm that because it became unusable. I was able to start enlightenment without gnome running so I know enlightenment is ok.

Reproducible: Always

Steps to Reproduce:
1. emerge latest GNOME
2. set env variable WINDOW_MANAGER to /usr/bin/e16
3. startx

Actual Results:  
Enlightenment doesn't start. Metacity starts.

Expected Results:  
Enlightenment should start.
Comment 1 Romain Perier (RETIRED) gentoo-dev 2010-02-03 19:33:17 UTC
- What about  /desktop/gnome/session/required_components/windowmanager ?
 You've to change this entry.

- Then, because metacity is an autostart app, started by the session manager, you need to add enlightenment in your startup applications . (the windowmanager must replaces metacity)

It works like a charm here with GNOME+fvwm ;) (or compiz)
Comment 2 mike johnson 2010-02-09 04:29:28 UTC
I have converged on what I believe is the best solution at this time. As Romain suggested, I edited:

/desktop/gnome/session/required_components/windowmanager
and
/desktop/gnome/session/required_components/filemanager
(see below for why I changed this parameter also)

and replaced each entry with: e16

However, e16 doesn't have a desktop file, so I had to create this using metacity.desktop as an example:

---------my e16.desktop file
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Enlightenment
Name[en_CA]=Enlightenment
Exec=e16
# name of loadable control center module
X-GNOME-WMSettingsModule=
# name we put on the WM spec check window
X-GNOME-WMName=Enlightenment
# back compat only 
X-GnomeWMSettingsLibrary=
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=
X-GNOME-Bugzilla-Component=general
X-GNOME-Autostart-Phase=WindowManager
#X-GNOME-Provides=windowmanager
X-GNOME-Provides=filemanager;windowmanager;
X-GNOME-Autostart-Notify=true

[Window Manager]
SessionManaged=true
-----------------------------------------

I placed this file in:
/usr/share/applications

I then removed the enlightenment startup apps entry. Gnome now starts e16 without needing to explicitly specify it as a startup application. Starting everything this way enables Gnome to display a nice background over the top of the enlightenment default background. Enlightenment is still complaining about another window manager running, but that's a fairly minor weakness and possibly there is a config option I haven't set correctly.

I configured e16 as the filemanager also because nautilus (and x-server overhead) was chewing up anywhere between 40% and 60% or more of my cpu on a continuous basis. Its now back down to normal, less than 5%.

I hope someone else finds these suggestions useful.

Thanks for the help.
-Mike


Comment 3 Gilles Dartiguelongue gentoo-dev 2010-09-29 15:17:50 UTC
the solution look like the new way of doing things. Unfortunately, with e16 ebuild starting to change gconf values, it's time we write thing down in our documentation so users and devs alike can do the right thing (and drop unneeded elogs from ebuilds).

Then we should probably reset the window manager to metacity by default in the gnome-session provided .desktop file and it will most likely also allow us to provide a .desktop file to start with mutter/gnome-shell.
Comment 4 Pacho Ramos gentoo-dev 2011-05-06 18:05:19 UTC
This has probably changed a lot with Gnome3, maybe other team members using it could confirm the status of this one there
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-05-06 18:31:58 UTC
The method has changed completely with GNOME 3. This is on the todo list for documenting GNOME 3.

Changing subject and blocking GNOME 3 release...
Comment 6 Gilles Dartiguelongue gentoo-dev 2012-11-04 11:22:40 UTC
*** Bug 436392 has been marked as a duplicate of this bug. ***
Comment 7 Pacho Ramos gentoo-dev 2013-08-17 13:09:49 UTC
I need someone to tell me (or do) what exactly needs to be documented in:
https://wiki.gentoo.org/wiki/GNOME/3.8-upgrade-guide

to handling this *with gnome 3.8* (if still needed)