Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 436392 - gnome-base/gnome-session: document how to manually start a session from the console without gdm (was: gnome-base/gnome-shell fails to load menu)
Summary: gnome-base/gnome-session: document how to manually start a session from the c...
Status: RESOLVED DUPLICATE of bug 303375
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome3-upgrade-guide
  Show dependency tree
 
Reported: 2012-09-27 09:07 UTC by Maciej Piechotka
Modified: 2012-11-04 11:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2012-09-27 09:07:34 UTC
gnome-base/gnome-shell fails to load menu as it tries to load /etc/xdg/menus/applications.menu instead of /etc/xdg/menus/gnome-applications.menu.
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-27 09:44:11 UTC
How are you launching gnome-shell?

We use /etc/X11/xinit/xinitrc.d/10-xdg-menu-gnome (installed by gnome-menus) to automatically set XDG_MENU_PREFIX to "gnome-" when DESKTOP_SESSION is "gnome" or "cinnamon" (which should be the case if you launch the gnome or cinnamon session from gdm or other modern login managers). Are you doing anything which might interfere with that setup, like custom /usr/share/xsessions files, unusual login managers, etc.?

(On my system, with gdm-3.6.0, gnome-session-3.6.0, and gnome-menus-3.5.92, everything works as expected.)
Comment 2 Maciej Piechotka 2012-09-27 15:08:44 UTC
(In reply to comment #1)
> How are you launching gnome-shell?
> 

This time from commandline from startx+gnome-session. I have unresolved yet problems with gdm-3.6 which I try to figure out (I thought that they might have common root cause but they don't).

> We use /etc/X11/xinit/xinitrc.d/10-xdg-menu-gnome (installed by gnome-menus)
> to automatically set XDG_MENU_PREFIX to "gnome-" when DESKTOP_SESSION is
> "gnome" or "cinnamon" (which should be the case if you launch the gnome or
> cinnamon session from gdm or other modern login managers). Are you doing
> anything which might interfere with that setup, like custom
> /usr/share/xsessions files, unusual login managers, etc.?
> 
> (On my system, with gdm-3.6.0, gnome-session-3.6.0, and gnome-menus-3.5.92,
> everything works as expected.)

Hmm. Gdm 3.5.9x/3.6.0 works for you (at least I have some data point it works for someone on Gentoo).

Possibly having gnome-shell start from cmd would be helpful (it helps to find the debug the setup).
Comment 3 Maciej Piechotka 2012-09-27 15:24:35 UTC
Current version from gnome overlay WFM (including gdm). It would be nice if it worked out of box from startx+gnome-session to debug issues.
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-09-27 19:13:41 UTC
(In reply to comment #3)
> Current version from gnome overlay WFM (including gdm). It would be nice if
> it worked out of box from startx+gnome-session to debug issues.

Starting gnome-3 from the command line via startx never worked. You need to run all the scripts in xinitrc.d, you need to start a session bus, you need to register the session with consolekit or systemd, etc.

Probably we should figure out the recommended way to do this and document it.
Comment 5 Gilles Dartiguelongue gentoo-dev 2012-09-29 22:29:49 UTC
It is documented here:

http://www.gentoo.org/doc/en/gnome-config.xml

It might be a little bit out of date, but it is a start.
Comment 6 Gilles Dartiguelongue gentoo-dev 2012-11-04 11:22:40 UTC
Sort of the same bug as bug #303375

*** This bug has been marked as a duplicate of bug 303375 ***