Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 290567 - gnome-base/nautilus-2.28.1 re-add support for tracker (0.7)
Summary: gnome-base/nautilus-2.28.1 re-add support for tracker (0.7)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.28
  Show dependency tree
 
Reported: 2009-10-26 13:54 UTC by Florian Scandella
Modified: 2009-12-13 22:51 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for totem 2.28.1 (totem-2.6.28-tracker-0.7-ver2.patch,18.96 KB, patch)
2009-10-26 21:50 UTC, Sander Sweers
Details | Diff
ebuild patch (totem-2.28.1-tracker.ebuild.patch,1.02 KB, patch)
2009-10-26 22:36 UTC, Sander Sweers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Scandella 2009-10-26 13:54:55 UTC
gnome-base/nautilus-2.18.1 depends on >=app-misc/tracker-0.7 but tracker-0.7 is not in overlay or portage tree. in addition media-video/totem-2.28.1-r1 depends on <tracker-0.7, so even if i put tracker-0.7 in my own overlay it does not work.

Reproducible: Always
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-10-26 14:15:07 UTC
Yes, it is a known problem. tracker is not an easy bump and API was broken so it'll be a mess to upgrade, just disable support for it until everything is migrated to 0.7, it'll avoid you a headache, really.
Comment 2 Florian Scandella 2009-10-26 14:26:09 UTC
ok, i build nautilus with -tracker for now (not that i use it much anyhow :) )...
Comment 3 Sander Sweers 2009-10-26 21:49:24 UTC
There is a patch for totem but it then *requires* tracker-0.7.
http://mail.gnome.org/archives/svn-commits-list/2009-October/msg05757.html

I tried it but for me it faild to find tracker.h, probably because totem-tracker-widget.h was not updated to the new location. I will attach the modified patch in a minute.
Comment 4 Sander Sweers 2009-10-26 21:50:51 UTC
Created attachment 208367 [details, diff]
Patch for totem 2.28.1

This is the mofified patch that makes it work for me. Tested on ~amd64.
Comment 5 Sander Sweers 2009-10-26 22:36:14 UTC
Created attachment 208376 [details, diff]
ebuild patch

This patch adds check on tracker version and use flag and applies patch. Not sure if this is the correct way of handling this but works for me.
Comment 6 Walter Meinl 2009-10-28 07:14:54 UTC
BTW, nautilus-2.28.1 (and totem) work well with tracker-0.6.95. I just lowered the tracker dependency of nautilus in my own overlay. Configure of nautilus checks, whether tracker <0.7 or >=0.7 is installed, and points to ifdefed code depending on the tracker version installed. 
Comment 7 Alexandre Ghisoli 2009-10-30 13:14:54 UTC
Proposed tracker-0.7.4 ebuild in bug #269928

Please note as comment #1, there is no easy upgrade path for tracker <= 0.6.6.
Comment 8 Helmut Eberharter 2009-11-02 13:31:13 UTC
Ergo: Remove the tracker useflag from nautilus ebuild!
Comment 9 Gilles Dartiguelongue gentoo-dev 2009-12-13 22:51:39 UTC
fixed in 2.28.2, see bug #296794 for keywording requests.