Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 296794 - app-misc/tracker (re)keywording request
Summary: app-misc/tracker (re)keywording request
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on:
Blocks: gnome2.28 313563 334427
  Show dependency tree
 
Reported: 2009-12-13 22:33 UTC by Gilles Dartiguelongue
Modified: 2012-09-11 07:04 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Dartiguelongue gentoo-dev 2009-12-13 22:33:47 UTC
Hi arches,

I added new tracker a few days ago to the tree and re-added tracker support to nautilus-2.28.2. As a consequence, your keywords were dropped from nautilus and will be dropped from gnome meta by the time it is added to the tree. Please consider keywording tracker and nautilus back. Thanks.
Comment 1 Alexis Ballier gentoo-dev 2009-12-14 13:08:47 UTC
(In reply to comment #0)
> I added new tracker a few days ago to the tree and re-added tracker support to
> nautilus-2.28.2. 

Weird you're asking for bsd keywording while the tracker ebuild has a mandatory dep on util-*linux*....

> As a consequence, your keywords were dropped from nautilus and
> will be dropped from gnome meta by the time it is added to the tree. Please
> consider keywording tracker and nautilus back. 

Why? We've had a p.use.mask on nautilus[tracker] for ages on bsd... and it seems to be the case for other arches too.

Comment 2 Gilles Dartiguelongue gentoo-dev 2009-12-14 13:46:39 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > I added new tracker a few days ago to the tree and re-added tracker support to
> > nautilus-2.28.2. 
> 
> Weird you're asking for bsd keywording while the tracker ebuild has a mandatory
> dep on util-*linux*....

hum right, I had forgotten that one. I guess there is upstream work to do here.

> > As a consequence, your keywords were dropped from nautilus and
> > will be dropped from gnome meta by the time it is added to the tree. Please
> > consider keywording tracker and nautilus back. 
> 
> Why? We've had a p.use.mask on nautilus[tracker] for ages on bsd... and it
> seems to be the case for other arches too.

I didn't check individual arch package.mask, I added a global mask a few weeks ago for tracker 0.6 elimination purpose but it's now restricted so it can be used in nautilus-2.28.2 with tracker-0.7.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-12-17 23:22:44 UTC
ok I re-added arm, hppa and sh and bsd keyword on nautilus after checking they had the USE masked in profile. Keeping everyone CCed so we can get a word on if you guys would like to support tracker or not. If not, please add a use.mask entry in your profile.
Comment 4 Raúl Porcel (RETIRED) gentoo-dev 2010-01-01 12:50:33 UTC
~alpha/~ia64/~sparc done and arm/sh are happy with the mask
Comment 5 Gilles Dartiguelongue gentoo-dev 2010-05-14 17:54:21 UTC
All arches done, closing.
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2010-07-06 14:43:16 UTC
(In reply to comment #5)
> All arches done, closing.
> 

~ppc/~ppc64/~hppa still missing, tracker needed by gnome-base/nautilus ...
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2010-07-06 15:20:01 UTC
ppc64 done

btw, alternative would be to use.mask "tracker" on profiles, in case hppa doesn't want tracker...
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2010-07-20 01:35:41 UTC
Keywording of gnome-base/nautilus removed for HPPA.
Comment 9 Joe Jezak (RETIRED) gentoo-dev 2010-08-11 17:46:22 UTC
Marked ~ppc.
Comment 10 Gilles Dartiguelongue gentoo-dev 2010-08-23 09:49:28 UTC
@bsd, any comment about tracker support ?
Comment 11 Gilles Dartiguelongue gentoo-dev 2010-11-14 16:15:59 UTC
alpha, ia64, ppc, ppc64 and sparc,

I'm sorry guys, but I must re-add you here due to the fix of bug #325435, I had to drop your keyword again. Please either keyword app-text/odt2txt or mask the gsf use flag altogether.

@bsd, I'm still waiting for a word from you guys.

Thanks in advance.
Comment 12 Raúl Porcel (RETIRED) gentoo-dev 2010-11-28 14:34:20 UTC
~alpha/~ia64/~sparc done
Comment 13 Mark Loeser (RETIRED) gentoo-dev 2011-02-02 15:59:08 UTC
~ppc64 done
Comment 14 Samuli Suominen (RETIRED) gentoo-dev 2011-03-23 15:33:31 UTC
This looks very broken:

tracker-0.10.0.ebuild:KEYWORDS="~alpha ~amd64 ~x86"
tracker-0.10.4.ebuild:KEYWORDS="~alpha ~amd64 ~x86"
tracker-0.8.17.ebuild:KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86"
tracker-0.9.38.ebuild:KEYWORDS="~alpha ~amd64 ~x86"

As current version for ia64/ppc64/sparc will fail to compile, for instance, with current stable sys-power/upower.

So rekeyword latest asap, or drop keywords so we can get rid of the will-not-compile-for-sure versions.
Comment 15 Gilles Dartiguelongue gentoo-dev 2011-03-23 16:26:37 UTC
the only installable tracker is 0.8 and should work with latest upower as I backported appropriate patches iirc.
I'll unmask 0.10 asap though given last talk I had with upstream about depending on too recent libs.
Comment 16 Raúl Porcel (RETIRED) gentoo-dev 2011-04-23 17:09:56 UTC
So what we have to do, then?
Comment 17 Alexis Ballier gentoo-dev 2012-08-06 21:21:53 UTC
(In reply to comment #11)
> @bsd, I'm still waiting for a word from you guys.

we're fine with the mask, esp. since the util-linux dep is still there, 2.5 years later :)
Comment 18 Pacho Ramos gentoo-dev 2012-09-11 07:04:52 UTC
Looks like tracker is now amd64/x86 only (for all versions)