Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269928 - app-misc/tracker-0.7.7 version bump + live ebuild update
Summary: app-misc/tracker-0.7.7 version bump + live ebuild update
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords: InVCS
: 251755 290562 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-15 10:33 UTC by Marcos
Modified: 2009-12-10 23:22 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild (tracker-0.6.94.ebuild,3.93 KB, text/plain)
2009-05-15 10:35 UTC, Marcos
Details
tracker-0.7,4,ebuild (tracker-0.7.4.ebuild,3.25 KB, text/plain)
2009-10-29 15:53 UTC, Alexandre Ghisoli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos 2009-05-15 10:33:12 UTC
This new version seems to have less bugs and worked well with me. The versions in portage eat up 100% CPU and never finish indexing om my machine.

Reproducible: Always
Comment 1 Marcos 2009-05-15 10:35:13 UTC
Created attachment 191338 [details]
ebuild
Comment 2 Sebastian Luther (few) 2009-05-15 10:40:59 UTC
This version this in the gnome overlay.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-05-15 10:46:54 UTC
This is clearly not something that will go in tree as is. It breaks API with everything, it's still buggy as hell, makes evolution hang and stuff.
Comment 4 Alexandre Ghisoli 2009-10-29 14:07:43 UTC
Tracker 0.7 is out late september.

  * Library: libtracker-miner
    A common library for data miners to use allowing easy integration
    with Tracker. This provides D-Bus integration, state and progress
    APIs and a means to pause / resume your miner.

  * Library: libtracker-client
    This API has been completely changed. It is much simpler now and
    relies more on the SPARQL language than specific APIs to query
    Tracker.

  * Daemon: tracker-store
    Completely reworked to accept SPARQL queries and updates.
    Implements Nepomuk ontology instead of flawed own brand. This
    ontology is implemented following the W3C RDF semantics.

  * Database: Completely redesigned ALL databases.
    These now support triple store and allow much faster querying.

  * Application: tracker-miner-fs
    Implements libtracker-miner and facilitates the old roles of
    tracker-indexer and some of the old roles from trackerd like file
    system crawling. This mines data and sends it to tracker-store to
    put in the database about files AND applications.

  * Application: tracker-sparql
    A command line tool to query or update the databases using SPARQL.

  * Application: tracker-import
    A command line tool to import data kept in Turtle files.

  * Application: tracker-search-bar
    An applet for quickly searching for music, videos, images,
    documents and folders.

  * Application: tracker-status-icon
    Previously tracker-applet, but rewritten and now much simpler.
    This provides state and progress information about all miners
    which are running. This also allows the user to pause / resume
    data miners.

  * Application: tracker-search-tool
    This has been completely rewritten using vala and the new
    architecture underneath it. Support for the old features are not
    quite there yet, but it is similar to its predecessor!

  * Application: tracker-explore
    This is an application written to explore data in the database and
    each item's relationship to the next. This really demonstrates
    Tracker's ontology and provides it through full text searching.

  * Plugin: Evolution
    Now the evolution plugin is supported by the developers instead of
    us dipping into their databases (as previously) which is dangerous
    and unsafe. Also this implements the libtracker-miner API so it
    can be controlled using tracker-status-icon.

  * Patches: Nautilus & GtkFileChooser
    These are currently submitted upstream to support the new APIs for
    continued integration between Tracker and GNOME.

Bugs:

  Too many to list here and so much development some are even obsolete.

Notes:

  There is currently no migration path from 0.6. to 0.7. So all
  configurations will have to be re-set up for now. This is planned to
  be added before a 0.8 release.

Comment 5 Alexandre Ghisoli 2009-10-29 15:53:30 UTC
Created attachment 208643 [details]
tracker-0.7,4,ebuild

Almost all dependencies checked.

There are two points left :

1/ gnome-desktop dep replaced by dev-python/gnome-desktop-python (?)
In ChangeLog.pre-0-6-93
2009-03-06  Michael Biebl  <mbiebl@gmail.com>
Starting with version 2.23.6, deskbar-applet no longer ships the deskbar.core.gnomedeskop python module so we use gnomedesktop directly (requires python-gnome-desktop).


2/ UNAC
--enable-unac           enable UNAC support, required for stripping accents
                          [default=auto]

Not in portage tree. Is that stuff needed ?
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-11-01 23:18:45 UTC
*** Bug 251755 has been marked as a duplicate of this bug. ***
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-11-01 23:19:27 UTC
*** Bug 290562 has been marked as a duplicate of this bug. ***
Comment 8 Helmut Eberharter 2009-11-02 13:28:52 UTC
(In reply to comment #5)
> 2/ UNAC
> --enable-unac           enable UNAC support, required for stripping accents
>                           [default=auto]
> 
> Not in portage tree. Is that stuff needed ?

There's a proposed ebild in #134732, which in the mean time made it to the sunrise overlay.

Comment 9 Gilles Dartiguelongue gentoo-dev 2009-11-02 22:03:00 UTC
Ok so just for the record, the proposed 0.7.4 ebuild is not respecting a lot of things from configure.ac so it's a definite no-no for the tree, I'll work on an updated ebuild that will first be commited to the gnome overlay and then moved to the tree if good enough.
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-11-13 09:14:03 UTC
gnome overlay now has 0.7.7, it'd be nice to have some feedback on it before we decide to move it to the tree.
Comment 11 Helmut Eberharter 2009-11-14 16:58:00 UTC
seems to work fine. despite it's not indexing evolution, but i may have missed a setting? (TrackerEvolutionPlugin is enabled)
Comment 12 Alexandre Ghisoli 2009-11-24 12:50:35 UTC
Works well too, except the evolution thing.
Will double check as soon I've spare time.
Comment 13 Helmut Eberharter 2009-11-24 13:28:57 UTC
to get this straight: 'TrackerEvolutionPlugin' is enabled in evolution, 'tracker-stats | grep -i mail' shows:
  nco:EmailAddress = 4971
  nmo:Email = 34511
  nmo:MailboxDataObject = 34980
'tracker-search' even shows email results, but 'tracker-search-tool' doesn't fine any emails or contacts from evolution.

Comment 14 Gilles Dartiguelongue gentoo-dev 2009-12-10 23:22:49 UTC
Tracker 0.6 is gone, 0.7.10 has been added to the tree and live ebuild has been updated to git repository with 0.7 deps. Please give them a shot. I'll start adding back tracker support to apps as patches come in. Thanks for your patience.