Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 286629 - dev-libs/glib-2.20.5 testsuite needs dev-util/desktop-file-utils
Summary: dev-libs/glib-2.20.5 testsuite needs dev-util/desktop-file-utils
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
: 282040 285823 292439 311839 332647 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-27 09:01 UTC by Jakub Kowalski
Modified: 2011-06-06 16:00 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
glib-2.20.5-r1 build log (build.log,344.65 KB, text/plain)
2009-12-06 16:51 UTC, Carmine Paolino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Kowalski 2009-09-27 09:01:45 UTC
dev-libs/glib-2.20.5 testsuite fails:
---------------------------------------------------
PASS: live-g-file                                                                                                                                                        
TEST: unix-streams... (pid=4288)                                                                                                                                         
  /unix-streams/pipe-io-test:                                          OK                                                                                                
PASS: unix-streams                                                                                                                                                       
TEST: desktop-app-info... (pid=4305)                                                                                                                                     
  /desktop-app-info/delete:                                                                                                                                              
GLib-GIO-WARNING **: Failed to execute child process "update-desktop-database" (No such file or directory)                                                               
aborting...                                                                                                                                                              
FAIL                                                                                                                                                                     
GTester: last random seed: R02Sde6a63c51cb6af6711afab5a42f976e9                                                                                                          
/bin/sh: line 1:  4093 Zakończony             ../../glib/gtester --verbose memory-input-stream memory-output-stream g-file g-file-info data-input-stream data-output-stream g-icon buffered-input-stream sleepy-stream filter-streams simple-async-result live-g-file unix-streams desktop-app-info                                               
make[5]: *** [test] Błąd 143                                                                                                                                             
make[5]: Opuszczenie katalogu `/var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5/gio/tests'                                                                         
make[4]: *** [test] Błąd 2                                                                                                                                               
make[4]: Opuszczenie katalogu `/var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5/gio'                                                                               
make[3]: *** [test] Błąd 2                                                                                                                                               
make[3]: Opuszczenie katalogu `/var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5'
make[2]: *** [check-am] Błąd 2
make[2]: Opuszczenie katalogu `/var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5'
make[1]: *** [check-recursive] Błąd 1
make[1]: Opuszczenie katalogu `/var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5'
make: *** [check] Błąd 2
--------------------------------------------

It looks like it needs update-desktop-database which is part of dev-util/desktop-file-utils.

Reproducible: Always

Steps to Reproduce:
1. check if you don't have dev-util/desktop-file-utils which is not dependency for glib.
2. FEATURES="test" emerge =dev-libs/glib-2.20.5


Actual Results:  
Testsuite fails

Expected Results:  
All tests should be passed.
Testsuite should depend on dev-util/desktop-file-utils or some tests should be removed.

Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r4 i686)
=================================================================                                    
System uname: Linux-2.6.30-gentoo-r4-i686-Pentium_III_-Coppermine-with-gentoo-1.12.11.1              
Timestamp of tree: Sun, 27 Sep 2009 01:45:01 +0000                                                   
distcc 3.1 i686-pc-linux-gnu [disabled]                                                              
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -mtune=pentium3 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=i686 -mtune=pentium3 -O2 -pipe"
DISTDIR="/pub/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://ftp.vectranet.pl/gentoo/ ftp://ftp.vectranet.pl/gentoo/ http://gentoo.prz.rzeszow.pl http://gentoo.zie.pg.gda.pl http://gentoo.po.opole.pl ftp://gentoo.po.opole.pl ftp://mirror.icis.pcz.pl/gentoo/ http://gentoo.mirror.pw.edu.pl/ "
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="pl en"
MAKEOPTS="-j2"
PKGDIR="/pub/distfiles/packages/R2D2"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl acpi apache2 apm atm avahi berkdb bindist bzip2 cli cracklib crypt dovecot-sasl dri fortran gdbm iconv imap ipv6 jpeg kerberos ldap libwww maildir mailwrapper mbox mmx mmxext modules mudflap mysql ncurses nls nptl nptlonly openmp pam pcre png pppd readline reflection samba sasl session snmp spl ssl sysfs tcpd truetype unicode vhosts x86 xml zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl en" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Mart Raudsepp gentoo-dev 2009-09-28 00:48:02 UTC
Actually the library itself depends on desktop-file-utils provided update-desktop-database since some newish version for some g_app_info_* API in GIO.
That could be a PDEPEND though, while tests need at build time (DEPEND) then.
Maybe it should skip that particular test though when update-desktop-database isn't installed
Comment 2 Mart Raudsepp gentoo-dev 2009-09-28 00:50:29 UTC
*** Bug 285823 has been marked as a duplicate of this bug. ***
Comment 3 Mart Raudsepp gentoo-dev 2009-10-07 23:40:16 UTC
desktop-file-utils seems to depend on glib, so indeed we'll need to just not fail the test if update-desktop-database isn't available, but run the test if it is - and consider the PDEPEND for the GIO API
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-11-09 07:07:25 UTC
*** Bug 292439 has been marked as a duplicate of this bug. ***
Comment 5 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2009-11-10 21:47:19 UTC
This bug is present on glib-2.22.2 also. 

This occurs on simply transitioning from a clean install to ACCEPT_KEYWORDS='~amd64' 

There should already be ample information in this bug report, and the duplicates, and the 2.22.2 problem appears identical, so I won't clutter it up with more. 

But here's a `gist` that has all the info in it anyway just in case somebody is curious.

http://gist.github.com/231295  # emerge info, build log and environment. 

Its from a relatively clean virtualbox install. :)
Comment 6 Carmine Paolino 2009-12-06 16:46:43 UTC
Same problem here with an hardened fresh install, I'll atach
Comment 7 Carmine Paolino 2009-12-06 16:50:10 UTC
(In reply to comment #6)
> Same problem here with an hardened fresh install, I'll *attach the build log*
> 

uh I did't know that adding a CC also posts what you have written..

BTW this is my emerge --info:
Portage 2.1.6.13 (hardened/linux/amd64/10.0/no-multilib, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.28-hardened-r9 x86_64)
=================================================================
System uname: Linux-2.6.28-hardened-r9-x86_64-Intel-R-_Core-TM-2_CPU_T7400_@_2.16GHz-with-gentoo-1.12.13
Timestamp of tree: Sun, 06 Dec 2009 13:15:01 +0000
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict test unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://gentoo.osuosl.org/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="R acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri emacs fortran gd gdbm git gmp gpm gsl hardened iconv idn justify lapack minimal mmap mmx modules mudflap mysql ncurses nls nptl nptlonly octave openmp pam pcre pdf perl pic png postgres pppd python readline reflection ruby session smp spl sse sse2 ssl sysfs tcpd threads truetype unicode urandom xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 8 Carmine Paolino 2009-12-06 16:51:11 UTC
Created attachment 212245 [details]
glib-2.20.5-r1 build log
Comment 9 Rainer Koschnick 2009-12-12 15:46:30 UTC
Thanks to this bug I can't install gentoo.  Are there any workaround?
Comment 10 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2009-12-12 23:51:58 UTC
(In reply to comment #9)
> Thanks to this bug I can't install gentoo.  Are there any workaround?
> 

You /could/ disable FEATURES="test".

Alternatively, if you want a workaround for one version of glib, you could try this technique I've been employing as of late: 

http://gist.github.com/255150

Note: this I believe is unsupported use of portage, and the code , while working for me, is also unsupported.
Comment 11 Gilles Dartiguelongue gentoo-dev 2009-12-12 23:56:34 UTC
Also installing most things in gentoo with FEATURES="test" from stage3 will most likely get you circular dependencies which can't be fixed. That's how this bug would be solved too. So saying you can't install gnome because of that bug is just silly.
Comment 12 Attila Stehr 2009-12-14 02:41:50 UTC
(In reply to comment #11)
> Also installing most things in gentoo with FEATURES="test" from stage3 will
> most likely get you circular dependencies which can't be fixed. 

Why  can't they be fixed? What's wrong with stage 3 if stage 1 or 2 - as you say - seem to work well with FEATURES="test"?

I hope you don't want to express that the average user should always keep his hands off from making portage run checks on installed packages?!

Anyway, I'll file a bug report -  circular dependencies should not occur or the package/portage should use a workaround to circumvent that. Of course forcing FEATURES="-test" is not a satisfying solution, IMHO it's hiding a problem instead of solving it!

I guess sometimes building a package with an older, compatible package which it depends on and then later use that package to emerge the other, new one may work in a few cases.

Or (please) make building gentoo from stage-1 possible again. For me it sounds like "circular dependencies won't occur then".
Comment 13 Rémi Cardona gentoo-dev 2009-12-14 08:00:48 UTC
(In reply to comment #12)
> Why  can't they be fixed? What's wrong with stage 3 if stage 1 or 2 - as you
> say - seem to work well with FEATURES="test"?

No they don't either. Not as of today.

> I hope you don't want to express that the average user should always keep his
> hands off from making portage run checks on installed packages?!

tests should be for the power user/sysadmin. Some tests can take up to a day (like berkdb), clearly the average user doesn't want nor need that.

> Anyway, I'll file a bug report -  circular dependencies should not occur or the
> package/portage should use a workaround to circumvent that. Of course forcing
> FEATURES="-test" is not a satisfying solution, IMHO it's hiding a problem
> instead of solving it!

We don't write tests. Upstream does. And some tests require a lot of new dependencies. For example, gstreamer and cairo tests require valgrind. x11-libs/libdrm's tests require to be root without sandbox with _full_ access to the graphics hardware (so much so that no X can run at the same time!).

So obviously, you should take a look at the wide variety of tests before writing this sort of comment. You'll find out that what you ask is just impossible. FEATURES="tests" is a _developer_ feature which should be turned on when you know what you're doing.

> Or (please) make building gentoo from stage-1 possible again. For me it sounds
> like "circular dependencies won't occur then".

It _will_. You just happened to be lucky.
Comment 14 Attila Stehr 2009-12-14 17:03:02 UTC
(In reply to comment #13)
> (In reply to comment #12)

> tests should be for the power user/sysadmin. Some tests can take up to a day
> (like berkdb), clearly the average user doesn't want nor need that.

Well, I am the admin of my PC at home - I guess every other user in this case, is the admin too. As long as I see processes do something I know that the test still run (e.g. using top). As well I guess that a lot gentoo users own more that just one machine, so why shouldn't we be able to wait patienty for tests successfully finish?

> We don't write tests. 

The guys programming coreutils do. In fact people are asked to post problems that occured when "make check" was run!

> Upstream does. And some tests require a lot of new
> dependencies. For example, gstreamer and cairo tests require valgrind.

atti@magic ~ $ emerge -pv valgrind gstreamer cairo; cat /etc/make.conf | grep -i test

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-util/valgrind-3.4.1  5,063 kB
[ebuild   R   ] media-libs/gstreamer-0.10.24  USE="nls test" 0 kB
[ebuild   R   ] x11-libs/cairo-1.8.8  USE="X directfb glitz opengl svg -cleartype -debug -doc -xcb" 0 kB

Total: 3 packages (1 new, 2 reinstalls), Size of downloads: 5,063 kB
FEATURES	="ccache stricter test"
USE="${USE} memlimit mudflap pam ssl test threadsafe tcpd"
atti@magic ~ $ 

> So obviously, you should take a look at the wide variety of tests before
> writing this sort of comment. You'll find out that what you ask is just
> impossible. FEATURES="tests" is a _developer_ feature which should be turned on
> when you know what you're doing.

I know that I'd like tests on software I install pass!
Comment 15 Attila Stehr 2009-12-14 17:07:19 UTC
sorry, my fault:

atti@magic ~ $ emerge -pv gstreamer cairo; cat /etc/make.conf | grep -i test

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/gstreamer-0.10.24  USE="nls test" 0 kB
[ebuild   R   ] x11-libs/cairo-1.8.8  USE="X directfb glitz opengl svg -cleartype -debug -doc -xcb" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB
FEATURES	="ccache stricter test"
USE="${USE} memlimit mudflap pam ssl test threadsafe tcpd"
Comment 16 Rémi Cardona gentoo-dev 2009-12-14 23:19:09 UTC
Well then, since you obviously know more than us, when can we expect your patches?
Comment 17 Attila Stehr 2009-12-15 00:34:57 UTC
Huh? I never said that! I guess you know very well, that I'm no member of the portage team. Tough I have some programming skills (not python btw.) I'm far from being able to enhance portage. Well I haven't taken a look into the sources yet. ;) ... erm, that was a joke ... in order to cheer up the tense atmosphere.

I'm just trying to point at a problem which should be solved. In some cases I was able to solve such circ.deps. by unmerging a blocked package first, then emerging the other and after that the first again. This technique is well known. In fact it's described in the handbook:
http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?full=1#book_part2_chap1__chap3_pre14

BTW: I'm not your enemy - nor you are mine! As well I'm not trying to upset you!
Comment 18 Attila Stehr 2009-12-15 00:53:02 UTC
*blush* Well, that was about blocked packages. But - couldn't something similar be used as workaround? Maybe "remove" a dependency temporarily?!
Comment 19 Gilles Dartiguelongue gentoo-dev 2010-03-09 00:12:26 UTC
*** Bug 282040 has been marked as a duplicate of this bug. ***
Comment 20 Rémi Cardona gentoo-dev 2010-03-28 21:48:20 UTC
*** Bug 311839 has been marked as a duplicate of this bug. ***
Comment 21 Pacho Ramos gentoo-dev 2010-08-14 16:49:59 UTC
*** Bug 332647 has been marked as a duplicate of this bug. ***
Comment 22 Pacho Ramos gentoo-dev 2011-06-06 16:00:11 UTC
+*glib-2.28.8 (06 Jun 2011)
+
+  06 Jun 2011; Pacho Ramos <pacho@gentoo.org> +glib-2.28.8.ebuild:
+  Version bump, also skip tests requiring dev-python/dbus-python and
+  dev-util/desktop-file-utils when they are not available as cannot DEPEND on
+  them due circular dependencies problem (bugs #286629 and #349236).
+