Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 332647 - dev-libs/glib-2.24.1-r1 fails portage tests
Summary: dev-libs/glib-2.24.1-r1 fails portage tests
Status: RESOLVED DUPLICATE of bug 286629
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-13 18:01 UTC by Tom Lane
Modified: 2010-08-14 16:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Complete Build Log. (build-log-glib-2.10.1-r1,455.10 KB, text/plain)
2010-08-13 18:01 UTC, Tom Lane
Details
Emerge --info =dev-libs/glib-2.10.1-r1 (emerge-info-glib-2.10.1-r1,3.38 KB, text/plain)
2010-08-13 18:03 UTC, Tom Lane
Details
System make.conf (make.conf,628 bytes, text/plain)
2010-08-13 18:04 UTC, Tom Lane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Lane 2010-08-13 18:01:24 UTC
dev-libs/glib-2.10.1-r1 fails portage tests stating:

GLib-GIO-WARNING **: Failed to execute child process "update-desktop-database" (No such file or directory)
aborting...
FAIL

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. After emerge failed tried to emerge again and bug did not reproduce.
Comment 1 Tom Lane 2010-08-13 18:01:54 UTC
Created attachment 242815 [details]
Complete Build Log.
Comment 2 Tom Lane 2010-08-13 18:03:55 UTC
Created attachment 242817 [details]
Emerge --info =dev-libs/glib-2.10.1-r1
Comment 3 Tom Lane 2010-08-13 18:04:09 UTC
Created attachment 242819 [details]
System make.conf
Comment 4 Gilles Dartiguelongue gentoo-dev 2010-08-13 20:16:17 UTC

*** This bug has been marked as a duplicate of bug 208047 ***
Comment 5 Gilles Dartiguelongue gentoo-dev 2010-08-13 20:20:48 UTC
erm, not a duplicate, but kinda like the same problem. desktop-file-utils provides the missing binary but it can't be depended on because it would cause a circular dependency. We should probably disable the test with a build use flag or some such.
Comment 6 Pacho Ramos gentoo-dev 2010-08-14 16:49:59 UTC

*** This bug has been marked as a duplicate of bug 286629 ***