Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 284776 - media-sound/pulseaudio-0.9.15-r2 stable request
Summary: media-sound/pulseaudio-0.9.15-r2 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: STABLEREQ
: 284699 (view as bug list)
Depends on: 257399
Blocks: 281827 284661 284780 CVE-2011-3623
  Show dependency tree
 
Reported: 2009-09-13 16:02 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-10-13 17:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 16:02:31 UTC
This would trump bug #284699 _if_ libtool 2.2 gets stabled, since 0.9.9 *does not work with libtool 2.2* and thus you need to get the two of them inside at once.

Have fun!
Diego
Comment 1 Christian Faulhammer (RETIRED) gentoo-dev 2009-09-13 16:35:31 UTC
*** Bug 284699 has been marked as a duplicate of this bug. ***
Comment 2 Olivier Crete (RETIRED) gentoo-dev 2009-09-13 17:14:30 UTC
Can we get 0.9.16 instead? .15 has an annoying bug that makes it not work properly with gstpulsesrc (meaning it breaks pidgin/empathy calling).
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 17:18:58 UTC
Given .17 (fixed .16) was added to the tree today … sure you can have it in 30 days…
Comment 4 Christian Faulhammer (RETIRED) gentoo-dev 2009-09-14 21:13:53 UTC
x86 stable
Comment 5 Jeroen Roovers gentoo-dev 2009-09-15 11:29:27 UTC
Stable for HPPA.
Comment 6 Olivier Crete (RETIRED) gentoo-dev 2009-09-15 16:36:18 UTC
amd64 done
Comment 7 Markus Meier gentoo-dev 2009-09-19 14:06:05 UTC
arm stable
Comment 8 Brent Baude (RETIRED) gentoo-dev 2009-09-27 12:39:46 UTC
ppc64 getting a compile error like so:

mv -f .deps/pulseaudio-daemon-conf.Tpo .deps/pulseaudio-daemon-conf.Po
powerpc64-unknown-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I..    -I../src -I../src -I../src/modules -I../src/modules -I../src/modules/rtp -I../src/modules/rtp -I../src/modules/gconf -I../src/modules/gconf -I../src/modules/bluetooth -I../src/modules/bluetooth -I../src/modules/alsa -I../src/modules/alsa -I../src/modules/raop -pthread -D_POSIX_PTHREAD_SEMANTICS    -DPA_DLSEARCHPATH=\"/usr/lib64/pulse-0.9.15/modules/\" -DPA_DEFAULT_CONFIG_DIR=\"/etc/pulse\" -DPA_BINARY=\"/usr/bin/pulseaudio\" -DPA_SYSTEM_RUNTIME_PATH=\"/var/run/pulse\" -DPA_SYSTEM_CONFIG_PATH=\"/var/lib/pulse\" -DPA_SYSTEM_STATE_PATH=\"/var/lib/pulse\" -DAO_REQUIRE_CAS -DPULSE_LOCALEDIR=\"/usr/share/locale\" -DPA_MACHINE_ID=\"/var/lib/dbus/machine-id\" -O2 -pipe -mcpu=970 -mtune=970 -UNDEBUG -Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option -MT sync_playback-sync-playback.o -MD -MP -MF .deps/sync_playback-sync-playback.Tpo -c -o sync_playback-sync-playback.o `test -f 'tests/sync-playback.c' || echo './'`tests/sync-playback.c
make[3]: *** [vector_test-vector-test.o] Error 1
make[3]: *** Waiting for unfinished jobs....
mv -f .deps/voltest-voltest.Tpo .deps/voltest-voltest.Po
mv -f .deps/close_test-close-test.Tpo .deps/close_test-close-test.Po
mv -f .deps/module_bluetooth_device_la-module-bluetooth-device.Tpo .deps/module_bluetooth_device_la-module-bluetooth-device.Plo
mv -f .deps/pulseaudio-main.Tpo .deps/pulseaudio-main.Po


thoughts?
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-27 12:53:59 UTC
Please open a bug for that and provide the full build log because that is not the error message (it's a parallel build, isn't it?).
Comment 10 nixnut (RETIRED) gentoo-dev 2009-09-27 15:56:06 UTC
ppc stable
Comment 11 Tobias Klausmann gentoo-dev 2009-09-29 17:29:17 UTC
Stable on alph.
Comment 12 Joe Jezak (RETIRED) gentoo-dev 2009-10-02 14:55:57 UTC
I can't reproduce the ppc64 compile error (I tried with a few different use flag combinations). Since someone already marked libtool stable, causing unresolvable deps, I've marked this ppc64 stable as well.
Comment 13 Raúl Porcel (RETIRED) gentoo-dev 2009-10-13 17:29:45 UTC
ia64/sh/sparc stable, closing