Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 284661 - [TRACKER] net-wireless/bluez-4 stabilization
Summary: [TRACKER] net-wireless/bluez-4 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Highest enhancement (vote)
Assignee: Tiziano Müller
URL:
Whiteboard:
Keywords: STABLEREQ, Tracker
Depends on: 279381 283672 284664 284776 284790 284794 284795
Blocks: 234780 281427 288715 300393
  Show dependency tree
 
Reported: 2009-09-12 07:50 UTC by Nirbheek Chauhan (RETIRED)
Modified: 2017-01-19 18:46 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Keyword list for bluez-4 (bluez-4-bump.list,850 bytes, text/plain)
2009-09-21 17:06 UTC, Nirbheek Chauhan (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-12 07:50:52 UTC
Hello bluez maintainers, we need bluez-4 stabilized (atleast x86+amd64) before gnome-2.26 can go stable (for gvfs-1.2.3, totem-2.26.3). Please consider this a priority request since this blocks addition of gnome-2.26 to the gentoo-10.0 LiveDVD (deadline for which is this weekend).

---
Here's packages that need to be stabilized *before* bluez-4 can go stable (to prevent blockers)[1]:

|| ( media-sound/pulseaudio-0.9.15-r2
     media-sound/pulseaudio-0.9.16
     media-sound/pulseaudio-0.9.16-r51 )
|| ( net-libs/libpcap-1.0.0-r2
     net-libs/libpcap-1.0.1_pre20090708
     net-libs/libpcap-1.0.1_pre20090812 )
app-laptop/laptop-mode-tools-1.47-r1
media-video/totem-2.24.4-r1

---
Here's packages that need to go stable *after* bluez-4 (to prevent blockers)[2]:

|| ( app-mobilephone/obexftp-0.23
     app-mobilephone/obexftp-0.23-r1 )
app-mobilephone/obex-data-server-0.4.4
gnome-base/gvfs-1.2.3
net-wireless/bluez-gnome-1.8
net-wireless/libbtctl-0.11.1
net-wireless/ussp-push-0.9-r1
|| ( app-emulation/qemu-0.10.5
     app-emulation/qemu-0.10.6 )


Please advise on how to proceed from here. Thanks in advance.

---
1. These packages have *DEPEND=|| ( net-wireless/bluez net-wireless/bluez-libs ) and atleast one version stable depending only on bluez-libs
2. These pakages have *DEPEND=net-wireless/bluez and atleast one version stable depending on bluez-libs
Comment 1 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-12 07:55:21 UTC
bug 279381 and bug 279384 are broken with bluez-4, and have a version stable. Hence those two also block stabilization of bluez-4

multisync can probably be removed (replaced by opensync). Not sure about blueproxy.
Comment 2 Pacho Ramos gentoo-dev 2009-09-12 11:09:11 UTC
Please note that, when stabling bluez, would be interesting to also hardmask bluez-libs for allowing portage users to get blockers resolved, otherwise, they will get bug 161953 , having to manually handle the blocker, but maybe this was caused by me locally updating to bluez-4 directly :-/
Comment 3 Pacho Ramos gentoo-dev 2009-09-12 11:13:11 UTC
bluez-4 installed this morning and tested without problems under amd64:
net-wireless/bluez-4.39-r1
net-wireless/bluez-gnome-1.8 (still affected by bug 260433 but, at least, it is as broken as current stable and seems to work ok with LD_PRELOAD hack, I will test gnome-bluetooth-2.27* in the near future)
net-wireless/libbtctl-0.11.1
gnome-base/gvfs-1.0.3-r13
app-mobilephone/obexftp-0.23-r1
media-video/totem-2.24.4-r1

My emerge --info:
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-tuxonice-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-tuxonice-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-gentoo-1.12.11.1
Timestamp of tree: Wed, 09 Sep 2009 14:20:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/distfiles"
FEATURES="autoaddcvs ccache cvs distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms strict test test-fail-continue unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/wschlich-testing /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 applet avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdinstall cdr cleartype cli consolekit cracklib crypt css cups daap dbus dell djvu dri dts dvd dvdr dvi eds emboss encode evo exif fam fat ffmpeg firefox flac fortran fuse gdbm gif git glitz gnome gnome-keyring gpm gstreamer gtk hal iconv ieee1394 imagemagick isdnlog java jpeg kdeenablefinal kdehiddenvisibility kpathsea laptop latex libnotify lm_sensors lyx lzma mad mikmod mmx mmxext mono mp3 mp4 mpeg mudflap multilib musicbrainz nautilus ncurses network network-cron networkmanager nls nptl nptlonly ntfs nvidia ogg opengl openmp pam pango pch pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection reiserfs scanner sdl session spell spl sse sse2 ssl ssse3 startup-notification subversion svg sysfs t1lib tcpd threads thunar tiff truetype unicode usb v4l2 vcd vdpau vorbis webkit x264 xattr xcb xml xmp xorg xpm xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 4 Pacho Ramos gentoo-dev 2009-09-12 11:35:02 UTC
This bug depends on bug 257399 because those pulseaudio versions need libtool-2 (bug 281342)

bluez stabilization will also solve bug 234780, that could be added in "blocks" field

Also, maybe this could depend on (trivial) bug 284664 , as, currently, elog information will suggest kde users to use kdebluetooth, that won't work. Maybe, until kdebluetooth4 is added to the tree, temporally all suggestions for kde users could be dropped :-/
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-12 11:44:38 UTC
(In reply to comment #4)
> This bug depends on bug 257399 because those pulseaudio versions need libtool-2
> (bug 281342)

Ew. I wonder if pulseaudio-0.9.9 (current stable) works/can be made to work with bluez-4. No way we can depend on libtool-2 going stable now.

Comment 6 Pacho Ramos gentoo-dev 2009-09-12 13:40:18 UTC
(In reply to comment #5)
> No way we can depend on libtool-2 going stable now.
> 

Well, at least seems that only a problem with libtool's tests are remaining :-/

http://bugs.gentoo.org/show_bug.cgi?id=257399#c12
Comment 7 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-12 13:53:35 UTC
Pulseaudio will not block stabilization of bluez-4 once bug 284699 is done.
Comment 8 Pacho Ramos gentoo-dev 2009-09-12 14:12:25 UTC
(In reply to comment #7)
> Pulseaudio will not block stabilization of bluez-4 once bug 284699 is done.
> 

OK, but please note that gnome-2.26 stabilization will also require a newer pulseaudio, then, I doubt that stabilizing that 0.9.9 version will solve the problem , as will allow bluez-4 to be stable but won't allow gnome-2.26 to do the same :-| (it only postpones the problem)

I can try to send to upstream libtool/autoreconf problem as suggested in http://bugs.gentoo.org/show_bug.cgi?id=257399#c13 :-/, or, maybe, you (or any other connected to IRC channel) could ask for their opinion to any base-system member :-)

Thanks a lot!
Comment 9 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-21 12:46:43 UTC
@lu_zero: Which version of qemu can go stable?
Comment 10 Luca Barbato gentoo-dev 2009-09-21 13:33:42 UTC
qemu .10.6 should be a good candidate I won't think about .11 rcs (since at least rc1 didn't even built)
Comment 11 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-21 17:06:49 UTC
Created attachment 204843 [details]
Keyword list for bluez-4

Here's a list of packages that need to go stable as a part of bluez-4 stabilization. Note: they need to be committed at the same time (starting with bluez-4)
Comment 12 Mart Raudsepp gentoo-dev 2009-09-27 00:12:30 UTC
It doesn't seem we need newer qemu stable for bluez-4 purposes...
The assertion of "This package has *DEPEND=net-wireless/bluez and at least one version stable depending on bluez-libs" is not true for it, older versions don't have bluetooth support enabled that might have needed bluez-libs; when bluez support was added in qemu in gentoo packages it was straight with bluez-4 only.
So we don't need to wait on linux-headers-2.7.29+ to go forward here
Comment 13 Mart Raudsepp gentoo-dev 2009-09-27 00:54:59 UTC
Hopefully this doesn't get wrapped too badly..



Arches, please test and proceed on the following after solving depend bugs (some noted below as well):


Handled in other bugs, need to be done first:

app-laptop/laptop-mode-tools-1.47-r1    amd64          ppc   <--- handled in DEP bug 284794
app-mobilephone/gammu-1.25.0-r1                        ppc   <--- might be safer for ppc, bug 283672  (wammu-0.30.1 there too)
media-sound/pulseaudio-0.9.15-r2        amd64          ppc ppc64 sh sparc     <-- bug 284776 
media-video/totem-2.24.4-r1             amd64 arm(hppa)ppc ppc64(sh)sparc     <-- handled in bug 284795, problematic hppa and sh not included in the bug yet, but will need to do something about it (perhaps the older version works with bluez-4 too and can have its dep adjusted, or package.use.mask)


Handled here:

net-wireless/libbtctl-0.11.1:           amd64     hppa ppc          sparc x86
dev-libs/libnl-1.1-r1:                                           sh sparc     <-- No maintainer OK saught, main arches have it stable already though
net-wireless/bluez-4.39-r2:             amd64 arm hppa ppc ppc64 sh sparc x86 <-- OK (dev-zero@ ack)
app-mobilephone/obex-data-server-0.4.4: amd64     hppa              sparc x86
app-mobilephone/obexftp-0.23-r1:        amd64     hppa ppc          sparc x86
net-wireless/bluez-gnome-1.8:           amd64     hppa              sparc x86
gnome-base/gvfs-1.0.3-r13:              amd64 arm hppa ppc ppc64 sh sparc x86
net-wireless/ussp-push-0.9-r1:                                            x86
net-wireless/blueproxy-1.3:                                               x86 <-- mobile@, newly discovered need, see also bug 279381


Remaining unhandled packages. We could probably assume these are for bluez-3 users only?

net-wireless/bluez-hciemu/bluez-hciemu-1.2.ebuild:DEPEND=">=net-wireless/bluez-libs-2.18" <-- ????
sys-auth/pam_blue/pam_blue-0.9.0.ebuild:	net-wireless/bluez-libs" <-- ???
Comment 14 Mart Raudsepp gentoo-dev 2009-09-27 00:56:01 UTC
Grr, forgot to click the "Add Archs" javascript button :(
Comment 15 Olivier Crete (RETIRED) gentoo-dev 2009-09-27 04:00:45 UTC
amd64 done.. now gets got for gnome 2.26!
Comment 16 Mart Raudsepp gentoo-dev 2009-09-27 12:32:51 UTC
amd64, you forgot bluez-gnome-1.8 and therefore stable amd64 bluetooth users are probably getting awful circular blocker issues.
Comment 17 Olivier Crete (RETIRED) gentoo-dev 2009-09-27 16:18:07 UTC
Arg, sorry, fixed it now
Comment 18 Clemente Aguiar 2009-10-02 08:45:36 UTC
When I try to emerge world I get a blocker.
What should I do?

# emerge -uDNvp world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-libs/libnl-1.1-r1  283 kB
[ebuild  N    ] net-wireless/bluez-4.39-r2  USE="alsa consolekit cups gstreamer usb -debug -doc -old-daemons -test-programs" 975 kB
[uninstall    ] net-wireless/bluez-utils-3.36  USE="alsa cups gstreamer usb -debug -examples -old-daemons -test-programs" 
[blocks b     ] net-wireless/bluez ("net-wireless/bluez" is blocking net-wireless/bluez-libs-3.36, net-wireless/bluez-utils-3.36)
[blocks b     ] net-wireless/bluez-utils ("net-wireless/bluez-utils" is blocking net-wireless/bluez-4.39-r2)
[ebuild     U ] gnome-base/gvfs-1.0.3-r13 [1.0.3-r2] USE="avahi bluetooth cdda gnome hal samba -archive -bash-completion -debug -doc -fuse -gnome-keyring -gphoto2" 900 kB
[ebuild     U ] net-wireless/libbtctl-0.11.1 [0.9.0] USE="-debug -doc" 325 kB
[ebuild   R   ] gnome-base/gnome-volume-manager-2.24.1  USE="consolekit* -automount -debug" 366 kB
[blocks B     ] net-wireless/bluez ("net-wireless/bluez" is blocking net-wireless/bluez-libs-3.36, net-wireless/bluez-utils-3.36)
[blocks B     ] net-wireless/bluez-libs ("net-wireless/bluez-libs" is blocking net-wireless/bluez-4.39-r2)

Total: 5 packages (2 upgrades, 2 new, 1 reinstall, 1 uninstall), Size of downloads: 2,847 kB
Conflict: 4 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'net-wireless/bluez-libs-3.36', 'nomerge') pulled in by
    >=net-wireless/bluez-libs-3 required by ('installed', '/', 'media-sound/pulseaudio-0.9.15-r2', 'nomerge')
    net-wireless/bluez-libs required by ('installed', '/', 'dev-libs/openobex-1.5', 'nomerge')
    net-wireless/bluez-libs required by ('installed', '/', 'net-libs/libpcap-1.0.0-r2', 'nomerge')
    (and 2 more)

  ('ebuild', '/', 'net-wireless/bluez-4.39-r2', 'merge') pulled in by
    net-wireless/bluez required by ('ebuild', '/', 'gnome-base/gvfs-1.0.3-r13', 'merge')
    >=net-wireless/bluez-4 required by ('ebuild', '/', 'net-wireless/libbtctl-0.11.1', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



# emerge --info

Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6750_@_2.66GHz-with-gentoo-1.12.11.1
Timestamp of tree: Thu, 01 Oct 2009 22:45:01 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=nocona -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=nocona -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="pt_PT.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="pt_PT pt en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/java-overlay /usr/local/portage"
SYNC="rsync://mero.madeiratecnopolo.pt/gentoo-portage"
USE="X a52 aac acl acpi ads alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdda cddb cdio cdparanoia cdr cli consolekit cracklib crypt cups dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif gnome gnome-print gpm gstreamer gtk hal iconv id3tag ipv6 isdnlog ithreads java jpeg kerberos lame lcms ldap libnotify live logrotate mad matroska mikmod mmx modules mp3 mp4 mpeg mudflap multilib musepac musepack nautilus ncurses network nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pcre pdf perl png ppds pppd pulseaudio python qt3support quicktime readline reflection samba sdl session smp spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd theora threads thunar tiff truetype tta unicode usb vorbis wavpack wma wmf x264 xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pt_PT pt en" USERLAND="GNU" VIDEO_CARDS="nvidia vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 19 Marcello Magaldi 2009-10-02 08:53:46 UTC
(In reply to comment #18)
> When I try to emerge world I get a blocker.
> What should I do?
> 
> # emerge -uDNvp world
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [ebuild  N    ] dev-libs/libnl-1.1-r1  283 kB
> [ebuild  N    ] net-wireless/bluez-4.39-r2  USE="alsa consolekit cups gstreamer
> usb -debug -doc -old-daemons -test-programs" 975 kB
> [uninstall    ] net-wireless/bluez-utils-3.36  USE="alsa cups gstreamer usb
> -debug -examples -old-daemons -test-programs" 
> [blocks b     ] net-wireless/bluez ("net-wireless/bluez" is blocking
> net-wireless/bluez-libs-3.36, net-wireless/bluez-utils-3.36)
> [blocks b     ] net-wireless/bluez-utils ("net-wireless/bluez-utils" is
> blocking net-wireless/bluez-4.39-r2)
> [ebuild     U ] gnome-base/gvfs-1.0.3-r13 [1.0.3-r2] USE="avahi bluetooth cdda
> gnome hal samba -archive -bash-completion -debug -doc -fuse -gnome-keyring
> -gphoto2" 900 kB
> [ebuild     U ] net-wireless/libbtctl-0.11.1 [0.9.0] USE="-debug -doc" 325 kB
> [ebuild   R   ] gnome-base/gnome-volume-manager-2.24.1  USE="consolekit*
> -automount -debug" 366 kB
> [blocks B     ] net-wireless/bluez ("net-wireless/bluez" is blocking
> net-wireless/bluez-libs-3.36, net-wireless/bluez-utils-3.36)
> [blocks B     ] net-wireless/bluez-libs ("net-wireless/bluez-libs" is blocking
> net-wireless/bluez-4.39-r2)
> 
> Total: 5 packages (2 upgrades, 2 new, 1 reinstall, 1 uninstall), Size of
> downloads: 2,847 kB
> Conflict: 4 blocks (2 unsatisfied)
> 
>  * Error: The above package list contains packages which cannot be
>  * installed at the same time on the same system.
> 
>   ('installed', '/', 'net-wireless/bluez-libs-3.36', 'nomerge') pulled in by
>     >=net-wireless/bluez-libs-3 required by ('installed', '/',
> 'media-sound/pulseaudio-0.9.15-r2', 'nomerge')
>     net-wireless/bluez-libs required by ('installed', '/',
> 'dev-libs/openobex-1.5', 'nomerge')
>     net-wireless/bluez-libs required by ('installed', '/',
> 'net-libs/libpcap-1.0.0-r2', 'nomerge')
>     (and 2 more)
> 
>   ('ebuild', '/', 'net-wireless/bluez-4.39-r2', 'merge') pulled in by
>     net-wireless/bluez required by ('ebuild', '/', 'gnome-base/gvfs-1.0.3-r13',
> 'merge')
>     >=net-wireless/bluez-4 required by ('ebuild', '/',
> 'net-wireless/libbtctl-0.11.1', 'merge')
> 
> 


try to unmerge bluez-libs 
Comment 20 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-10-02 10:18:13 UTC
(In reply to comment #18)
> When I try to emerge world I get a blocker.
> What should I do?
> 

Bugzilla is not for support, check on forums and/or IRC

[snip]
> For more information about Blocked Packages, please refer to the following
> section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
> 
> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
> 

Or, you could read the link given by portage...
Comment 21 Clemente Aguiar 2009-10-02 14:27:02 UTC
Just for your information, I have solved the problem.

The problem was with gnome-bluetooth.
Version 0.9.1 pulls bluez-libs and version 0.12.0 was masked by: ~AMD64 keyword.

So I had to unmask version 0.12.0 of this package, then

emerge --unmerge libbtctl gnome-bluetooth gvfs bluez-libs bluez-utils

and then

emerge -uDN world

Comment 22 Markus Meier gentoo-dev 2009-10-11 16:16:41 UTC
arm stable
Comment 23 Markus Meier gentoo-dev 2009-10-11 16:24:24 UTC
x86 stable
Comment 24 Alex Buell 2009-10-11 18:52:40 UTC
Please stabilise net-wireless/gnome-bluetooth-0.12.0 as it's needed!! 
Comment 25 Marcello Magaldi 2009-10-12 11:33:53 UTC
(In reply to comment #24)
> Please stabilise net-wireless/gnome-bluetooth-0.12.0 as it's needed!! 
> 

Yes , it is needed : gnome-bluetooth-0.9 (last stable on x86) still require old bluez-libs and this result on a blocking bug while revdep-rebuild.
Comment 26 Mart Raudsepp gentoo-dev 2009-10-13 01:09:16 UTC
To me the question is, what needs gnome-bluetooth-0.*?
Comment 27 Denilson Sá Maia 2009-10-13 01:15:06 UTC
(In reply to comment #26)
> To me the question is, what needs gnome-bluetooth-0.*?

It has a bluetooth file transfer applet, that works as an obex server allows receiving files via obex push. I use that to transfer text notes from mobile phone to PC.

Unless there is something else that works that way, then the users still need gnome-bluetooth.
Comment 28 Mart Raudsepp gentoo-dev 2009-10-13 01:45:04 UTC
(In reply to comment #27)
> It has a bluetooth file transfer applet, that works as an obex server allows
> receiving files via obex push. I use that to transfer text notes from mobile
> phone to PC.

If I understand it correctly, that functionality is available with bluez-gnome-1.8 applet, which has a "Browse files on device..." under right click that lets you make an obex connection and then show and transfer files with nautilus or other things that use GIO and gvfs.

> Unless there is something else that works that way, then the users still need
> gnome-bluetooth.
> 

Lets track this in bug 288715 then, which is a request to stabilize it
Comment 29 nixnut (RETIRED) gentoo-dev 2009-10-24 11:13:23 UTC
ppc stable
Comment 30 Mart Raudsepp gentoo-dev 2009-10-24 11:20:18 UTC
hppa, ppc64, sh and sparc seem still left, so no marking FIXED..
Comment 31 Raúl Porcel (RETIRED) gentoo-dev 2009-11-21 15:23:08 UTC
sh/sparc keywords dropped and bluetooth use.masked
Comment 32 Jeroen Roovers gentoo-dev 2010-01-14 01:29:25 UTC
Stable for HPPA.
Comment 33 Pacho Ramos gentoo-dev 2010-02-01 20:24:39 UTC
KEYWORDS="amd64 arm hppa ppc ppc64 x86"

All stable, closing then