Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250712 - media-video/gephex-0.4.4 version bump (or 0.4.3 removal)
Summary: media-video/gephex-0.4.4 version bump (or 0.4.3 removal)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: PMASKED
: 251268 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-12-12 16:08 UTC by Samuli Suominen
Modified: 2009-03-23 14:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild for 0.4.4. (gephex-0.4.4.ebuild,1.57 KB, text/plain)
2008-12-12 16:09 UTC, Samuli Suominen
Details
Missing includes for GCC 4.3. (gephex-0.4.4-gcc43.patch,1.89 KB, patch)
2008-12-12 16:10 UTC, Samuli Suominen
Details | Diff
Fix configure.ac to find libmpeg3. (gephex-0.4.4-libmpeg3.patch,618 bytes, patch)
2008-12-12 16:10 UTC, Samuli Suominen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2008-12-12 16:08:11 UTC
I was trying to bump gephex to 0.4.4, but..

/bin/sh ../../../libtool --tag=CC   --mode=link i686-pc-linux-gnu-gcc  -fpic -O2 -march=athlon-xp -pipe -shared -fpic -Wl,-O1,--as-needed -o chromakeymodule.so chromakeymodule-chromakeymodule_auto.o chromakeymodule-chromakeymodule.o  
libtool: link: i686-pc-linux-gnu-gcc -fpic -O2 -march=athlon-xp -pipe -fpic -Wl,-O1 -Wl,--as-needed -o chromakeymodule.so chromakeymodule-chromakeymodule_auto.o chromakeymodule-chromakeymodule.o 
/usr/lib/gcc/i686-pc-linux-gnu/4.3.2/../../../crt1.o: In function `_start':
(.text+0x18): undefined reference to `main'
collect2: ld returned 1 exit status
make[4]: *** [chromakeymodule.so] Error 1

Other issues..

- It has old bundled FFMPEG.
- It needs GCC 4.3 patching (attaching one here, might be unfinished)
- It needs patching to find libmpeg3 (attaching one here, might be unfinished)
Comment 1 Samuli Suominen gentoo-dev 2008-12-12 16:09:25 UTC
Created attachment 175114 [details]
Ebuild for 0.4.4.

Might want to simply --without-FFMPEG because bundled junk blows.
Comment 2 Samuli Suominen gentoo-dev 2008-12-12 16:10:00 UTC
Created attachment 175115 [details, diff]
Missing includes for GCC 4.3.
Comment 3 Samuli Suominen gentoo-dev 2008-12-12 16:10:32 UTC
Created attachment 175116 [details, diff]
Fix configure.ac to find libmpeg3.
Comment 4 Samuli Suominen gentoo-dev 2008-12-12 16:13:09 UTC
It also needs libXv as a dep wrt bug 239799. At least build-time.
Comment 5 Samuli Suominen gentoo-dev 2008-12-12 16:23:37 UTC
So as said, this is a work in progress but it's a starting point for someone.
I lost my intrest. Current version 0.4.3 also fails with GCC 4.3.2.
Comment 6 Samuli Suominen gentoo-dev 2008-12-12 16:36:54 UTC
In fact, because the current version and the new version both are incompatible with GCC 4.3, I'm requesting removal of this package. CCing treecleaners.

You can see the justifications in this bug.
Comment 7 Samuli Suominen gentoo-dev 2008-12-12 16:41:23 UTC
18:13 <@aballier> ssuominen: (gephex error) seems its missing the -shared option at link
18:14 <@aballier> check if you've not been overiding it with your ldflags

but as said I totally lost intrest in the package for now.
Comment 8 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-15 20:20:02 UTC
*** Bug 251268 has been marked as a duplicate of this bug. ***
Comment 9 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-15 20:24:20 UTC
+# Peter Alfredsen <loki_val@gentoo.org>
+# Masking for removal in 30 days.
+# Fails to build with gcc-4.3, bug 250712
+media-video/gephex
+
On behalf of video herd.
Comment 10 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-23 14:35:39 UTC
Gone