Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 248053 - kde-misc/yakuake-2.9.4-r1 wants to pull in monolithic qt4
Summary: kde-misc/yakuake-2.9.4-r1 wants to pull in monolithic qt4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
Keywords: InVCS
: 248055 (view as bug list)
Depends on:
Blocks: 210077 216231
  Show dependency tree
Reported: 2008-11-21 20:33 UTC by Andrei Slavoiu
Modified: 2008-12-05 02:49 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

fix bug in || ( ) dependency handling wrt blockers (blocker_or.patch,891 bytes, patch)
2008-11-22 01:54 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Slavoiu 2008-11-21 20:33:51 UTC
starting with today, the already installed kde-misc/yakuake wants to install x11-libs/qt-4.3.5 even though I have the split qt installed.

Reproducible: Always

Steps to Reproduce:
emerge -ptv yakuake

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ] kde-misc/yakuake-2.9.4-r1  USE="-kdeprefix" LINGUAS="ro -ca -cs -da -de -el -en_GB -fr -ga -gl -ja -ko -nds -nl -pt -pt_BR -ru -sv -tr -uk" 0 kB
[ebuild  NS   ]  x11-libs/qt-4.3.5 [3.3.8b] USE="accessibility cups dbus doc examples gif glib jpeg mng opengl pch png qt3support sqlite sqlite3 ssl tiff zlib -debug (-firebird) -mysql -nas -nis -odbc -postgres -xinerama" INPUT_DEVICES="-wacom" 0 kB
[ebuild  NS   ]   dev-db/sqlite-2.8.16-r4 [3.6.2] USE="doc nls -tcl" 0 kB
[ebuild  N    ]    dev-lang/tcl-8.4.19  USE="threads -debug" 3,573 kB
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-sql-4.4.2, x11-libs/qt-gui-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)
[blocks B     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.5)

Total: 4 packages (1 new, 2 in new slots, 1 reinstall), Size of downloads: 3,573 kB
Conflict: 2 blocks (2 unsatisfied)
Comment 1 Andrei Slavoiu 2008-11-21 20:34:27 UTC
Portage 2.2_rc14 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r3 x86_64)
System uname: Linux-2.6.27-gentoo-r3-x86_64-AMD_Phenom-tm-_9350e_Quad-Core_Processor-with-glibc2.2.5             
Timestamp of tree: Fri, 21 Nov 2008 19:31:01 +0000                                                               
ccache version 2.4 [enabled]                                                                                     
app-shells/bash:     3.2_p39                                                                                     
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -ggdb -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -ggdb -O2 -pipe"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="buildpkg ccache collision-protect distlocks fixpackages parallel-fetch preserve-libs preserved-rebuild protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch userpriv usersandbox"
LINGUAS="ro en eo"
MAKEOPTS="-j6 -l9"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
USE="3dnow 3dnowext 3ds 7zip X a52 aac aalib accessibility acl acpi aiglx akode alsa amd64 amr amrnb amrwb apache2 asf aspell audiofile bash-completion berkdb branding bzip2 caps captury cddb cdinstall cdparanoia cdr cisco clamav cracklib crypt css cups curl dba dbus dga djvu dmi doc dpms dri dts dv dvd dvdr dvdread eds emboss encode erandom evo examples exif expat fam fbcon ffmpeg firefox flac fontconfig fortran ftp gcj gd gdbm geoip gif glib glut gmp gnokii gnutls gpm graphviz gsm hal hddtemp hou htmlhandbook iconv id3tag idn imagemagick imlib inotify ipv6 isdnlog jadetex java javascript jingle jpeg jpeg2k justify kde kdeenablefinal kdehiddenvisibility kerberos kig-scripting kipi kqemu lame lcms ldap libcacalibclamav libgcrypt libnotify libsamplerate libssh2 libwww live lm_sensors lua lzo mad maildir matroska mbrola metric midi mikmod mjpeg mmap mmx mmxext mng mp3 mp4 mplayer mppe-mppc mudflap multilib musepack musicbrainz mythtv ncurses network nls nodrm nowin nptl nptlonly offensive ofx ogg openal openexr opengl openmp pam pch pcre pdf perl php physfs plugins png posix povray ppds pppd pth python qt qt3 qt3support qt4 quicktime rdesktop readline reflection reiserfs rtc ruby samba sasl schroedinger sdl session slang sms sockets sou sound sox speex spell spl sqlite sqlite3 sse sse2 ssl startup-notification subversion svg symlink sysfs syslog sysvipc tcpd theora threads tidy tiff truetype tunepimp unicode usb vhook videos visualization vnc voice vorbis wifi wmf x264 xattr xcb xcomposite xine xml xml2 xmlrpc xmp xorg xpm xsl xv xvid xvmc yahoo zeroconf zip zlib zvbi" ALSA_CARDS="bt87x via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ro en eo" LIRC_DEVICES="kworld" USERLAND="GNU" VIDEO_CARDS="radeon radeonhd vesa"
Comment 2 Graham Murray 2008-11-21 20:43:46 UTC
As do lots of other packages, including amarok-1.90-r1, gtk-engines-1.1. Every time, I tried to resolve the conflict between qt-4.3.5 and qt-4.4.2, another package tried to pull in the monolithic one.
Comment 3 Andrei Slavoiu 2008-11-21 22:22:18 UTC
(In reply to comment #2)
> As do lots of other packages, including amarok-1.90-r1, gtk-engines-1.1. Every
> time, I tried to resolve the conflict between qt-4.3.5 and qt-4.4.2, another
> package tried to pull in the monolithic one.

You're right, it will happen with any package that has a version different then 4.1* as kde4-base.eclass will add the monolithic qt as an alternative to the modular one in the list of dependencies for packages older then 4.1 (they probably forgot that packages in kde-misc also use that eclass). What I don't understand is why portage chooses to use the monolithic alternative when the modular packages are installed. And why 4.3.5 when there is a 4.4.2 monolithic ebuild and the dependency added by kde4-base.eclass is >=x11-libs/qt-4.3.3:4?
Comment 4 Zac Medico gentoo-dev 2008-11-22 01:50:14 UTC
It seems that this bug is the result of a portage bug involving interaction between blockers and || ( ) dependencies. It was triggered by this commit which added a blocker inside of an || ( ) dependency:
Comment 5 Zac Medico gentoo-dev 2008-11-22 01:54:58 UTC
Created attachment 172801 [details, diff]
fix bug in || ( ) dependency handling wrt blockers

If this patch is saved as /tmp/blocker_or.patch, then it can be applied as follows:

  patch /usr/lib/portage/pym/portage/ /tmp/blocker_or.patch

If this patch doesn't solve the problem then in means that you are experiencing a case of bug 1343. In that case, you should mask qt-4.3 in /etc/portage/package.mask.
Comment 6 Zac Medico gentoo-dev 2008-11-22 05:57:38 UTC
This is fixed in 2.2_rc15.
Comment 7 Jan Kundrát (RETIRED) gentoo-dev 2008-11-22 08:56:25 UTC
*** Bug 248055 has been marked as a duplicate of this bug. ***