Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 210077 - [TRACKER] sys-apps/portage-2.2
Summary: [TRACKER] sys-apps/portage-2.2
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Conceptual/Abstract Ideas (show other bugs)
Hardware: All All
: High normal with 11 votes (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: Tracker
Depends on: 62207 208946 210501 213540 213592 219251 225429 226307 228075 228489 228595 228939 228977 229033 230053 230245 230249 230483 230525 230579 230587 230975 231358 231382 231455 231464 232924 232985 233077 233103 233137 233165 233253 233296 233421 233458 233487 233635 233735 234100 234157 234301 234478 235250 235542 235642 236021 236207 236683 236714 236748 236786 237840 238251 238766 238957 239015 239068 239070 239272 239471 239529 240022 240295 240684 241100 241118 241132 241204 241808 241906 242304 243022 243030 243178 243220 243224 244485 244792 244975 245231 245356 245358 245362 245422 245661 245716 245779 245932 246451 246667 246821 246853 247370 247548 247625 247776 248053 248059 248464 248469 248782 249805 250020 250148 250166 250212 250469 250902 251591 251616 251664 251976 252167 252243 252304 252354 252374 252562 252572 252727 252840 252995 253002 253210 253467 253563 253745 253800 253904 254114 254421 254825 255101 255358 256289 256616 257660 258433 258773 259124 259697 259994 261082 261377 261670 261675 261835 261852 261992 262012 262096 262132 262211 262428 262485 262647 263081 263370 264291 264434 264494 265034 265111 265267 265747 265768 265909 266211 266454 266493 267104 267468 267810 267860 267972 268398 268929 270040 270866 270933 270953 271416 271551 272000 273020 273099 273644 274279 274497 274742 274870 275047 275217 275532 275796 275821 275901 275945 275947 276264 276813 276866 277537 277544 277619 278368 278729 280521 280690 281133 281355 281964 282808 283292 283357 283358 283513 283795 285767 286522 287333 287869 287870 311253 335439 339231 341299 344179 387059 433704 433964
Blocks: 472632
  Show dependency tree
 
Reported: 2008-02-14 07:42 UTC by Zac Medico
Modified: 2013-08-13 00:15 UTC (History)
27 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
spamassassin-3.2.4.build.log (spamassassin-3.2.4.build.log,55.89 KB, text/plain)
2008-04-05 05:17 UTC, Xavian-Anderson Macpherson
Details
portage.info_2008.04.04.14:13:50 (portage.info_2008.04.04.14:13:50,18.81 KB, text/plain)
2008-04-05 05:18 UTC, Xavian-Anderson Macpherson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2008-02-14 07:42:57 UTC
Mark bugs fixed since 2.1.x as blockers of this bug.
Comment 1 Xavian-Anderson Macpherson 2008-03-30 07:14:38 UTC
I keep getting this, even after I've run the command specified.
---------------------------------------------------------------------------------

!!! existing preserved libs:
>>> package: dev-lang/tk-8.5.1
 *  - /usr/lib64/libtk8.4.so
>>> package: dev-lang/tcl-8.5.1
 *  - /usr/lib64/libtcl8.4.so
>>> package: sci-libs/cln-1.2.0
 *  - /usr/lib64/libcln.so.4
 *  - /usr/lib64/libcln.so.4.0.2
Use emerge @preserved-rebuild to rebuild packages using these libraries
Comment 2 Xavian-Anderson Macpherson 2008-04-05 05:17:35 UTC
Created attachment 148697 [details]
spamassassin-3.2.4.build.log
Comment 3 Xavian-Anderson Macpherson 2008-04-05 05:18:09 UTC
Created attachment 148698 [details]
portage.info_2008.04.04.14:13:50
Comment 4 Xavian-Anderson Macpherson 2008-04-05 05:19:33 UTC
Sorry, I put these in the wrong bug!

Shingoshi
Comment 5 Zac Medico gentoo-dev 2008-10-05 18:48:41 UTC
*** Bug 240022 has been marked as a duplicate of this bug. ***
Comment 6 MaratIK 2009-03-13 21:14:26 UTC
What about "profiles/package.mask"?

> # Zac Medico <zmedico@gentoo.org> (05 Jan 2009)
> # Portage 2.2 is masked due to known bugs in the
> # package sets and preserve-libs features.
> >=sys-apps/portage-2.2_pre

Are there any known open bugs related to package sets and preserve-libs features?
Comment 7 Zac Medico gentoo-dev 2009-03-17 20:55:30 UTC
(In reply to comment #6)
> Are there any known open bugs related to package sets and preserve-libs
> features?

Yes, see bug 253802.
Comment 8 DEMAINE Benoît-Pierre, aka DoubleHP 2009-07-04 16:37:16 UTC
(In reply to comment #6)

according to
http://bugs.gentoo.org/buglist.cgi...
bug 215242 and bug 229695 

***

I am using 2.2_rc33 since a bit of time, and I am pretty happy with it. When will it become stable ?
Comment 9 Oschtan 2009-10-11 06:34:51 UTC
Stable or never?
Comment 10 Zac Medico gentoo-dev 2009-10-18 21:18:49 UTC
The preserve-libs and package sets features in portage-2.2_rc are still quite unstable. See bug 144480, bug 240323, and bug 253802.
Comment 11 DEMAINE Benoît-Pierre, aka DoubleHP 2010-09-22 11:04:06 UTC
I think this bug should be blocked/depend on bug 240323
Comment 12 Oschtan 2010-11-02 17:33:30 UTC
Portage-2.2 sawed completely?
==============================
eix sys-apps/portage
[D] sys-apps/portage
     Available versions:  [P]2.1.6.7 2.1.6.13 2.1.7.17 2.1.8.3 (~)2.1.9.22 (~)2.1.9.23 (~)2.1.9.24 **2.2_rc67 **2.2.0_alpha1 **2.2.0_alpha2 **2.2.0_alpha3{tbz2} **9999 {build doc epydoc +ipc linguas_pl python3 selinux}                                                                                                
     Installed versions:  2.2.0_alpha3{tbz2}(14:13:07 01.11.2010)(ipc python3 -build -doc -epydoc -linguas_pl -selinux)
     Homepage:            http://www.gentoo.org/proj/en/portage/index.xml
     Description:         Portage is the package management and distribution system for Gentoo
Comment 13 Zac Medico gentoo-dev 2010-11-03 00:36:10 UTC
(In reply to comment #12)
> Portage-2.2 sawed completely?

It's still available, however it's masked by KEYWORDS for most profiles. You can unmask it like this:

  echo "=sys-apps/portage-2.2* **" >> /etc/portage/package.keywords
Comment 14 Oschtan 2010-12-29 06:43:23 UTC
sys-apps/portage-2.2.0_alpha10 ... portage removed from the profile "system"? Or does it refer to the bug? And in the world it is not added when you try to add it there.
Comment 15 Zac Medico gentoo-dev 2010-12-29 07:12:36 UTC
(In reply to comment #14)
> sys-apps/portage-2.2.0_alpha10 ... portage removed from the profile "system"?
> Or does it refer to the bug? And in the world it is not added when you try to
> add it there.

System packages are automatically excluded from the world file. You can edit /var/lib/portage/world manually if you want them added.

Please don't post random questions/reports on this bug. Either post questions on forums.gentoo.org or file a new bug report if necessary.