Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 240022 - suppress preserved libs entries for symlinks
Summary: suppress preserved libs entries for symlinks
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All All
: High trivial (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: preserve-libs 210077
  Show dependency tree
 
Reported: 2008-10-05 17:49 UTC by Fabian Groffen
Modified: 2008-10-09 21:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to make preserved-libs output shorter (preserved-libs-quieter.patch,723 bytes, patch)
2008-10-05 17:49 UTC, Fabian Groffen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Groffen gentoo-dev 2008-10-05 17:49:02 UTC
Portage currently shows output like so:

!!! existing preserved libs:
>>> package: net-misc/neon-0.26.4
 *  - /Library/Gentoo/usr/lib/libneon.so.27
 *      used by /Library/Gentoo/usr/bin/svn (dev-util/subversion-1.5.2)
 *      used by /Library/Gentoo/usr/bin/svnsync (dev-util/subversion-1.5.2)
 *      used by /Library/Gentoo/usr/lib/libsvn_ra_neon-1.so.0.0.0 (dev-util/subversion-1.5.2)
 *  - /Library/Gentoo/usr/lib/libneon.so.27.1.2
 *      used by /Library/Gentoo/usr/bin/svn (dev-util/subversion-1.5.2)
 *      used by /Library/Gentoo/usr/bin/svnsync (dev-util/subversion-1.5.2)
 *      used by /Library/Gentoo/usr/lib/libsvn_ra_neon-1.so.0.0.0 (dev-util/subversion-1.5.2)

This is a bit redundant, since libneon.so.27.1.2 and libneon.so.27 are the same object.

Reproducible: Always



Expected Results:  
only show "used by" once for each real file.

I will attach a patch which implements the desired behaviour.
Comment 1 Fabian Groffen gentoo-dev 2008-10-05 17:49:58 UTC
Created attachment 167347 [details, diff]
patch to make preserved-libs output shorter

output with this patch:

!!! existing preserved libs:
>>> package: net-misc/neon-0.26.4
 *  - /Library/Gentoo/usr/lib/libneon.so.27.1.2
 *  - /Library/Gentoo/usr/lib/libneon.so.27
 *      used by /Library/Gentoo/usr/bin/svn (dev-util/subversion-1.5.2)
 *      used by /Library/Gentoo/usr/bin/svnsync (dev-util/subversion-1.5.2)
 *      used by /Library/Gentoo/usr/lib/libsvn_ra_neon-1.so.0.0.0 (dev-util/subversion-1.5.2)
Comment 2 Zac Medico gentoo-dev 2008-10-05 18:48:41 UTC
Thanks, this is in svn r11636.

*** This bug has been marked as a duplicate of bug 210077 ***
Comment 3 Zac Medico gentoo-dev 2008-10-05 18:49:08 UTC
oops, not a duplicate...
Comment 4 Zac Medico gentoo-dev 2008-10-09 21:42:58 UTC
This is fixed in 2.2_rc12.