Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 238694 (gtk2.14-compat) - [TRACKER] x11-libs/gtk+-2.14.3 && dev-libs/glib-2.18.1 breakage
Summary: [TRACKER] x11-libs/gtk+-2.14.3 && dev-libs/glib-2.18.1 breakage
Status: RESOLVED FIXED
Alias: gtk2.14-compat
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: Tracker
Depends on: 226405 231823 233870 238698 238734 238737 238837 238872 238874 247707
Blocks: gnome2.24 gtk2.14-stable
  Show dependency tree
 
Reported: 2008-09-25 21:09 UTC by Rémi Cardona
Modified: 2009-01-07 14:01 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2008-09-25 21:09:25 UTC
Tracker bug for build breakage induced by gtk+ 2.14 (required for Gnome 2.24)
Comment 1 Mart Raudsepp gentoo-dev 2008-09-28 05:03:57 UTC
When it's first pass stabilization time, at least >=dev-util/intltool-0.40.4 and >=gnome-base/libgnomeui-2.24.0 need to go stable at the same time as well. libgnomeui just removes the filechooser backend modules (and gtk3 compatibility preparations), because the semi-private GtkFileSystem API doesn't exist anymore in this form - has to go stable at the same time primarily because libgnomeui-2.22 doesn't build anymore due to no GtkFileSystem.
intltool-0.40 is just a dep of new libgnomeui
Comment 2 Mart Raudsepp gentoo-dev 2008-09-28 18:49:06 UTC
gtk+-2.14 is now unmasked. Hopefully not too many additional broken packages turn up :P
Comment 3 Serkan Kaba (RETIRED) gentoo-dev 2008-10-05 11:26:54 UTC
Please consider dev-java/java-gnome-4.0.7-r2 in stabilization list because the current stable (4.0.7) has a crasher bug with 2.14 which is fixed in this revision.
Comment 4 Hans de Graaff gentoo-dev 2008-10-26 14:14:36 UTC
I've just filed #244471 to stabilize ruby-gtk2+-0.16.0-r4.
Comment 5 Pacho Ramos gentoo-dev 2008-12-15 12:31:29 UTC
Current stable gnome-sharp (and related) 2.16 won't work with gtk+-2.14, then. maybe all new gnome/gtk-sharp stuff will need to be stabilized with new gtk+/glib (I can open a separate bug report for gnome-sharp not compiling if you want)
Comment 6 Mart Raudsepp gentoo-dev 2009-01-07 02:14:56 UTC
Yes, please a new bug blocking 253934 as I'm closing this one now, as the known and filed stuff is all fixed.
Comment 7 Pacho Ramos gentoo-dev 2009-01-07 14:01:18 UTC
(In reply to comment #6)
> Yes, please a new bug blocking 253934 as I'm closing this one now, as the known
> and filed stuff is all fixed.
> 

New gtk-sharp will require mono-2, then, I think that bug 234305 is the one that should block bug 253934 (sorry for the inconvenience if I am wrong)