Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 230389 - pidgin-2.4.2 fails with icq (icq protocoll is to old)
Summary: pidgin-2.4.2 fails with icq (icq protocoll is to old)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
: 230399 230475 230479 230497 230503 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-01 19:05 UTC by Steffen 'j0inty' Stollfuß
Modified: 2008-07-18 09:32 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The fix for the oscar.h (pidgin-oscar-icq-versionfix.patch,441 bytes, patch)
2008-07-01 19:06 UTC, Steffen 'j0inty' Stollfuß
Details | Diff
The new ebuild file (pidgin-2.4.2-r1.ebuild,5.82 KB, text/plain)
2008-07-01 19:08 UTC, Steffen 'j0inty' Stollfuß
Details
modified patch version for pidgin 2.4.2 (pidgin-2.4.2-oscar-icq-versionfix.patch,441 bytes, patch)
2008-07-01 20:59 UTC, bluescream
Details | Diff
Same fix, but for pidgin 2.3.1 (stable x86) (pidgin-2.3.1-icq_protocol_version_fix.patch,457 bytes, patch)
2008-07-01 21:14 UTC, Heiko Rosemann
Details | Diff
ebuild file for 2.3.1-r1 (pidgin-2.3.1-r1.ebuild,5.73 KB, text/plain)
2008-07-01 21:15 UTC, Heiko Rosemann
Details
with modified patch (pidgin-2.4.2-r2.ebuild,5.81 KB, text/plain)
2008-07-18 09:29 UTC, Alexey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen 'j0inty' Stollfuß 2008-07-01 19:05:10 UTC
Hi,

Since today my pidgin stops to connect to ICQ network. The problem is that ICQ has change something at their protocol.

After a look at developer.pidgin.im I found a patch that fix the problem for me.

I will attach all need files.

j0inty

Reproducible: Always

Steps to Reproduce:
1.Emerge <=pidgin-2.4.2
2.Start it
3.

Actual Results:  
Fail to connect to the ICQ network.

Expected Results:  
A successfull connection ;)
Comment 1 Steffen 'j0inty' Stollfuß 2008-07-01 19:06:37 UTC
Created attachment 159143 [details, diff]
The fix for the oscar.h
Comment 2 Steffen 'j0inty' Stollfuß 2008-07-01 19:08:36 UTC
Created attachment 159145 [details]
The new ebuild file
Comment 3 Robert Bombka 2008-07-01 20:02:29 UTC
(In reply to comment #2)
> Created an attachment (id=159145) [edit]
> The new ebuild file
> 

Works, thanks a lot mate.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2008-07-01 20:18:33 UTC
Someone able to add new ICQ-contacts to your buddy list with this patch? I can't but I'm not sure if this is related to this bug. OTOH with this patch I can login to ICQ again and talk with my already added contacts...
Comment 5 bluescream 2008-07-01 20:59:54 UTC
Created attachment 159159 [details, diff]
modified patch version for pidgin 2.4.2

The original patch didn't work for me.
I had to modify the 0x010A to 0x010B; see attachment.
Comment 6 Heiko Rosemann 2008-07-01 21:14:36 UTC
Created attachment 159165 [details, diff]
Same fix, but for pidgin 2.3.1 (stable x86)

Since the very same problem occurs with pidgin 2.3.1, I created a patch and a fixed ebuild for that version.
Comment 7 Heiko Rosemann 2008-07-01 21:15:49 UTC
Created attachment 159167 [details]
ebuild file for 2.3.1-r1
Comment 8 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-01 21:48:31 UTC
*** Bug 230399 has been marked as a duplicate of this bug. ***
Comment 9 Lars Wendler (Polynomial-C) gentoo-dev 2008-07-01 23:55:59 UTC
There's an official patch at http://www.pidgin.im/pidgin-2.4.2-icq6.patch
It's slightly different from all patches submitted in this bugreport but it's the official patch currently...
Comment 10 Lars Wendler (Polynomial-C) gentoo-dev 2008-07-02 04:12:22 UTC
pidgin-2.4.3 was released, which contains a fix for this bug. See http://developer.pidgin.im/wiki/ChangeLog
Comment 11 Olivier Crete (RETIRED) gentoo-dev 2008-07-02 04:15:08 UTC
they should be releasing 2.4.3 any time now.. if they don't, I'll put a version of 2.4.2 with the patch in
Comment 12 Olivier Crete (RETIRED) gentoo-dev 2008-07-02 04:33:50 UTC
its in the tree...
Comment 13 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-02 08:39:09 UTC
*** Bug 230479 has been marked as a duplicate of this bug. ***
Comment 14 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-02 08:39:31 UTC
*** Bug 230475 has been marked as a duplicate of this bug. ***
Comment 15 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-02 10:51:18 UTC
*** Bug 230497 has been marked as a duplicate of this bug. ***
Comment 16 Doug Goldstein gentoo-dev 2008-07-02 13:22:26 UTC
*** Bug 230503 has been marked as a duplicate of this bug. ***
Comment 17 Doug Goldstein gentoo-dev 2008-07-02 13:23:10 UTC
*** Bug 230497 has been marked as a duplicate of this bug. ***
Comment 18 Alexander Haensch 2008-07-05 08:58:21 UTC
Does not work for me with version 2.4.3.
Comment 19 Steffen 'j0inty' Stollfuß 2008-07-05 11:26:35 UTC
(In reply to comment #18)
> Does not work for me with version 2.4.3.
> 

What doesn't work for you with version 2.4.3 ???

Can you please give us more Informations about the problem ???

Logs,emerge --info, and soon

regards
j0inty
Comment 20 Alexey 2008-07-18 09:29:42 UTC
Created attachment 160701 [details]
with modified patch