Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 228831 - Can't build app-pda/multisync-0.83_pre20050414-r4
Summary: Can't build app-pda/multisync-0.83_pre20050414-r4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-06-22 03:00 UTC by Leonardo Ferreira Fontenelle
Modified: 2008-07-09 14:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,94.07 KB, text/plain)
2008-07-09 10:32 UTC, Tobias Klausmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonardo Ferreira Fontenelle 2008-06-22 03:00:19 UTC
Emerging multisync fails. This bug might be related to bug #202905 or bug #203959.


Reproducible: Always

Steps to Reproduce:
USE="irmc evo gnokii" sudo emerge multisync

(but happens without those USE flags too) 
Actual Results:  
if /bin/sh ../libtool --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_DATA_DIR=\""/usr/share/multisync"\" -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1   -I../include -I../../../include    -O2 -march=athlon-xp -pipe -mno-tls-direct-seg-refs -MT interface.lo -MD -MP -MF ".deps/interface.Tpo" \
	  -c -o interface.lo `test -f 'interface.c' || echo './'`interface.c; \
	then mv -f ".deps/interface.Tpo" ".deps/interface.Plo"; \
	else rm -f ".deps/interface.Tpo"; exit 1; \
	fi
../libtool: line 454: CDPATH: command not found
../libtool: line 454: CDPATH: command not found
../libtool: line 1146: func_opt_split: command not found
../libtool: line 1146: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
make[2]: ** [support.lo] Erro 1
make[2]: ** Esperando que outros processos terminem.
make[2]: ** [interface.lo] Erro 1
make[2]: Saindo do diretório `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/backup_plugin/src'
make[1]: ** [all-recursive] Erro 1
make[1]: Saindo do diretório `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/backup_plugin'
make: ** [all] Erro 2
 * 
 * ERROR: app-pda/multisync-0.83_pre20050414-r4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3688:  Called run_compile
 *             environment, line 3543:  Called die
 * The specific snippet of code:
 *       emake || die "Failed during make!"
 *  The die message:
 *   Failed during make!
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/app-pda:multisync-0.83_pre20050414-r4:20080622-024918.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/temp/environment'.
 * This ebuild is from an overlay: '/home/leonardof/.portage/'
 * 



Portage 2.1.5.5 (default-linux/x86/2007.0, gcc-4.2.4, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r5 i686)
=================================================================
System uname: 2.6.25-gentoo-r5 i686 AMD Sempron(tm) 2400+
Timestamp of tree: Sat, 21 Jun 2008 13:33:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.4-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -mno-tls-direct-seg-refs"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="pt_BR.UTF-8"
LC_ALL="pt_BR.UTF-8"
LDFLAGS=""
LINGUAS="pt_BR pt"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/leonardof/.portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion berkdb bluetooth cairo cdda cdr cli cracklib crypt cups curl dbus dri dts dvd dvdr dvdread eds encode epiphany exif fam ffmpeg fortran gdbm gedit gif gnome gnome-keyring gphoto2 gpm gstreamer gtk hal iconv isdnlog javascript jpeg lcms libnotify mad midi mmx mono mp3 mpeg mudflap musicbrainz nautilus ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pch pcre pdf perl png ppds pppd python readline reflection samba session spell spl sse ssl startup-notification svg tcpd theora tiff truetype unicode usb vcd vcdx vim-syntax vorbis x264 x86 xcomposite xorg xulrunner xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 	emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m 	maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pt_BR pt" USERLAND="GNU" VIDEO_CARDS="nv vesa via"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-22 16:34:35 UTC
(In reply to comment #0)
> Emerging multisync fails. This bug might be related to bug #202905 or bug
> #203959.

Nope, libtool issue
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-05 11:17:49 UTC
+  05 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+  multisync-0.83_pre20050414-r4.ebuild:
+  Fix for libtool-2.2 wrt bug #228831.
+

Some of the plugins needed to get their libtool scripts updated.
Comment 3 Tobias Klausmann gentoo-dev 2008-07-09 10:32:02 UTC
Created attachment 159948 [details]
build log

Still bombs:

config.status: executing depfiles commands
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/gnokii_sync'
Making all in src
make[2]: Entering directory `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/gnokii_sync/src'
if /bin/sh ../libtool --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_DATA_DIR=\""/usr/share/multisync"\" -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1   -I../include -I../../../include -I../../../src/libversit    -march=prescott -O2 -pipe -fomit-frame-pointer -MT gnokii_sync.lo -MD -MP -MF ".deps/gnokii_sync.Tpo" \
          -c -o gnokii_sync.lo `test -f 'gnokii_sync.c' || echo './'`gnokii_sync.c; \
        then mv -f ".deps/gnokii_sync.Tpo" ".deps/gnokii_sync.Plo"; \
        else rm -f ".deps/gnokii_sync.Tpo"; exit 1; \
        fi
../libtool: line 454: CDPATH: command not found
../libtool: line 1139: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
make[2]: *** [gnokii_sync.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/gnokii_sync/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/gnokii_sync'
make: *** [all] Error 2

Portage 2.2_rc1 (default-linux/x86/2007.0/desktop, gcc-4.3.1, glibc-2.7-r2, 2.6.25 i686)
=================================================================
System uname: Linux-2.6.25-i686-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-glibc2.0
Timestamp of tree: Wed, 09 Jul 2008 09:45:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r5
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://gentoo.tiscali.nl/"
INSTALL_MASK="/etc/udev/rules.d/75-persistent-net-generator.rules"
LC_ALL="en_US.utf8"
LDFLAGS=""
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X a52 acl acpi aim alsa ao apache2 audiofile bash-completion berkdb browserplugin bzip2 bzlib cairo cdr cli cracklib crypt cups curlwrappers divx4linux dri dv dvd dvdr dvdread dxr3 emboss encode ethereal exif exiscan exiscan-acl fam fame ffmpeg fftw firefox font-server fortran ftp gdbm gif gimpprint gnokii gnutls gpgme gpm gstreamer gtk hal iconv icq imap isdnlog jabber jpeg kdeenablefinal mad maildir midi mikmod mmap mmx mng mp3 mpeg mpi mudflap ncurses network nls nptl nptlonly offensive ogg openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline recode reflection sdl session sndfile spell spl sse ssl svg sysvipc tcpd theora tiff truetype unicode usb v4l v4l2 vorbis win32codecs wmf wxwindows x264 x86 xattr xml xorg xpm xscreensaver xv xvid yv12 zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm v4l vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LANG, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Tobias Klausmann gentoo-dev 2008-07-09 14:29:20 UTC
(loki and I chatted on IRC and he told me he'd fixed it for libtool-2. 

Now this happens:
libtool: compile:  i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DPACKAGE_DATA_DIR=\"/usr/share/multisync\" -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I../include -I../../../include -I../../../src/libversit -march=prescott -O2 -pipe -fomit-frame-pointer -MT gnokii_sync.lo -MD -MP -MF .deps/gnokii_sync.Tpo -c gnokii_sync.c  -fPIC -DPIC -o .libs/gnokii_sync.o
In file included from gnokii_sync.c:47:
vcard.h:5: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘int’
vcard.h:6: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘int’
vcard.h:7: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘int’
vcard.h:8: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘int’
gnokii_sync.c: In function ‘gnokii_do_connect’:
gnokii_sync.c:131: warning: ‘gn_cfg_phone_load’ is deprecated (declared at /usr/include/gnokii.h:267)
gnokii_sync.c:138: warning: ‘gn_cfg_get’ is deprecated (declared at /usr/include/gnokii.h:257)
gnokii_sync.c:138: warning: ‘gn_cfg_info’ is deprecated (declared at /usr/include/gnokii.h:244)
gnokii_sync.c:142: warning: ‘gn_device_lock’ is deprecated (declared at /usr/include/gnokii.h:307)
gnokii_sync.c:151: warning: ‘gn_gsm_initialise’ is deprecated (declared at /usr/include/gnokii.h:253)
gnokii_sync.c:162: warning: ‘gn_device_unlock’ is deprecated (declared at /usr/include/gnokii.h:309)
gnokii_sync.c: In function ‘gnokii_free_connection’:
gnokii_sync.c:203: warning: ‘gn_device_unlock’ is deprecated (declared at /usr/include/gnokii.h:309)
make[2]: *** [gnokii_sync.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/gnokii_sync/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/gnokii_sync'
make: *** [all] Error 2