Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 202905 - app-pda/multisync-0.83_pre20050414-r4 doesn't compile with popt-1.12
Summary: app-pda/multisync-0.83_pre20050414-r4 doesn't compile with popt-1.12
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-20 23:58 UTC by Marco Marzetti
Modified: 2009-10-13 11:26 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Marzetti 2007-12-20 23:58:23 UTC
I'm unable to re-emerge app-pda/multisync-0.83_pre20050414-r4 to fix gnutls reverse dependencies

Reproducible: Always

Steps to Reproduce:
1.emerge --oneshot multisync
2.
3.

Actual Results:  
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_DATA_DIR=\"/usr/share/multisync\" -I../../../src/libversit -I.. -DORBIT2=1 -pthread -D_REENTRANT -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/gail-1.0 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/directfb -I/usr/include/libpng12 -I../include -I../../../include -Werror -O2 -march=pentium3 -pipe -fomit-frame-pointer -mmmx -msse -msse2 -mfpmath=sse -DLDAP_DEPRECATED -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -MT gui.lo -MD -MP -MF .deps/gui.Tpo -c gui.c  -fPIC -DPIC -o .libs/gui.o
In file included from /usr/include/libbonobo-2.0/bonobo/bonobo-i18n.h:39,
                 from /usr/include/libgnome-2.0/libgnome/gnome-i18n.h:41,
                 from /usr/include/libgnome-2.0/libgnome/libgnome.h:30,
                 from /usr/include/libgnomeui-2.0/gnome.h:5,
                 from support.h:5,
                 from gui.c:4:
/usr/include/glib-2.0/glib/gi18n.h:30:1: error: "N_" redefined
In file included from /usr/include/libgnome-2.0/libgnome/gnome-program.h:41,
                 from /usr/include/libgnome-2.0/libgnome/libgnome.h:29,
                 from /usr/include/libgnomeui-2.0/gnome.h:5,
                 from support.h:5,
                 from gui.c:4:
/usr/include/popt.h:161:1: error: this is the location of the previous definition
make[2]: *** [gui.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/ldap_plugin/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/work/multisync/plugins/ldap_plugin'
make: *** [all] Error 2
 * 
 * ERROR: app-pda/multisync-0.83_pre20050414-r4 failed.
 * Call stack:
 *               ebuild.sh, line   46:  Called src_compile
 *             environment, line 3718:  Called run_compile
 *             environment, line 3535:  Called die
 * The specific snippet of code:
 *       emake || diefunc "$FUNCNAME" "$LINENO" "$?" "Failed during make!"
 *  The die message:
 *   Failed during make!
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-pda/multisync-0.83_pre20050414-r4/temp/environment'.



nerv ~ # emerge --info
Portage 2.1.4_rc10 (default-linux/x86/2007.0, gcc-4.2.2, glibc-2.7-r1, 2.6.23-gentoo i686)
=================================================================
System uname: 2.6.23-gentoo i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Timestamp of tree: Thu, 20 Dec 2007 23:00:04 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.3
dev-lang/python:     2.5.1-r4
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -pipe -fomit-frame-pointer -mmmx -msse -msse2 -mfpmath=sse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium3 -pipe -fomit-frame-pointer -mmmx -msse -msse2 -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/"
LANG="it_IT.utf8"
LINGUAS="it en"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/evan-overlay /usr/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi administrator aim alsa apache2 asf automount avahi beagle berkdb bgpclassless bitmap-fonts bluetooth bonjour browserplugin bzip2 cairo cdda cddb cdio cdr chm cjk cli cracklib crypt cups curl dba dbus directfb disk-partition divx divx4linux dri dvd dvdr dvdread eds encode ffmpeg firefox flash fortran ftp gd gdbm geoip gif glitz gmedia gnome gnutls gphoto2 gpm gstreamer gtk hal howl-compat i8x0 iconv ieee1394 imagemagick ipod iproute2 ipv6 irda isdnlog java javascript jpeg ldap libnotify lzo mad mdnsresponder-compat midi mjpeg mmx mono moznocompose moznoirc moznomail mozxmlterm mp3 mpeg msn mudflap multipath mysql nas nautilus ncurses new-login nls nptl nptlonly nsplugin ogg opengl openmp passwordsave pcre pda pdf pear perl php png pppd print python query-browser quicktime readline real realmedia reflection rtsp samba scanner session skins smp sms snmp spell spl sse sse2 ssl stats svg tcltk tcpd threads thunderbird tiff truetype truetype-fonts type1-fonts unicode usb userlocales v4l v4l2 vorbis webservices wifi win32codecs wmp wv wxwindows x86 xinerama xml xmlreader xmlrpc xorg xprint xscreensaver xsl xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" USERLAND="GNU" VIDEO_CARDS="fglrx vga ati"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

nerv ~ #
Comment 1 Guillaume Villeneuve 2007-12-26 02:46:50 UTC
Same problem here

workaround: install popt-1.10.7 temporarly
Comment 2 Sandro Bonazzola 2008-03-13 19:21:10 UTC
Since opensync 0.22 is already in portage is there any need for multisync?

quoting http://multisync.sourceforge.net/news.php:
22.04.06 Multisync successor - by Armin Bauer
We were working on the successor to Multisync called OpenSync. OpenSync is a synchronization framework and is capable of synchronizing a large variety of devices and protocols like Evolution 2, IRMC, Palms, SyncML and more.

If multisync is absolutely needed for any reason, please try again with popt-1.13 and the latest dev-libs/glib available since it seems that is glib that try to redefine something that already exists without any checking or undef.
Comment 3 Leonardo Ferreira Fontenelle 2008-06-22 02:34:43 UTC
OpenSync provides libraries, but not applications.

Quoting http://www.opensync.org/wiki/SetupGuide:

"First, download and install: OpenSync, the plugins you plan to use, and Multisync."

BTW, this bug could be a dup of #203959 (just guessing).
Comment 4 Samuli Suominen gentoo-dev 2009-10-13 11:26:38 UTC
Removed from tree (see bug 279384).