Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 203959 - app-pda/multisync-0.83_pre20050414-r4 doesn't compile
Summary: app-pda/multisync-0.83_pre20050414-r4 doesn't compile
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-01 06:00 UTC by Alexey Parshin
Modified: 2009-10-13 11:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Multisync/gnokii patch (changes API to GNOKII-API) (multisync-gnokii.patch,1.81 KB, patch)
2008-02-28 20:14 UTC, Mike Civil
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Parshin 2008-01-01 06:00:27 UTC
Failing fragment:

 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_DATA_DIR=\"/usr/share/multisync\" -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/gail-1.0 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I../include -I../../../include -I../../../src/libversit -march=prescott -O2 -pipe -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -I/usr/include/libpisock -MT vcard.lo -MD -MP -MF .deps/vcard.Tpo -c vcard.c  -fPIC -DPIC -o .libs/vcard.o
vcard.c:194: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'int'
vcard.c:242: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'int'
vcard.c:312: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'int'

emerge info:

Portage 2.1.4_rc14 (default-linux/x86/2007.0/desktop, gcc-4.2.2, glibc-2.7-r1, 2.6.23-gentoo-r5 i686)
=================================================================
System uname: 2.6.23-gentoo-r5 i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Timestamp of tree: Mon, 31 Dec 2007 22:16:01 +0000
distcc[1072] (dcc_mkdir) ERROR: mkdir /var/tmp/portage/.distcc/state failed: No such file or directory [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.5.1-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.pacific.net.au/linux/Gentoo ftp://mirror.pacific.net.au/linux/Gentoo http://mirror.usu.edu/mirrors/gentoo/ ftp://mirror.datapipe.net/gentoo"
LINGUAS="en ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/enlightenment /root/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="7zip X a52 aac accessibility acpi aim alsa amd amr apache2 automount bash-completion berkdb binary-drivers bluetooth branding bzip2 cairo calendar cardbus cdda cdr cgi chroot cli cpudetection crypt css cups dbm dbus dhcp divx djvu dri dts dv dvd dvdnav dvdr dvdread dvi encode enscript excel fam fame fastcgi fat fax fbcon ffmpeg filepicker firefox flac fltk foomaticdb freetds ftp fuse gaim gd gdbm gif gimp gimpprint glitz gmail gnokii gnome gnome-print gpm gstreamer gtk gzip h323 hal hbci hddtemp icq ieee1394 imap irc jpeg jpeg2k kde lame lm_sensors mad matroska mjpeg mmap mmx mmxext mono motif mp3 mp4 mpeg mplayer mpm-prefork mppe-mppc msn mssql nautilus ncurses nfs nls nntp nptl nptlonly nsplugin ntfs nvidia obex odbc ogg opengl oss pam pango pcmcia pcre pdf perl php pmu png pop postgres ppds python quicktime rar rdesktop readline real realmedia reiser4 reiserfs rplay rpm rtc samba scanner sensord server slang slp smp sms sox spamassassin speex spell sqlite sqlite3 sse sse2 ssl subtitles subversion svg tga theora threads tiff timidity transcode truetype type1 unicode usb v4l v4l2 vcd vdr vidix vorbis vorbis-psy wavpack webdav wifi win32codecs wma wmf wmp x264 x86 xcomposite xfs xine xml xorg xosd xpm xprint xscreensaver xv xvid xvmc yahoo yv12 zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shm" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mike Civil 2008-02-28 20:14:39 UTC
Created attachment 144898 [details, diff]
Multisync/gnokii patch (changes API to GNOKII-API)

It looks you get this when emerging multisync with the gnokii USE flag. The vcard.c and vcard.h files in the gnokii plugin dir are out of sync with /usr/include/gnokii.h. The attached patch fixed it for me.
Comment 2 Samuli Suominen gentoo-dev 2009-10-13 11:26:53 UTC
Removed from tree (see bug 279384).