Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 226323 - =dev-python/pygtk-2.12.0: autotools are being rebuilt through maintainer-mode
Summary: =dev-python/pygtk-2.12.0: autotools are being rebuilt through maintainer-mode
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 226719 (view as bug list)
Depends on: 229709 236971
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2008-06-13 12:31 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-02-22 17:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-13 12:31:17 UTC
Rebuilding autotools through maintainer-mode is _not_ good, because it usually means you forget to add dependencies, and they'll magically use the same version as used by upstream, which might not be what the user have installed at all.

If you patch Makefile.am or configure.in/configure.ac you _have to_ use autotools.eclass and eautomake/eautoreconf. Exceptions are granted _only_ for system packages that would make it impossible to run autotools during stagebuilding.

Please fix your package.
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-08-23 10:42:03 UTC
this concerns the 2.12.0 series with extrafuncs patch, it should die as soon as arches stabilize 2.12.1-r2.
Comment 2 Mart Raudsepp gentoo-dev 2008-08-30 00:21:04 UTC
This in the ebuild looks like trouble:

        use doc || sed -e 's/\(SUBDIRS =.*\) docs$/\1/' -i "${S}"/Makefile.am

Can someone please explain why the maintainer-mode kicks in for this package, while for most of the rest patching Makefile.am/in together this does not happen?
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-11-29 23:24:59 UTC
@arm, sh, hello guys, we are still waiting for you to mark stable pygtk-2.12.1-r2 ebuild to kill this one from the tree. Thanks for considering.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-11-30 12:20:35 UTC
*** Bug 226719 has been marked as a duplicate of this bug. ***
Comment 5 Raúl Porcel (RETIRED) gentoo-dev 2009-02-21 19:41:23 UTC
arm/sh stable
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-02-22 17:59:19 UTC
Cleaned up dead old revision. Thanks for reporting.