Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 226719 - dev-python/pygtk: patch (pygtk-2.12.0-extrafuncs.patch) changes both autotools source and result
Summary: dev-python/pygtk: patch (pygtk-2.12.0-extrafuncs.patch) changes both autotool...
Status: RESOLVED DUPLICATE of bug 226323
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2008-06-14 16:20 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2008-11-30 12:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-14 16:20:06 UTC
The patch in summary is touching both Makefile.in and Makefile.am, probably to avoid autotools rebuild.

This treatment is usually reserved for a few selected system packages that cannot have their autotool scripts rebuilt.

This _could_ cause maintainermode-driven rebuild (see http://blog.flameeyes.eu/articles/2008/06/13/maintaner-mode ), which is something we should be avoiding as much as possible.

Please just patch Makefile.am and/or configure.in/.ac and rebuild autotools, unless you have very good reasons not to.
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-11-30 12:20:35 UTC
actually this has been filled twice.

*** This bug has been marked as a duplicate of bug 226323 ***