Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 229709 - Stabilization of GNOME-2.22
Summary: Stabilization of GNOME-2.22
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 214301 222219 228087 228991 229679 229717 232054 232370 232484
Blocks: gnome2.22-tracker 226323 232726
  Show dependency tree
 
Reported: 2008-06-27 11:35 UTC by Mart Raudsepp
Modified: 2009-04-20 22:01 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnome-2.22.2-bump.list (gnome-2.22.2-bump.list,11.85 KB, text/plain)
2008-07-26 18:31 UTC, Gilles Dartiguelongue
Details
gnome-2.22.2-keyword.list (gnome-2.22.2-keyword.list,826 bytes, text/plain)
2008-07-26 18:33 UTC, Gilles Dartiguelongue
Details
gnome-2.22.2-bump.list (gnome-2.22.2-bump.list,12.18 KB, text/plain)
2008-07-27 17:55 UTC, Gilles Dartiguelongue
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mart Raudsepp gentoo-dev 2008-06-27 11:35:06 UTC
This bug will be the stabilization bug for GNOME-2.22. Filing it before the stabilization list, so that we can track the true blocker bugs for stabilization purposes, and have other maintainers be able to ask here beforehand packages to be included together with the rest for possible compatibility reasons
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-07-17 09:11:59 UTC
some packages in gnome 2.22 (sound-juicer iirc) requires gstreamer >= 0.10.17, hence adding dep on bug #232054
Comment 2 Rémi Cardona gentoo-dev 2008-07-21 08:09:19 UTC
As promised, the gnome-mm list. All of these have been in tree for more than 30 days (except glibmm, but I've reviewed the changes and I've ACKed them).

With those ebuilds stable, we should be able to clean up quite a few of the old cruft we currently carry (if reluctant arches are willing to cooperate...)

dev-cpp/cairomm-1.6.0
dev-cpp/gconfmm-2.22.0
dev-cpp/glibmm-2.16.4
dev-cpp/gnome-vfsmm-2.22.0
dev-cpp/gtkglextmm-1.2.0-r1
dev-cpp/gtkmm-2.12.7
dev-cpp/gtksourceviewmm-2.2.0
dev-cpp/libglademm-2.6.6
dev-cpp/libgnomecanvasmm-2.22.0
dev-cpp/libgnomemm-2.22.0
dev-cpp/libgnomeuimm-2.22.0
dev-cpp/libxmlpp-2.22.0
dev-libs/libsigc++-2.2.2
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-07-26 18:31:30 UTC
Created attachment 161432 [details]
gnome-2.22.2-bump.list

After cross checking leio's and my work, here is a hopefully complete list of things to stabilize for gnome 2.22
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-07-26 18:33:03 UTC
Created attachment 161433 [details]
gnome-2.22.2-keyword.list

and things that still need keywords on various arches.
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-07-26 18:45:33 UTC
hello arches, please find attached to this bug the list of packages to stabilize for gnome 2.22. Some packages might need keywording first for your arch too.

Please also find the list of gnome-mm bindings to stabilize in comment #2

Comment 6 Gilles Dartiguelongue gentoo-dev 2008-07-27 17:55:40 UTC
Created attachment 161478 [details]
gnome-2.22.2-bump.list

update of the bump list after tester's review.
Comment 7 Olivier Crete (RETIRED) gentoo-dev 2008-07-27 22:57:16 UTC
To be added to the list are: dev-dotnet/mono-addins-0.3.0 (for tomboy) .. and don't forgot the dependant bugs on beagle and evolution-sharp

amd64 is done
Comment 8 Pacho Ramos gentoo-dev 2008-07-28 14:38:34 UTC
gnome-extra/nautilus-open-terminal-0.9 must be stabilized also, as current stable version (0.8) doesn't work with nautilus-2.22

Works ok for me under amd64. Thanks
Comment 9 Gustavo Zacarias 2008-07-30 14:48:58 UTC
You also need a newer mail-notification stable.
mail-client/mail-notification-5.0 doesn't work with evolution-2.22*.
5.4 does, haven't tried anything in between.
Comment 10 Brent Baude (RETIRED) gentoo-dev 2008-07-30 23:34:10 UTC
Ok, ppc should be good to go but I am not going to remove the arch alias until some more of the depends bugs are shot.  

Comment 11 Raúl Porcel (RETIRED) gentoo-dev 2008-07-31 09:42:27 UTC
Readding amd64
Comment 12 Olivier Crete (RETIRED) gentoo-dev 2008-07-31 13:31:48 UTC
We can't stabilize mail-client/mail-notification because it depends on net-mail/fetchyahoo which the maintainer doesnt not which to stabilize, see bug #214301
Comment 13 Gustavo Zacarias 2008-07-31 13:34:51 UTC
Well do as graaff says, drop yahoo support and then stabilize, or fix 5.3.
Comment 14 Alex 2008-08-01 11:13:48 UTC
I've used the gnome-2.22.2-keyword.list on x86 (I have gnome-light applets and evolution) and it compiled fine except a circular dependency (gnome-applets with the weather applet I think but I'm not 100% sure).

For the moment it works like a charm.
Comment 15 Alex 2008-08-01 14:11:20 UTC
(In reply to comment #14)
> I've used the gnome-2.22.2-keyword.list on x86 (I have gnome-light applets and
> evolution) and it compiled fine except a circular dependency (gnome-applets
> with the weather applet I think but I'm not 100% sure).
> 
> For the moment it works like a charm.
> 

I'm sorry I meant gnome-2.22.2-bump.list
Comment 16 Brent Baude (RETIRED) gentoo-dev 2008-08-04 14:11:54 UTC
Any reason ppc64 is not on the arch list here but is listed as an arch in the attachments?  I'd be happy to work on ppc64 if this simply an error.
Comment 17 Olivier Crete (RETIRED) gentoo-dev 2008-08-04 14:26:37 UTC
mail-notification has been done on amd64
Comment 18 Markus Meier gentoo-dev 2008-08-09 12:34:15 UTC
looks good so far on x86 (I'll mark it stable today/tomorrow). please note these minor things:

x11-libs/gtksourceview-2.2.1: dodoc: TODO does not exist
x11-terms/gnome-terminal-2.22.3: dodoc: TODO does not exist
x11-libs/gtk+-2.12.10-r1: rm: cannot remove `/var/tmp/portage/x11-libs/gtk+-2.12.10-r1/image//etc/gtk-2.0/gtk.immodules': No such file or directory
x11-libs/pango-1.20.5: rm: cannot remove `/var/tmp/portage/x11-libs/pango-1.20.5/image//etc/pango/pango.modules': No such file or directory
Comment 19 Sven 2008-08-10 14:37:38 UTC
(In reply to comment #18)
> looks good so far on x86 (I'll mark it stable today/tomorrow).

Only half of the ebuilds is marked stable at the moment. Portage is in a pretty unconsistent state at the moment yielding unsolvable blockers and stuff.
Comment 20 Paul B. 2008-08-10 16:18:57 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > looks good so far on x86 (I'll mark it stable today/tomorrow).
> 
> Only half of the ebuilds is marked stable at the moment. Portage is in a pretty
> unconsistent state at the moment yielding unsolvable blockers and stuff.
> 

I agree - in my install, gnome-settings-daemon is blocking gnome-control-center and I have not been able to resolve this.:

[blocks B] <gnome-base/gnome-control-center-2.22 (is blocking gnome-base/gnome-settings-daemon-2.22.2.1)

and:

[ebuild   R   ] gnome-base/gnome-settings-daemon-2.22.2.1  USE="alsa -debug -esd -gstreamer" 0 kB 

how can something be blocking something that is already installed?




Comment 21 Gilles Dartiguelongue gentoo-dev 2008-08-10 16:37:54 UTC
Sven, Paul, please read upgrade notes at http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.22-upgrade.xml and be patient we our arch teams, thanks. If you have issues with gnome 2.22, please open a separate bug for them.
Comment 22 Sven 2008-08-10 17:01:12 UTC
(In reply to comment #21)
> Sven, Paul, please read upgrade notes at
> http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.22-upgrade.xml and
> be patient we our arch teams, thanks. If you have issues with gnome 2.22,
> please open a separate bug for them.

I don't have any problem with gnome itself.

The problem is, that gnome-settings-daemon-2.22 has gone stable while gnome-base/gnome-control-center-2.22 is not yet stable.
So portage complains:
"<gnome-base/gnome-control-center-2.22 (is blocking gnome-base/gnome-settings-daemon-2.22.2.1)"

It seems, like the x86 maintainer committed to CVS after doing only half the job. It's been like that for hours now.
Comment 23 Douglas Anderson 2008-08-10 17:27:00 UTC
short term fix:

echo "=gnome-base/gnome-control-center-2.22.2.1" >>/etc/portage/package.keywords

actually solution would be of course to stabilize that package.
Comment 24 Raúl Porcel (RETIRED) gentoo-dev 2008-08-10 17:38:45 UTC
x86 should be done already, please report if not after you've synced in an hour or so
Comment 25 Sven 2008-08-10 19:20:38 UTC
(In reply to comment #24)
> x86 should be done already, please report if not after you've synced in an hour
> or so

gnome-extra/nautilus-cd-burner
app-accessibility/gnome-speech
gnome-base/gnome-volume-manager
app-text/evince

These are still missing on x86. I doublechecked by looking at http://viewcvs.gentoo.org
Comment 26 Markus Meier gentoo-dev 2008-08-10 19:42:24 UTC
x86 stable (thanks armin76 =))
Comment 27 Paul B. 2008-08-12 12:33:32 UTC
(In reply to comment #21)
> Sven, Paul, please read upgrade notes at
> http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.22-upgrade.xml and
> be patient we our arch teams, thanks. If you have issues with gnome 2.22,
> please open a separate bug for them.

A sync last night resulted in a successfull 2.22 build - thanks and apologize for being impatient...!

Paul
Comment 28 Raúl Porcel (RETIRED) gentoo-dev 2008-08-12 19:36:53 UTC
alpha/ia64/sparc stable
Comment 29 Friedrich Oslage (RETIRED) gentoo-dev 2008-08-13 18:31:07 UTC
If GNOME-2.22 is (going) stable, why is it still masked in profiles/base/package.mask which all 2008 profiles use?
Comment 30 Jeremy Koppel 2008-08-21 01:56:27 UTC
Is this still broken?  I just did an emerge --sync, and am still getting:

[blocks B     ] <gnome-base/gnome-control-center-2.22 (is blocking gnome-base/gnome-settings-daemon-2.22.2.1)


The "fix" echo "=gnome-base/gnome-control-center-2.22.2.1" >>/etc/portage/package.keywords, doesn't change the result.
Comment 31 Jeroen Roovers (RETIRED) gentoo-dev 2008-08-23 04:13:26 UTC
I think this should go in first:

Index: gnome-settings-daemon-2.22.2.1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.22.2.1.ebuild,v
retrieving revision 1.8
diff -u -B -r1.8 gnome-settings-daemon-2.22.2.1.ebuild
--- gnome-settings-daemon-2.22.2.1.ebuild       14 Aug 2008 00:35:50 -0000      1.8
+++ gnome-settings-daemon-2.22.2.1.ebuild       23 Aug 2008 04:12:42 -0000
@@ -37,7 +37,7 @@
                                                >=media-libs/gstreamer-0.10.1.2
                                                >=media-libs/gst-plugins-base-0.10.1.2
                                        )
-               !<gnome-base/gnome-control-center-2.22"
+               >=gnome-base/gnome-control-center-2.22"
 DEPEND="${RDEPEND}
                  sys-devel/gettext
                >=dev-util/intltool-0.35.0
Comment 32 Jeroen Roovers (RETIRED) gentoo-dev 2008-08-23 04:26:16 UTC
Or is there a reason for the blocker?
Comment 33 Rémi Cardona gentoo-dev 2008-08-23 07:27:54 UTC
gnome-settings-daemon used to be shipped with gnome-control-center, but was split out for Gnome 2.22, hence the current blocker. g-s-d does not depend in anyway on g-c-c. It's actually the opposite :)

Users should just remove the old gnome-control-center and carry on with the installation. Newer portages in ~arch should handle this blocker correctly without user intervention.

Thanks
Comment 34 Gilles Dartiguelongue gentoo-dev 2009-04-20 22:01:37 UTC
Obsoleted by bug #260063, see you there.