Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 222345 - sys-apps/hal fails eautoreconf with sys-devel/libtool-2.2
Summary: sys-apps/hal fails eautoreconf with sys-devel/libtool-2.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Project Gentopia
URL: http://lists.freedesktop.org/archives...
Whiteboard:
Keywords:
: 223167 223409 (view as bug list)
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-05-16 07:47 UTC by Rémi Cardona
Modified: 2008-05-28 06:20 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fix-libtool-2.2.patch (patch,234 bytes, patch)
2008-05-16 07:48 UTC, Rémi Cardona
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2008-05-16 07:47:45 UTC
Patch to follow
Comment 1 Rémi Cardona gentoo-dev 2008-05-16 07:48:45 UTC
Created attachment 153289 [details, diff]
fix-libtool-2.2.patch
Comment 2 Rafał Mużyło 2008-05-16 10:09:52 UTC
Damn, overlay slower than normal portage tree.
There this patch had been for quite awhile.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2008-05-16 10:45:23 UTC
duplicate of https://bugs.gentoo.org/show_bug.cgi?id=212772 maybe?
Comment 4 Rémi Cardona gentoo-dev 2008-05-16 11:29:04 UTC
Yeah, it's a dupe (almost), except that I don't have access to Gentopia's overlay (btw, if gentopia is interested in my help, I don't mind helping out with hal and related stuff).

I did send the patch upstream though, better get it fixed there too.
Comment 5 Rémi Cardona gentoo-dev 2008-05-20 09:56:49 UTC
Same bug with 0.5.11 in portage. Saleem, could you add it to the hal patchset?

Thanks
Comment 6 Carsten Lohrke (RETIRED) gentoo-dev 2008-05-22 22:46:51 UTC
*** Bug 223167 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Schwarzott gentoo-dev 2008-05-23 06:43:06 UTC
It is useless to add ~arch keywords, while package is broken on ~arch. Please apply this patch.
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-05-24 12:41:15 UTC
CCing compnerd so this doesn't get lost, see also bug #212772 which got fixed by vapier.
Comment 9 Gilles Dartiguelongue gentoo-dev 2008-05-24 14:36:05 UTC
*** Bug 223409 has been marked as a duplicate of this bug. ***
Comment 10 Saleem Abdulrasool (RETIRED) gentoo-dev 2008-05-28 02:51:39 UTC
This has been added to the ebuild in the overlay.  Once I test it a bit more, I will push it to the portage tree.
Comment 11 Rémi Cardona gentoo-dev 2008-05-28 06:20:31 UTC
FYI, it builds fine and seems to be working fine too. Thanks

BTW, could you ping upstream to include my patch? They've perfectly ignored my message...