Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 212772 - sys-apps/hal-0.5.10 fails to emerge w/ libtool 2.2
Summary: sys-apps/hal-0.5.10 fails to emerge w/ libtool 2.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Project Gentopia
URL:
Whiteboard:
Keywords:
: 220411 (view as bug list)
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-03-08 23:01 UTC by Tom Crosby
Modified: 2008-05-24 12:40 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Crosby 2008-03-08 23:01:34 UTC
sys-apps/hal-0.5.10 fails to run aclocal with libtool 2.2.  Works fine with previous version of libtool.

Steps to reproduce:

1. Upgrade to sys-devel/libtool-2.2.
2. Emerge sys-apps/hal-0.5.10.

Results:

 *   0045-lshal-use-l-as-default-for-show.patch ...                                            [ ok ]
 *   0046-set-laptop_panel.brightness_in_hardware-true-for-all.patch ...                       [ ok ]
 *   0047-always-define-DELL_WCTL.patch ...                                                    [ ok ]
 *   0049-add-missing-semicolon-lost-in-the-cleanup.patch ...                                  [ ok ]
 *   0050-linux-add-drm-subsystem.patch ...                                                    [ ok ]
 *   0051-use-slices-for-HalProperty.patch ...                                                 [ ok ]
 *   0052-use-g_slice-for-hotplug-events.patch ...                                             [ ok ]
 *   0053-process-coldplug-events-as-soon-as-they-re-generated.patch ...                       [ ok ]
 *   0054-rework-handling-of-data-from-udevinfo-for-more-effic.patch ...                       [ ok ]
 * Done with patching
 * Applying hal-0.5.9-hide-recovery-partitions.patch ...                                       [ ok ]
 * Applying 96_plugdev_allow_send.patch ...                                                    [ ok ]
 * Running eautoreconf in '/var/tmp/portage/sys-apps/hal-0.5.10/work/hal-0.5.10' ...
 * Running aclocal ...                                                                         [ !! ]

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/sys-apps/hal-0.5.10/temp/aclocal-2028.out

 * 
 * ERROR: sys-apps/hal-0.5.10 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3731:  Called eautoreconf
 *             environment, line 1289:  Called eaclocal
 *             environment, line 1228:  Called autotools_run_tool 'src_unpack'
 *             environment, line  558:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running aclocal !
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/hal-0.5.10/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/hal-0.5.10/temp/environment'.
 * 


/var/tmp/portage/sys-apps/hal-0.5.10/temp/aclocal-2028.out:

***** aclocal *****

configure.in:394: error: m4_require: circular dependency of AC_LANG_COMPILER(C++)
../../lib/autoconf/lang.m4:297: AC_LANG_COMPILER_REQUIRE is expanded from...
../../lib/autoconf/general.m4:2405: AC_LINK_IFELSE is expanded from...
/usr/share/aclocal/libtool.m4:1005: _LT_SYS_MODULE_PATH_AIX is expanded from...
/usr/share/aclocal/libtool.m4:5287: _LT_LANG_CXX_CONFIG is expanded from...
/usr/share/aclocal/libtool.m4:787: _LT_LANG is expanded from...
/usr/share/aclocal/libtool.m4:770: LT_LANG is expanded from...
../../lib/autoconf/c.m4:736: AC_LANG_COMPILER(C++) is expanded from...
../../lib/autoconf/lang.m4:297: AC_LANG_COMPILER_REQUIRE is expanded from...
../../lib/autoconf/general.m4:2405: AC_LINK_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:516: AS_IF is expanded from...
../../lib/autoconf/general.m4:1898: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:1911: AC_CACHE_CHECK is expanded from...
../../lib/autoconf/libs.m4:121: AC_CHECK_LIB is expanded from...
configure.in:394: the top level
autom4te-2.61: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1
Comment 1 Rafał Mużyło 2008-03-15 19:06:01 UTC
Following a hunch, I added following line:
sed -i -e '/AC_PROG_CC/aAC_PROG_CXX'  "${S}"/configure.in
in the ebuild, right above eautoreconf and it built fine.
Comment 3 Sebastian Glita 2008-05-05 17:50:15 UTC
*** Bug 220411 has been marked as a duplicate of this bug. ***
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-05-24 12:40:05 UTC
closing per comment #2