Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 178512 - Gentoo 2007.0 Installer Errors on amd64/x86 LiveCD/DVD
Summary: Gentoo 2007.0 Installer Errors on amd64/x86 LiveCD/DVD
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Installer (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Installer
URL: http://gentoo.ru/node/6966
Whiteboard:
Keywords: InVCS
: 178150 184239 213400 (view as bug list)
Depends on:
Blocks: 178085
  Show dependency tree
 
Reported: 2007-05-14 14:21 UTC by Pandora
Modified: 2008-07-13 01:05 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pandora 2007-05-14 14:21:12 UTC
(RU)
Всем привет!

Возникают проблемы при установке Gentoo 2007.0 сразу на двух архитектурах (i686 и AMD64).
Сразу хочу предупредить, что речь идет о графическом (GTK) инсталяторе. Как ведет себя классический (консольный) вариант инсталятора я еще не опробовал.

1. С официального сайта (http://www.gentoo.org/main/en/where.xml) были получены два образа: 1)"Gentoo 2007.0 LiveDVD i686" и "Gentoo 2007.0 LiveСD AMD64".

2. При попытке установить систему (после загрузки с LiveCD/LiveDVD), как на AMD64 (Athlon 4000+), так и на i686 (Pentium4 3GHz) машинах - всё заканчивается неудачей. Причем ошибка возникает в одном из нескольких мест.

(Вариант - А) Во время установки третьей стадии (STAGE3-по умолчанию) с LiveCD/LiveDVD - происходит либо зависание на 50-ом пакете "Perl" (50-ый из 116-ти пакетов), либо система пишет, что портаж (Portage) успешно установлен - и ВСЁ! Дальше никаких попыток продолжить установку система не предпринимает, хотя в лог-журнале не отображается никаких ошибок (опцию "ViewLog" можно вкдючить в самом начале инсталляции).

(Вариант - Б) После якобы удачной установки портажа (Portage) - система пытается сменить корень (chroot) c LiveCD/LiveDVD на жесткий диск, в результате чего мы постоянно получаем в ответ чудесное слово "FAILED".

P.S.
Все вышеописанные "телодвижения" производились на 4 разных (физические машины) машинах i686/AMD64 и 2 виртуальных (VMWare) - естественно в зависимости от архитектуры использовался либо "Gentoo 2007.0 LiveDVD i686" ,либо "Gentoo 2007.0 LiveСD AMD64".

Что это значит? Gentoo выложила "сырой срез" вместо "RELEASED"? В чем может быть дело?

"Pandora"
marvelcat@gmail.com
deathcell@mail.ru
ICQ:291644543
-------------------------------------------------------------------------------------------------------------------------------------------------------------
(EN)
All greetings!

There are problems at installation Gentoo 2007.0 at once on two architecture (i686 and AMD64). At once I wish to warn, that it is a question about graphic (GTK) installator. As the classical (console) variant of installator I yet behaves has not tested.

1. From an official site (http: // www.gentoo.org/main/en/where.xml) two images have been received: 1) " Gentoo 2007.0 LiveDVD i686 " and " Gentoo 2007.0 LiveСD AMD64 ".

2. At attempt to install system (after loading with LiveCD/LiveDVD) as on AMD64 (Athlon 4000 +), and on i686 (Pentium4 3GHz) computers - all comes to an end with failure. And the error arises in one of several places:

(A variant) During installation of the third stage (by default) with LiveCD/LiveDVD - occurs(happens) or lag on 50-th package "Perl" (50/116 packages), or the system writes, that Portage is successfully established (installed) - and "THE END"! Further any attempts to continue the system does not undertake installation, though in a broad gully-magazine is not displayed any errors (an option "ViewLog" it is possible "ON" right at the beginning of installation).

(B variant) After ostensibly successful installation портажа (Portage) - the system tries to replace a root (chroot) c LiveCD/LiveDVD with a hard disk therefore we constantly receive in the answer a wonderful word "FAILED".

P.S.
All above described "BODY-MOVING" were made on 4 different (physical computers) computers i686/AMD64 and 2 virtual (VMWare) - it is natural depending on architecture it was used or " Gentoo 2007.0 LiveDVD i686 ", or " Gentoo 2007.0 LiveСD AMD64 ". What does it mean? Gentoo has laid out " a crude cut " instead of "RELEASED"? In what there can be a business?

"Pandora"
marvelcat@gmail.com
deathcell@mail.ru
ICQ:291644543


Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-05-14 14:42:19 UTC
1/ This is *not* a Gentoo Bugzilla product bug; why don't read the big bold letter descriptions before filing a bug?

2/ No need for Russian versions of bugs, thanks anyway. :)

3/ Attach the installer logs as told to by the installer.
Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2007-05-16 18:57:52 UTC
Jakub:  You have been asked before.  You do not have the right to be condescending to our users.  It is much simpler to just explain to the user their mistake without being insulting or talking down to them.  If you are unable to do this, then I ask you to stay away from any bugs that deal with releases, which is the first interface our users have with Gentoo.  Your attitude should not reflect on the entire Gentoo staff.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-05-16 19:08:19 UTC
I guess you really want to see me retired. So... as you wish.
Comment 4 Chris Gianelloni (RETIRED) gentoo-dev 2007-05-16 19:16:40 UTC
I really don't care what you do, so long as you quit being insulting to our users.
Comment 5 Ferris McCormick (RETIRED) gentoo-dev 2007-05-16 19:52:18 UTC
Ombudsman --- please comment.
Comment 6 Chris Gianelloni (RETIRED) gentoo-dev 2007-05-16 20:17:50 UTC
To the original poster, I am sending this to the Installer team.  They are likely going to need a little clarification on a few things, since it is a bit hard to understand exactly what you mean at certain points.
Comment 7 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-05-16 23:51:05 UTC
Just for the record, I've read several threads in the forums about point 2 variant A - the install freezing while installing PERL. Some people have reported that after rebooting and running the install again, it then proceeds to finish. Others haven't been so lucky. An example is https://forums.gentoo.org/viewtopic-t-558465-highlight-perl.html
I wonder if this is related to the old bug(?) that if one wishes to use a networkless install, one must say the network is configured even if it isn't or the system will freeze - https://forums.gentoo.org/viewtopic-p-3490243.html#3490243
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2007-05-17 01:46:24 UTC
No, the perl thing is something specific to that media.  We really are not positive why it is doing it just yet.  It definitely isn't the old installer hang, since the installer has been pretty much rewritten and it no longer does that network configuration.  The funny thing is that the perl bug doesn't show up on the LiveDVD media for AMD64.  I have no clue why.

As for this bug, I am hoping the original poster can be more specific in what problems he had with each media set.  For example, on each of your four trials, which options did you choose?  The perl bug only shows up in networkless, so I know that one, but what about the others?  What errors did you receive, exactly?  Can you post the installation failure log?
Comment 9 Andrew Gaffney (RETIRED) gentoo-dev 2007-05-17 02:48:31 UTC
(In reply to comment #8)
> It definitely isn't the old installer
> hang, since the installer has been pretty much rewritten and it no longer does

Yes, this is definitely unrelated to that old bug.

> The funny thing is that the perl bug doesn't show
> up on the LiveDVD media for AMD64.  I have no clue why.

I believe it happens on the amd64 LiveCD because of the lack of a populated vdb.
Comment 10 Preston Cody (RETIRED) gentoo-dev 2007-05-17 03:55:32 UTC
more info from screenshots of a test networkless install from amd64 livecd
http://dev.gentoo.org/~codeman/uhoh_amd64_1.png
http://dev.gentoo.org/~codeman/uhoh_amd64_2.png

there seems to be no vdb on the livecd, and the installer just goes right through all the packages until it dies on perl
Comment 11 Lance Spaulding 2007-05-22 15:10:13 UTC
I'm also running into the hang installing perl from the x86 DVD.  Is there any workaround for this issue?  
Comment 12 Andrew Gaffney (RETIRED) gentoo-dev 2007-05-22 15:34:37 UTC
Well, I haven't been able to reproduce it yet.
Comment 13 n. doriot 2007-05-29 02:24:40 UTC
I believe that I am having the same problem as mentioned in Item 2 (A variant).  I have tried an installation of Gentoo 2007.0 amd64 LiveCD and the installation hangs while unpacking item 50/116 (perl).  I have performed the installation via the GTK+ installer using the "Advanced" option and also via the command line installer using the "Networkless" option.  Both attempts have resulted in the installation hanging on the perl item.  I also received the following text printed on the screen using the command line installer.

/mnt/gentoo/etc/passwd: No such file or directory
sh: /mnt/gentoo/etc/group: No such file or directory
sh: /mnt/gentoo/etc/shadow: No such file or directory

It might be that I have burned a bad CD, but seems quite a coincidence to have the same problem due to a burned CD... I suppose it is possible.  The md5sum did check out as OK on my download of the LiveCD.
Comment 14 Frank Cringle 2007-05-31 11:00:52 UTC
The livedvd-i686-installer-2007.0 also hangs for me when copying dev-lang/perl.

While it is hanging I poked around in another terminal.  I don't see where the
tarball is being copied to.  Here is a screen log...

livcd ~ # df
Filesystem           1K-blocks      Used Available Use% Mounted on
tmpfs                   517172     49312    467860  10% /
/dev/hdd               3924620   3924620         0 100% /mnt/cdrom
/dev/loop0             1352704   1352704         0 100% /mnt/livecd
udev                    517172       732    516440   1% /dev
tmpfs                   517172      2132    515040   1% /mnt/livecd/lib/firmware
tmpfs                   517172         0    517172   0% /mnt/livecd/usr/portage
/dev/hda3            113259912    192704 107313932   1% /mnt/gentoo
/dev/hda1               101086      1550     94317   2%
/mnt/gentoo/boot
livecd ~ # ls -lR /mnt/gentoo
/mnt/gentoo:
total 25
drwxr-xr-x 3 root root  1024 May 31 10:12 boot
drwx------ 2 root root 16384 May 31 10:13 lost+found
drwxrwxrwt 2 root root  4096 May 31 10:15 tmp
drwxr-xr-x 4 root root  4096 May 31 10:15 var

/mnt/gentoo/boot:
total 12
drwx------ 2 root root 12288 May 31 10:12 lost+found

/mnt/gentoo/boot/lost+found:
total 0

/mnt/gentoo/lost+found:
total 0

/mnt/gentoo/tmp:
total 4
-rw-r--r-- 1 root root 662 May 31 10:15 extrastuff.sh

/mnt/gentoo/var:
total 8
drwxr-xr-x 3 root root 4096 May 31 10:15 lib
drwxrwxrwt 2 root root 4096 May 31 10:15 tmp

/mnt/gentoo/var/lib:
total 4
drwxr-x--- 2 root root 4096 May 31 10:15 portage

/mnt/gentoo/var/lib/portage:
total 0

/mnt/gentoo/var/tmp:
total 4
-rwxr-xr-x 1 root root 69 May 31 10:15 spawn.sh
livecd ~ # cat /var/log/installer.log 
GLI: May 31 2007 10:11:36 - Gentoo Linux Installer version 0.5.4
GLI: May 31 2007 10:12:11 - Gentoo Linux Installer version 0.5.4
GLI: May 31 2007 10:15:15 - Mounted mountpoint: /
GLI: May 31 2007 10:15:16 - Created mountpoint /boot
GLI: May 31 2007 10:15:16 - Mounted mountpoint: /boot
GLI: May 31 2007 10:15:17 - Stage3 was generated successfully
livecd ~ # cat /tmp/compile_output.log 
chroot: cannot run command `/var/tmp/spawn.sh': No such file or directory
Comment 15 faceman 2007-06-21 16:02:38 UTC
I've got the perl hang on the livecd with standard, advanced and networkless installs from both the gui and the command line installer.
Comment 16 heman 2007-06-28 12:38:13 UTC
the bug #178150 seems to be a duplicate of this one.


I can confirm I have the same problems. hangs at perl 50/xxx
using installer-dialog and the gtk installer, whether I do 
networkless or not.

I also see the same errors about /mnt/gentoo/etc/passwd etc.

For me it was the amd64 LiveCD which did it.

Is this going to be another one of those cases where you continue to offer a stuffed CD for download for 6 months or more?

If the problem really is due to the VDB (wikipedia tells me this is /var/db/pkg) being missing, then you should remove the liveCD download! Please at least put a warning on the page to save people wasting their bandwidth and time.

It also seems to me that perhaps the baselayout package is stuffed because if I remember correctly I had no /mnt/gentoo/etc directory at the time of the failure (although I did have lib and lib64 unlike the guy below who had the problem with the livedvd).

please someone change this to critical. If no-one being able to install the thing is not critical then I don't know what is.

At least for the next few days I am available to try stuff on my box to try 
to track down the problem.

Please email me at csreg at netspace dot net dot au if you wish me to try something.
Comment 17 Chris Gianelloni (RETIRED) gentoo-dev 2007-07-03 18:58:01 UTC
*** Bug 178150 has been marked as a duplicate of this bug. ***
Comment 18 Andrew Gaffney (RETIRED) gentoo-dev 2007-07-05 03:22:29 UTC
*** Bug 184239 has been marked as a duplicate of this bug. ***
Comment 19 Brandon Mintern 2007-09-29 05:14:45 UTC
I would just like to add my own experiences. I have tried this on an AMD64 laptop (Turion X2) with similar problems, during a networkless attempt. First issue was hanging right after perl, at gettext (I think so, anyways... number 51). A few attempts later, it hung at Perl. After a reboot and trying again, it went up to and through Perl and then suddenly said "Done!" without installing anything else, but the installation dialog remained open, and my only choice was to Cancel, exiting the installer.  If it adds anything to the discussion, I am installing / on /dev/sdb3 (/boot on sdb1 and swap on sdb2), as sda is currently formatted with an NTFS system. I, too, think this should be a critical bug, if we expect to get new Gentoo users.
Comment 20 Andrew Gaffney (RETIRED) gentoo-dev 2007-11-16 21:36:02 UTC
This one is due to a problem with catalyst which caused some of the CD/DVDs from 2007.0 to not have a VDB. This has been fixed and won't be a problem with 2007.1. Anyway, not an installer bug.
Comment 21 Andrew Gaffney (RETIRED) gentoo-dev 2007-11-16 21:45:03 UTC
Meh, didn't realize release was on this one, too. This will be closed once 2007.1 is out.
Comment 22 Andrew Gaffney (RETIRED) gentoo-dev 2008-03-14 20:17:53 UTC
*** Bug 213400 has been marked as a duplicate of this bug. ***
Comment 23 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-13 01:05:36 UTC
This should be fixed in 2008.0