Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 159176 - media-video/{gspca,spca5xx,gspcav1} removal request
Summary: media-video/{gspca,spca5xx,gspcav1} removal request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mike Doty (RETIRED)
URL:
Whiteboard:
Keywords:
: 159177 160045 163144 165411 166814 167782 167922 170074 170076 176807 206049 209313 210406 (view as bug list)
Depends on:
Blocks: kernel-2.6.19
  Show dependency tree
 
Reported: 2006-12-26 17:19 UTC by David Carlos Manuelda
Modified: 2009-10-25 13:57 UTC (History)
23 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch that makes the suggested change (new-kernel-fix.diff,534 bytes, patch)
2006-12-31 06:33 UTC, Kiyoshi Aman
Details | Diff
patch that makes the suggested change (new-kernel-fix.diff,492 bytes, patch)
2006-12-31 06:56 UTC, Kiyoshi Aman
Details | Diff
Error file (spca5xx-2.6.19-r2.patch-31101.out,2.98 KB, text/plain)
2006-12-31 09:39 UTC, Ewan Gunn
Details
ebuild for patch (spca5xx-20060501-r3.ebuild,1.06 KB, application/octet-stream)
2007-01-02 13:24 UTC, Ewan Gunn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Carlos Manuelda 2006-12-26 17:19:11 UTC
This is what I get:

>>> Emerging (1 of 1) media-video/spca5xx-20060501-r2 to /
 * spca5xx-20060501.tar.gz MD5 ;-) ...                                                              [ ok ]
 * spca5xx-20060501.tar.gz RMD160 ;-) ...                                                           [ ok ]
 * spca5xx-20060501.tar.gz SHA1 ;-) ...                                                             [ ok ]
 * spca5xx-20060501.tar.gz SHA256 ;-) ...                                                           [ ok ]
 * spca5xx-20060501.tar.gz size ;-) ...                                                             [ ok ]
 * checking ebuild checksums ;-) ...                                                                [ ok ]
 * checking auxfile checksums ;-) ...                                                               [ ok ]
 * checking miscfile checksums ;-) ...                                                              [ ok ]
 * checking spca5xx-20060501.tar.gz ;-) ...                                                         [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.19-gentoo-r2/build
 * Found sources for kernel version:
 *     2.6.19-gentoo-r2
 * Checking for suitable kernel configuration options...                                            [ ok ]
>>> Unpacking source...
>>> Unpacking spca5xx-20060501.tar.gz to /var/tmp/portage/spca5xx-20060501-r2/work
tar: spca5xx-20060501/drivers: implausibly old time stamp 1970-01-01 01:00:00
 * Converting spca5xx-20060501/Makefile to use M= instead of SUBDIRS= ...                           [ ok ]
 * Applying spca-20060501-defines.patch ...                                                         [ ok ]
 * Applying spca-20060501-2.6.18.patch ...                                                          [ ok ]
 * Applying spca-20060501-LogitechQC92f.patch ...                                                   [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501 ...
 * Preparing spca5xx module
   Building SPCA5XX driver for 2.5/2.6 kernel.
   Remember: you must have read/write access to your kernel source tree.
make -C /usr/src/linux M=/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501 CC=x86_64-pc-linux-gnu-gcc modules
make[1]: Entering directory `/usr/src/linux-2.6.19-gentoo-r2'
  CC [M]  /var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.o
  CC [M]  /var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spcadecoder.o
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.c:39:26: error: linux/config.h: No such file or directory
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.c: In function 'spca50x_init_isoc':
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.c:1624: warning: assignment from incompatible pointer type
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.c: In function 'spca50x_create_sysfs':
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.c:3451: warning: ignoring return value of 'video_device_create_file', declared with attribute warn_unused_result
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.c:3452: warning: ignoring return value of 'video_device_create_file', declared with attribute warn_unused_result
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.c:3453: warning: ignoring return value of 'video_device_create_file', declared with attribute warn_unused_result
make[2]: *** [/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spca5xx.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spcadecoder.c: In function 'fun_D':
/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501/drivers/usb/spcadecoder.c:809: warning: value computed is not used
make[1]: *** [_module_/var/tmp/portage/spca5xx-20060501-r2/work/spca5xx-20060501] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.19-gentoo-r2'
make: *** [default] Error 2

!!! ERROR: media-video/spca5xx-20060501-r2 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  ebuild.sh, line 1255:   Called linux-mod_src_compile
  linux-mod.eclass, line 510:   Called die

!!! Unable to make  KERNELDIR=/usr/src/linux default.
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 1 David Carlos Manuelda 2006-12-26 17:29:16 UTC
*** Bug 159177 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Drake (RETIRED) gentoo-dev 2006-12-30 18:04:37 UTC
you need to patch the affected lines in this way:

#include <linux/version.h>
#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,18)
#include <linux/config.h>
#endif
Comment 3 David Carlos Manuelda 2006-12-30 21:13:18 UTC
Sorry, but I don't know how to patch files... if you could give something more I'll be pleased :=) (like an ebuild, ... )
Comment 4 Kiyoshi Aman 2006-12-31 06:33:38 UTC
Created attachment 105036 [details, diff]
patch that makes the suggested change

I don't know if this will work or not, but it's worth a try.
Comment 5 Kiyoshi Aman 2006-12-31 06:56:44 UTC
Created attachment 105041 [details, diff]
patch that makes the suggested change

Oops. Apparently epatch doesn't know how to deal with leading paths. Stupid thing.
Comment 6 Ewan Gunn 2006-12-31 09:39:00 UTC
Created attachment 105055 [details]
Error file

Tried the above patch, it didn't work. The attachment is the result.
Comment 7 Ewan Gunn 2007-01-02 13:24:01 UTC
Created attachment 105235 [details]
ebuild for patch

This ebuild applies the patch listed above.
Comment 8 Ewan Gunn 2007-01-02 13:25:11 UTC
(In reply to comment #6)
> Created an attachment (id=105055) [edit]
> Error file
> 
> Tried the above patch, it didn't work. The attachment is the result.
> 

Ignore this, it works fine
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2007-01-04 10:53:08 UTC
*** Bug 160045 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Drake (RETIRED) gentoo-dev 2007-01-07 16:31:47 UTC
Maintainers, this is your 1 week advance warning for 2.6.19 going stable.
Comment 11 David Carlos Manuelda 2007-01-08 00:35:26 UTC
Is there the needed patch in the tree? I can't still emerge spca5xx properly (same error). Maybe putting a -r3 ?
Comment 12 Natanael Copa 2007-01-08 20:52:35 UTC
i can confirm the patch works. I'm using it right now.

Linux nc 2.6.19-gentoo-r2 #1 SMP PREEMPT Sun Dec 17 00:24:24 CET 2006 x86_64 Intel(R) Pentium(R) D CPU 3.00GHz GenuineIntel GNU/Linux

Would be nice if it could get committed

Thanks!
Comment 13 Robert Marmorstein 2007-01-15 00:18:47 UTC
I can second that.  The patch works great on both amd64 and i686!
Comment 14 Mike Doty (RETIRED) gentoo-dev 2007-01-20 06:59:38 UTC
you should move to media-video/gspcav1.  spca5xx is no longer developed upstream.
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-02-05 08:42:13 UTC
*** Bug 165411 has been marked as a duplicate of this bug. ***
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2007-02-14 12:50:28 UTC
*** Bug 166814 has been marked as a duplicate of this bug. ***
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2007-02-20 20:01:30 UTC
*** Bug 167782 has been marked as a duplicate of this bug. ***
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2007-02-21 09:16:14 UTC
Please, package.mask and remove this. Getting tired of the duplicates, people should get a message to switch to media-video/gspca.
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2007-02-21 20:39:45 UTC
*** Bug 167922 has been marked as a duplicate of this bug. ***
Comment 20 Mike Doty (RETIRED) gentoo-dev 2007-02-22 02:11:22 UTC
(In reply to comment #18)
> Please, package.mask and remove this. Getting tired of the duplicates, people
> should get a message to switch to media-video/gspca.
> 

gspca will go stable on all arches when I return from europe in march.  then I can p.mask spca5xx.
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2007-03-10 18:40:02 UTC
*** Bug 163144 has been marked as a duplicate of this bug. ***
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2007-03-10 18:40:41 UTC
*** Bug 170074 has been marked as a duplicate of this bug. ***
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2007-03-10 18:41:04 UTC
*** Bug 170076 has been marked as a duplicate of this bug. ***
Comment 24 Pacho Ramos gentoo-dev 2007-03-11 17:38:53 UTC
media-video/gspca-01.00.10 and media-video/spca5xx are deprecated in favor to media-video/gspcav1-20070110 that is currently supported by upstream and works fine with recent kernels.

Thanks a lot :-)
Comment 25 Alexander Skwar 2007-03-17 23:21:44 UTC
(In reply to comment #18)
> Please, package.mask and remove this. Getting tired of the duplicates, people
> should get a message to switch to media-video/gspca.

Why should gspca be used? It's, in comparison with gspcav1, older. I was under the impression that we got this straing in bug #159125 and bug #159126, ie. gspca should not be used and gspcav1 should be used instead. Mike also said that gspcav1 shouldn't have been masked.

(In reply to comment #20)
> (In reply to comment #18)
> > Please, package.mask and remove this. Getting tired of the duplicates, people
> > should get a message to switch to media-video/gspca.
> > 
> 
> gspca will go stable on all arches when I return from europe in march.  then I
> can p.mask spca5xx.

Will you really declare gspca stable (ie. NOT the upstream name of gspcav1)?

And when will you return?

Anyway - it would be nice if gspca could be hard masked and gspcav1 unmasked until then, to have a working package. Thanks!

Comment 26 Pacho Ramos gentoo-dev 2007-03-19 10:19:22 UTC
> 
> (In reply to comment #20)
> > (In reply to comment #18)
> > > Please, package.mask and remove this. Getting tired of the duplicates, people
> > > should get a message to switch to media-video/gspca.
> > > 
> > 
> > gspca will go stable on all arches when I return from europe in march.  then I
> > can p.mask spca5xx.
> 
> Will you really declare gspca stable (ie. NOT the upstream name of gspcav1)?
> 
> And when will you return?
> 
> Anyway - it would be nice if gspca could be hard masked and gspcav1 unmasked
> until then, to have a working package. Thanks!
> 

Please, be patient, kingtaco is too busy now

Thanks a lot :-)
Comment 27 Mike Doty (RETIRED) gentoo-dev 2007-03-24 18:05:30 UTC
sorry for the delay, this is finally done.
Comment 28 Pacho Ramos gentoo-dev 2007-03-24 18:25:22 UTC
Thanks :-)
Comment 29 Jakub Moc (RETIRED) gentoo-dev 2007-05-02 13:49:28 UTC
*** Bug 176807 has been marked as a duplicate of this bug. ***
Comment 30 Chen Xing 2007-05-04 15:49:05 UTC
It seems that according to the summary, gspcav1 should be unmasked. But when I am emerging, it says:

# emerge gspcav1
Calculating dependencies \
!!! All ebuilds that could satisfy "gspcav1" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-video/gspcav1-20070110 (masked by: ~x86 keyword)
- media-video/gspcav1-20060925 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or 
refer to the Gentoo Handbook.

----------------------
The newest version of gspcav1 seems to be 20070426
Comment 31 Jakub Moc (RETIRED) gentoo-dev 2007-05-04 15:50:36 UTC
(In reply to comment #30)
> It seems that according to the summary, gspcav1 should be unmasked.

unmasked != stable...

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3&chap=3
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2008-01-16 06:05:06 UTC
*** Bug 206049 has been marked as a duplicate of this bug. ***
Comment 33 Jakub Moc (RETIRED) gentoo-dev 2008-02-08 07:37:52 UTC
*** Bug 209313 has been marked as a duplicate of this bug. ***
Comment 34 Jakub Moc (RETIRED) gentoo-dev 2008-02-16 21:24:28 UTC
*** Bug 210406 has been marked as a duplicate of this bug. ***
Comment 35 Jakub Moc (RETIRED) gentoo-dev 2008-02-16 21:25:31 UTC
Please remove the thing so that people stop filing bugs about it.
Comment 36 Pacho Ramos gentoo-dev 2008-02-16 22:08:58 UTC
You can drop it, it's completely useless

Thanks
Comment 37 Carlos Eduardo Santos 2008-03-14 23:50:41 UTC
Cannot compile it.

 * Preparing gspca module
make -C /usr/src/linux M=/var/tmp/portage/media-video/gspcav1-20070508/work/gspcav1-20070508 CC=i686-pc-linux-gnu-gcc modules
make[1]: Entering directory `/usr/src/linux-2.6.24-gentoo-r3'
scripts/Makefile.build:46: *** CFLAGS was changed in "/var/tmp/portage/media-video/gspcav1-20070508/work/gspcav1-20070508/Makefile". Fix it to use EXTRA_CFLAGS.  Stop.
make[1]: *** [_module_/var/tmp/portage/media-video/gspcav1-20070508/work/gspcav1-20070508] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.24-gentoo-r3'
make: *** [default] Error 2
 *
 * ERROR: media-video/gspcav1-20070508 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3147:  Called linux-mod_src_compile
 *             environment, line 2420:  Called die
 * The specific snippet of code:
 *               emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} || die "Unable to make ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}.";
 *  The die message:
 *   Unable to make  KERNELDIR=/usr/src/linux default.

Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r3 i686)
=================================================================
System uname: 2.6.24-gentoo-r3 i686 AMD Athlon(tm) XP 2600+
Timestamp of tree: Fri, 14 Mar 2008 20:30:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.3.5-r3, 2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
DISTDIR="/mnt/sata/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo http://mirror.datapipe.net/gentoo http://gentoo.mirrors.pair.com/"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/mnt/sata/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X acpi alsa apache2 bash-completion berkdb branding bzip2 bzlib cairo cddb cdr cli cracklib crypt cups dbus divx4linux djvu dri dvd dvdr dvdread emboss esd evo fam firefox flac foomaticdb fortran gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2 hal iconv innodb isdnlog javascript jpeg jpeg2k kdeenablefinal kdexdeltas keyring lcms logrotate mad matroska midi mmx mmx2 mmxext mng mp3 mpeg msn mudflap ncurses network-cron nls nptl nptlonly nsplugin offensive ogg opengl openmp oscar pam pcre pdf perl php png pppd python qt3support qt4 quicktime readline reflection rtc ruby samba sasl sdl session spl sse ssl svg tcpd threads truetype unicode v4l v4l2 vhosts vim-syntax vorbis win32codecs x86 xinetd xml xorg xosd xprint xv xvid xvmc yv12 zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 38 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2008-05-21 18:28:53 UTC
=media-video/gspcav1-20071224 works fine on 2.6.25-gentoo-r4 on x86.
Comment 39 Renato Caldas 2008-10-18 14:12:56 UTC
The gspcav1 module will soon be deprecated in favor of the in-kernel driver (in kernel 2.6.27). Just so that you know.
Comment 40 Pacho Ramos gentoo-dev 2008-10-26 13:53:48 UTC
Mike, please, drop spca5xx and gspca as gspcav1 replaces them 

Thanks :-)
Comment 41 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2008-11-30 14:33:31 UTC
(In reply to comment #39)
> The gspcav1 module will soon be deprecated in favor of the in-kernel driver (in
> kernel 2.6.27). Just so that you know.
> 

I don't think that'll happen really soon. 2.6.27's gspca doesn't work with my webcam, where last gspcav1 did.
Comment 42 Renato Caldas 2008-11-30 14:39:43 UTC
(In reply to comment #41)
> I don't think that'll happen really soon. 2.6.27's gspca doesn't work with my
> webcam, where last gspcav1 did.

It should work. The problem is that most apps don't yet support it. Google around for libv4l.
Comment 43 Pacho Ramos gentoo-dev 2009-02-05 10:47:56 UTC
Please drop gspca and spca5xx

Thanks
Comment 44 Pacho Ramos gentoo-dev 2009-05-12 20:58:57 UTC
I think that would be even better mask also gspcav1 and try to drop all *spca* drivers soon as current gspcav2 kernel driver should replace all of them. Should I open a new bug report for it?
Comment 45 Pacho Ramos gentoo-dev 2009-09-14 08:21:13 UTC
Any news on this? Thanks :-)
Comment 46 Pacho Ramos gentoo-dev 2009-09-28 15:14:58 UTC
Treecleaners, can you please take a look on this? In summary, all these drivers should be dropped, as kernel already supports that cameras:
media-video/gspca
media-video/gspcav1
media-video/spca5xx

Thanks
Comment 47 Samuli Suominen gentoo-dev 2009-09-28 18:56:56 UTC
# Samuli Suominen <ssuominen@gentoo.org> (28 Sep 2009)
# Obsolete. Supported by in-kernel drivers. Masked for removal,
# see bug 159176.
media-video/gspca
media-video/spca5xx
media-video/gspcav1
Comment 48 Pacho Ramos gentoo-dev 2009-09-28 18:58:21 UTC
Thanks a lot
Comment 49 Samuli Suominen gentoo-dev 2009-10-25 13:57:52 UTC
(In reply to comment #48)
> Thanks a lot
> 

Np

Also removed from tree now.