Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 153113 - >=gnome-system-tools 2.20.0 bump request
Summary: >=gnome-system-tools 2.20.0 bump request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 196373 211636 (view as bug list)
Depends on:
Blocks: 214265
  Show dependency tree
 
Reported: 2006-10-27 21:48 UTC by Luis Medinas (RETIRED)
Modified: 2008-04-12 15:10 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Medinas (RETIRED) gentoo-dev 2006-10-27 21:48:27 UTC
seems like other distros have pick this to gnome 2.16 release we should do it too.
Comment 1 Alex 2006-10-28 21:43:53 UTC
Requires system-tools-backends-2.9.90 or anything in 2.9.X, which requires dev-perl/Net-DBus which is amd64 keyworded only.
Comment 2 Luis Medinas (RETIRED) gentoo-dev 2006-11-04 20:13:03 UTC
there's no problem with Net-DBUS since the s-t-b packages already provides the bindings. The problem is with liboobs that requires dbus-glib 0.7 at least.
Comment 3 brad walker 2007-01-04 08:07:51 UTC
i have g-s-t-2.15.6 running with liboobs-0.6.1 and s-t-b-2.0.0. it also runs with liboobs-{0.5.0,2.17.2} (2.17.3 doesn't build).

system-tools-backends-2.0.0 is a pain. none of g-s-t's frontends would run until /usr/share/system-tools-backends-2.0/scripts/SystemToolsBackends.pl ran as root. running it non-root allows the frontends to run but they are unable to modify system configurations. 

this solution came from the following thread (not sure why thread title includes non-existant s-t-b-2.17): http://mail.gnome.org/archives/system-tools-list/2006-November/msg00000.html

the thread mentions running scripts in /etc/dbus-1/event.d, but would this not require modifying /etc/init.d/dbus? would it be easier and better to create an /etc/init.d/system-tools-backends? should we endure this pain and do this configuration (the versions I tested) or wait until 2.18 and a new stable >s-t-b-2.1?

another thing, should future system-tools-backends (>=1.9) create a new group 'stb-admin' or use wheel by configuring with '--with-stb-group-wheel'? s-t-b-1.4.2's ebuild recently added adding group 'stb-admin'. using wheel is less work for new users but makes migrating 2.14->2.15 harder.
Comment 5 Gilles Dartiguelongue gentoo-dev 2007-02-11 20:53:39 UTC
for anybody that feels advanturous enough, you could try g-s-t-2.17 that is in gnome-experimental, I've commited every pieces this week. I'd be happy to push any stuff that helps make this work on gentoo to the overlay and eventually upstream.

Actually the following works out of the box:
Comment 6 Gilles Dartiguelongue gentoo-dev 2007-02-11 20:55:04 UTC
(damn enter)

works: 
 - users-admin

half-working:
 - network
 - time

empty list:
 - services
 - shares
Comment 7 Pacho Ramos gentoo-dev 2007-04-09 18:06:25 UTC
gnome-system-tools-2.18.0 has been released :-D

http://ftp.gnome.org/pub/GNOME/sources/gnome-system-tools/2.18/

Thanks a lot
Comment 8 Rémi Cardona gentoo-dev 2007-04-09 18:36:41 UTC
Pacho, we know about new releases, no need to remind us :)

We won't be adding g-s-t to portage any time soon, because most of the tools don't work correctly in Gentoo and may actually do more harm (see bug 131097, all gst bugs are like this) than good.

If you really want to see them hit portage, please test them as much as you can, patches are of course more than welcome. If you want to help out, it's a great opportunity.

Thanks for your time.
Comment 9 Pacho Ramos gentoo-dev 2007-04-10 10:24:20 UTC
OK, thanks for information, but I will wait until gnome 2.18 goes to stable (there are many users on my machines that use gnome and need a "secure" version)
Comment 10 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-04-16 18:22:55 UTC
For the record, we really need someone to take ownership of the gentoo portions of g-s-t (and s-t-b) and work with upstream to make them work well with gentoo.  So far, no one has volunteered.
Comment 11 Gilles Dartiguelongue gentoo-dev 2007-07-07 13:28:05 UTC
I've recently talked with one of the sabayon linux's dev and with garnacho (dev of  g-s-t) and we're still at the same point. I'll meet garnacho at GUADEC and hopefully we'll be able to fix this mess.
Comment 12 Xake 2007-07-28 14:29:28 UTC
Is the real problem in gnome-system-tools or system-tools-backends? Or is it both?
Comment 13 Rémi Cardona gentoo-dev 2007-07-28 15:36:57 UTC
now the problem is in the backends. They either _break_ your system, or just plain don't work at all :)

This is definitely a Gnome Love type of bug. If someone wants to contribute, please by all means do!
Comment 14 Xake 2007-07-28 15:59:08 UTC
Does it require experience with perl and some programming skills or is it "just" a contact upstream and help them test and sort things out thing? 
Comment 15 Rémi Cardona gentoo-dev 2007-07-28 18:11:18 UTC
Basically, this work will have to be done in 3 parts :
- really test things out, tool by tool, try as many features as possible
- report breakage here (upstream only really cares about the UI)
- write patches that will be sent upstream for inclusion

I honestly believe that a good chunck of the tools-backend can be fixed quite easily (even though they're written in perl), comparing the Fedora/Ubuntu backends with our own should be a good source of information.

Imho, one tool really worth fixing is the User Management tool, which can act quite awkwardly. For Gentoo, this tool should never try to modify any files other than /etc/{passwd,shadow,group}. Right now, I think it modifies a few more files which break our PAM setup.
Comment 16 Xake 2007-07-28 19:42:06 UTC
Well. I tried with system-tools-backends-2.3.0, gnome-system-tools-2.19.0, liboobs-2.19.0 and Net-DBus-0.33.5. The tools I have been testing so far (time-admin, shares-admin, users-admin, services-admin) reads my settings just fine, but does not seems to be able to write anything (yes.i am a stb-admin)... And I can't make it drop any errormessages as far as I can see.
The ebuilds are taken or bumps of those in gnome-experimental and Net-DBus from portage.
Comment 17 Gilles Dartiguelongue gentoo-dev 2007-07-28 19:58:11 UTC
remi, you are out of date :)

users-admin work well with s-t-b-2.*, my comment #6 is still valid. The thing is that s-t-b needs to be run as root to actually do something. being in stb-admin only gives you the right to read the config.
Comment 18 Xake 2007-07-28 20:42:30 UTC
So how do I run the thing as root?
sudo *-admin does not make any diffrence for me....
Comment 19 Gilles Dartiguelongue gentoo-dev 2007-07-28 21:37:51 UTC
s-t-b running as root means that you need to kill all instances started by dbus and do :

# system-tools-backends

You need to kill other instances or you won't get the good one for communication over dbus.
Comment 20 Xake 2007-07-29 00:59:46 UTC
Ok, running system-tools-backends as root gave me the following experiences:
time-admin & shares-admin seems to handle ntp & SMB alright.
users-admin & network-admin still seems incapable of changeing anything (tried to add user and bork up my eth0&wlan0-configs)
services-admin rebooted my computer when I tried to enable samba...
This is with s-t-b-2.3 & g-s-t-2.19.0 so it could be that it is dev-versions.
Comment 21 Gilles Dartiguelongue gentoo-dev 2007-10-19 09:17:11 UTC
*** Bug 196373 has been marked as a duplicate of this bug. ***
Comment 22 Mart Raudsepp gentoo-dev 2007-10-19 17:08:11 UTC
There is some notion that gnome-system-tools 2.20.x and co might actually not kill babies on Gentoo. system-tools-backends will need a patch though that makes "rc-status -nc" calls be "rc-status --no-color" instead to not freeze stuff with baselayout-2
Comment 23 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-10-22 15:44:57 UTC
I have a small patch for s-t-b that allows it to show current status on init scripts.  I still can't enable/disable init stuff properly, but it's a step in the right direction.

In my limited testing, g-s-t and s-t-b, even in gnome 2.20, does not work well enough on Gentoo to put into portage.
Comment 24 Gilles Dartiguelongue gentoo-dev 2007-12-13 23:47:58 UTC
little status update, even with the patch to handle baselayout-1/2 service handling is still not right in 2.20. waiting on bheekling input (on #-desktop).
Comment 25 Conrad Kostecki gentoo-dev 2008-01-20 12:35:18 UTC
Any news?
Comment 26 Rémi Cardona gentoo-dev 2008-01-20 13:03:50 UTC
2.21 is in the overlay, and there are encouraging signs :) I haven't tried it myself, but I've heard of some working tools.

Once 2.22 is in portage (around March), we will probably put g-s-t with a big fat package.mask so that you can all try it and hopefully report bugs (here or upstream).

Thanks
Comment 27 Gilles Dartiguelongue gentoo-dev 2008-01-24 23:01:24 UTC
ok, besides the fact that network is pretty much useless and services work be isn't perfect yet, I've added gnome-system-tools 2.20 to the tree but pmasked for testing. Please take time to read installation instructions and report here success or failures.
Comment 28 Pacho Ramos gentoo-dev 2008-02-18 11:05:09 UTC
users-admin doesn't work for me. I cannot add users with it, it seems to do it properly but, after closing users-admin, nothing is added to /etc/passwd or /etc/group
Comment 29 Nirbheek Chauhan (RETIRED) gentoo-dev 2008-02-18 15:20:34 UTC
(In reply to comment #28)
> users-admin doesn't work for me. I cannot add users with it, it seems to do it
> properly but, after closing users-admin, nothing is added to /etc/passwd or
> /etc/group
> 

I can confirm this. An strace on users-admin revealed only a read-only access to /etc/passwd:

open("/etc/passwd", O_RDONLY|0x80000 /* O_??? */) = 3


Comment 30 Gilles Dartiguelongue gentoo-dev 2008-02-27 13:45:21 UTC
*** Bug 211636 has been marked as a duplicate of this bug. ***
Comment 31 Pacho Ramos gentoo-dev 2008-04-05 10:12:53 UTC
Maybe would be cleaner close this and others "version bump" related bugs and open a new one for users-admin issue (I cannot still test with system-tools-backends-2.6, if anybody else is able please report if it is fixed)

I can do it myself if you prefer

Thanks
Comment 32 Gilles Dartiguelongue gentoo-dev 2008-04-12 15:10:36 UTC
closing because it is in tree. We are going to handle broken tools on the tracker.