Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 131097 - app-admin/system-tools-backends-1.4.2-r1 - users-admin adds PASS_MIN_LEN to /etc/login.defs
Summary: app-admin/system-tools-backends-1.4.2-r1 - users-admin adds PASS_MIN_LEN to /...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 136844 142535 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-24 07:17 UTC by Pacho Ramos
Modified: 2007-02-21 21:59 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
modified ebuild that prevents the PASS_MIN_LEN property from being written (system-tools-backends-1.4.2-r1.ebuild,903 bytes, text/plain)
2006-10-08 03:19 UTC, Ben Tucker
Details
system-tools-backends-1.4.2-r2.ebuild (system-tools-backends-1.4.2-r2.ebuild,938 bytes, text/plain)
2007-02-14 10:56 UTC, Pacho Ramos
Details
pass_min.patch (pass_min.patch,1.27 KB, patch)
2007-02-14 10:56 UTC, Pacho Ramos
Details | Diff
ebuilds.diff (ebuilds.diff,349 bytes, patch)
2007-02-21 10:39 UTC, Pacho Ramos
Details | Diff
differences in login.defs after running GST (login.defs.diff,1.04 KB, text/plain)
2007-02-21 19:20 UTC, Rémi Cardona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2006-04-24 07:17:11 UTC
Problem described in this link:
http://forums.gentoo.org/viewtopic-t-366499-highlight-.html

is provoked by gnome-system-tools 1.4.1

After create a user using users-admin (provided by gnome-system-tools) the following line is always added in /etc/login.devfs: PASS_MIN_LEN 5 

Thanks a lot for try to fix it :)

_______-

Portage 2.0.54 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.3.5-r3, 2.6.16-suspend2-r4 i686)
=================================================================
System uname: 2.6.16-suspend2-r4 i686 Genuine Intel(R) CPU           T2300  @ 1.66GHz
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer -march=pentium-m"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ "
LANG="es_ES"
LC_ALL="es_ES"
LINGUAS="es"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi aim alsa apache2 apm arts asf audiofile avi bash-completion bcmath bidi bitmap-fonts bonobo bzip2 bzlib caps cdb cddb cdparanoia cdr cdrparanoia cli cpdflib cross crypt cscope css ctype cups curl curlwrappers db2 dbus dga dio directfb divx4linux dri dts dv dvb dvd dvdr dvdread eds emboss encode escreen esd evo exif expat fam fbcon ffmpeg fftw flac foomaticdb fortran ftp gb gcj gd ggi gif gimp gimpprint glut glx gmp gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile hal iconv idn imagemagick imlib ipv6 isdnlog jabber jack java jbig jikes jpeg junit kde latex lcms ldap lesstif libg++ libwww lirc logrotate lua mad mbox mikmod mime ming mmap mmx mng mono motif mozilla mp3 mpeg mpi mysql nas ncurses nethack nls nocd nptl nsplugin nvidia odbc ogg oggvorbis openal opengl opnegl oss pam pcmcia pcre pdflib perl pic png pnp posix ppds pppd python qt quicktime readline real recode reflection rtc ruby scanner sdl session slp smp sndfile sockets socks5 speex spell spl sqlite sse sse2 ssl svg svga tcltk tcpd tetex tga theora tiff truetype truetype-fonts trusted type1-fonts udev unicode usb userlocales v4l v4l2 vcd videos vorbis wifi win32codecs wma wmf wxwindows x86 xine xml xml2 xmms xorg xpm xv xvid zlib linguas_es userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LDFLAGS
Comment 1 John N. Laliberte (RETIRED) gentoo-dev 2006-05-12 07:57:47 UTC
can you still reproduce this?

I cannot reproduce this with:

system-tools-backends-1.4.2 ( this is the pack that writes information to login.defs )
gnome-system-tools-1.4.1

Furthermore, the code looks like it only replaces values that already exist in the login.defs file.

If you can still reproduce the problem please let us know the following:
What version of system-tools-backends, gnome-system-tools, and shadow are you using?
Comment 2 Pacho Ramos gentoo-dev 2006-05-13 00:48:57 UTC
The problem persits :(

I am using the following:
shadow-4.0.14-r1
system-tools-backends-1.4.2
gnome-system-tools-1.4.1

I have re-emerged them but the PASS_MIN_LEN line is still been added :(

Thanks a lot for your help
Comment 3 John N. Laliberte (RETIRED) gentoo-dev 2006-05-13 05:12:11 UTC
if you completely remove the PASS_MIN_LEN from the file ( even if its commented out) does it still happen?

Also, do you pam in your use flags?

Thanks.
Comment 4 Pacho Ramos gentoo-dev 2006-05-13 07:33:20 UTC
(In reply to comment #3)
> if you completely remove the PASS_MIN_LEN from the file ( even if its commented
> out) does it still happen?
> 
> Also, do you pam in your use flags?
> 
> Thanks.
> 

Yes, I have removed this line and it still hapen.
I have "pam" in my USE flags

Thanks a lot for your help :)
Comment 5 Matthias Langer 2006-05-16 05:09:34 UTC
this also is a problem for me:

app-admin/gnome-system-tools-1.4.1  -debug -nfs -samba
app-admin/system-tools-backends-1.4.2  -debug
sys-apps/shadow-4.0.14-r1  +nls -nousuid +pam (-selinux) -skey

Portage 2.0.54-r2 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-gentoo-r7 i686)
=================================================================
System uname: 2.6.16-gentoo-r7 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5-r2, 2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig collision-protect distlocks sandbox sfperms strict test"
GENTOO_MIRRORS="http://gentoo.ynet.sk/pub "
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LINGUAS="en de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://192.168.0.1/gentoo-portage"
USE="x86 3dnow 3dnowext X a52 aac aalib acpi alsa apm audiofile avi berkdb bitmap-fonts bonobo bzip2 cairo cdr cli crypt css cups curl dbus dri dts dvd dvdr dvdread eds emboss encode exif expat fam fbcon ffmpeg firefox flac foomaticdb fortran gd gdbm gif ginac glut gmp gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile hal icq idn imagemagick imlib ipv6 isdnlog java javascript jpeg jpeg2k junit lcms libg++ libwww mad matroska mikmod mime mmx mmxext mng motif mozsvg mp3 mpeg msn nautilus ncurses nls nptl nsplugin nvidia offensive ogg oggvorbis openal opengl pam pcre pdflib perl plotutils png posix pppd python quicktime readline real reflection ruby sdl session slang sockets speex spell spl sqlite sqlite3 sse ssl subtitles svg svga tcltk tcpd tetex theora tiff truetype truetype-fonts type1-fonts udev unicode usb vcd vorbis win32codecs wma xine xml xml2 xmms xorg xv xvid zlib video_cards_nvidia linguas_en linguas_de userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTAGE_RSYNC_OPTS
Comment 6 John N. Laliberte (RETIRED) gentoo-dev 2006-06-15 10:48:08 UTC
*** Bug 136844 has been marked as a duplicate of this bug. ***
Comment 7 Alasdair Thomson 2006-07-24 15:56:52 UTC
I have also just encountered this bug. I added a new group using users-admin, and assigned membership of the new group to root and my user. It doesn't seem to affect usability, but it's still annoying.


Portage 2.1-r1 (default-linux/amd64/2005.1, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r13 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r13 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib64/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk ftp://mirrors.blueyonder.co.uk/mirrors/gentoo http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/"
LANG="eb_GB@euro"
LC_ALL="en_GB@euro"
LINGUAS="en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac acpi alsa arts avi bash-completion berkdb bitmap-fonts bonobo bzip2 cdparanoia cdr cli crypt cups dga divx4linux dlloader doc dri dts dv dvb dvd dvdr dvdread eds emboss encode ffmpeg firefox flac foomaticdb fortran gif gnome gphoto2 gpm gstreamer gtk gtk2 ieee1394 imlib ipv6 isdnlog jack jpeg kde kdeenablefinal kqemu ldap lzw lzw-tiff mad mp3 mpeg mysql mysqli ncurses nls nvidia offensive ogg opengl pam pcre pdflib perl png postgres pppd python qt qt3 qt4 quicktime readline reflection ruby samba scanner sdl session sox spell spl ssl tcpd theora threads tiff truetype-fonts type1-fonts unicode usb v4l vcd vorbis xine xinerama xml xmms xorg xpm xv xvid xvmc zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en_GB userland_GNU video_cards_nv video_cards_nvidia video_cards_vesa video_cards_fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-08-02 08:20:33 UTC
*** Bug 142535 has been marked as a duplicate of this bug. ***
Comment 9 Trey Blancher 2006-08-03 18:56:04 UTC
I'm getting the same error on amd64.  I think it started after I used users-admin to add a group.  Here's my info:

app-admin/system-tools-backends-1.4.2
app-admin/gnome-system-tools-2.14.0  << I think I may have made the group change when I had 2.12 installed, I'm not sure
sys-apps/shadow-4.0.15-r2

Portage 2.1-r1 (default-linux/amd64/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r12 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r12 x86_64 AMD Opteron(tm) Processor 242
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=k8"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.mirrors.pair.com/ http://gentoo.llarian.net/ http://mirror.phy.olemiss.edu/mirror/gentoo http://gentoo.osuosl.org/"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X aac acpi aim alsa apache2 audiofile avi bash-completion berkdb bitmap-fonts bonobo bzip2 cdparanoia cdr cli crypt cups dbus dlloader dri dvd dvdr dvdread eds emboss emul-linux-x86 encode exif expat foomaticdb fortran ftp gif gnome gphoto2 gpm gstreamer gtk gtk2 imlib ipv6 isdnlog jpeg kde libwww lm_sensors lzw lzw-tiff mad mikmod mozilla mp3 mpeg ncurses nls nptl offensive ogg opengl oscar pam pcre pdf pdflib perl png ppds pppd python qt qt3 qt4 quicktime readline reflection samba sasl sdl session smp sockets sox spell spl ssl svg symlink tcltk tcpd threads tiff truetype truetype-fonts type1-fonts usb vorbis xine xmms xorg xpm xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS

As you can see I have pam enabled in USE.
Comment 10 Ben Tucker 2006-10-08 03:19:58 UTC
Created attachment 99097 [details]
modified ebuild that prevents the PASS_MIN_LEN property from being written

Added a tiny sed hack that prevents system-tools-backends from writing the PASS_MIN_LEN property to /etc/login.defs.
Comment 11 Matthias Langer 2007-01-22 02:02:23 UTC
(In reply to comment #10)
> Created an attachment (id=99097) [edit]
> modified ebuild that prevents the PASS_MIN_LEN property from being written

seems to work for me, thanks!
Comment 12 Pacho Ramos gentoo-dev 2007-01-22 10:39:47 UTC
Please, fix this bug

Thanks
Comment 13 Pacho Ramos gentoo-dev 2007-01-27 12:51:55 UTC
Fix this bug please
Comment 14 Pacho Ramos gentoo-dev 2007-01-27 13:03:54 UTC
Umm, the attached ebuild doesn't work for 2.14.0, I will ask gnome-system-tools developers

Comment 15 Pacho Ramos gentoo-dev 2007-02-11 19:00:40 UTC
(In reply to comment #14)
> Umm, the attached ebuild doesn't work for 2.14.0, I will ask gnome-system-tools
> developers
> 

They say that:
"Please try a more recent version of g-s-t, the 2.14.x releases are obsolete, as
the development focus is on the 2.17/2.18 releases."

"using latest 2.15.x or
latest 2.17.x (which will soon be 2.18) should be ok"

http://bugzilla.gnome.org/show_bug.cgi?id=401320

Then, I think that we should "vote" for this bug:
http://bugs.gentoo.org/show_bug.cgi?id=153113
Comment 16 Waldo 2007-02-14 03:59:29 UTC
Same bug here:

$ su
Password: 
configuration error - unknown item 'PASS_MIN_LEN' (notify administrator)


No clue what it means.

W
Comment 17 Pacho Ramos gentoo-dev 2007-02-14 10:54:39 UTC
Is an app-admin/system-tools-backends-1.4.2-r1 bug
Comment 18 Pacho Ramos gentoo-dev 2007-02-14 10:56:20 UTC
Created attachment 110156 [details]
system-tools-backends-1.4.2-r2.ebuild
Comment 19 Pacho Ramos gentoo-dev 2007-02-14 10:56:44 UTC
Created attachment 110157 [details, diff]
pass_min.patch

FIXED :-D
Comment 20 Pacho Ramos gentoo-dev 2007-02-18 17:34:15 UTC
Please, fix this problem

Thanks
Comment 21 Pacho Ramos gentoo-dev 2007-02-20 11:13:20 UTC
Please, FIX this, the patch works properly and fixes this awful bug
Comment 22 Pacho Ramos gentoo-dev 2007-02-21 10:39:57 UTC
Created attachment 110815 [details, diff]
ebuilds.diff

Differences between ebuilds
Comment 23 Rémi Cardona gentoo-dev 2007-02-21 19:20:02 UTC
Created attachment 110889 [details]
differences in login.defs after running GST

I'm sorry but I cannot reproduce. Attached is a diff of the changes made by gst to login.defs on my stable box. As you can see it does _not_ touch the PASS_MIN_LEN variable which is still commented.

Any chance you could try and figure out why we have different mods done by GST?

As a side note, there's no need to insist on having a bug fixed (even if you attach the patch, which is very kind). You'll only get us annoyed and we'll likely just ignore the bug :)

Thanks for your time and patches.
Comment 24 Pacho Ramos gentoo-dev 2007-02-21 19:43:47 UTC
(In reply to comment #23)
> Created an attachment (id=110889) [edit]
> differences in login.defs after running GST
> 
> I'm sorry but I cannot reproduce. Attached is a diff of the changes made by gst
> to login.defs on my stable box. As you can see it does _not_ touch the
> PASS_MIN_LEN variable which is still commented.
> 
> Any chance you could try and figure out why we have different mods done by GST?
> 
> As a side note, there's no need to insist on having a bug fixed (even if you
> attach the patch, which is very kind). You'll only get us annoyed and we'll
> likely just ignore the bug :)
> 
> Thanks for your time and patches.
> 

Yes, the problem is the following, when I launch "users-admin" and I add a new user and click on "OK", the line "PASS_MIN_LEN 5" is added at the end of /etc/login.devfs file.

Thanks
Comment 25 Pacho Ramos gentoo-dev 2007-02-21 19:45:29 UTC
And sorry for insist on having this bug fixed, this will never occur again :-(

Sorry
Comment 26 Rémi Cardona gentoo-dev 2007-02-21 21:35:20 UTC
I did add a new user in there, otherwise user-admin leaves the file alone. I tried again, same results. I have _no_ idea why it's behaving differently.

It could very well be a side effect of something else. It would help if you could under what conditions PASS_MIN_LEN is modified/added by gst.

Thanks
Comment 27 Pacho Ramos gentoo-dev 2007-02-21 21:59:35 UTC
I have re-emerged it and seems FIXED :-O

I am really surprised, sorry for the inconvenience :-(