Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 130999 - Skype ebuild is broken
Summary: Skype ebuild is broken
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Net-im project
URL:
Whiteboard:
Keywords: QAbadiuse
: 121069 130966 (view as bug list)
Depends on:
Blocks: 100507 107400 109746 124196 138422
  Show dependency tree
 
Reported: 2006-04-23 11:08 UTC by Steve Berryman
Modified: 2006-07-02 16:07 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
skype-1.2.0.21-r2.ebuild (skype-1.2.0.21-r2.ebuild,3.70 KB, text/plain)
2006-04-25 05:11 UTC, Jakub Moc (RETIRED)
Details
skype-1.2.0.21-r2.ebuild.diff (skype-1.2.0.21-r2.ebuild.diff,2.93 KB, patch)
2006-04-25 05:14 UTC, Jakub Moc (RETIRED)
Details | Diff
patch for the skype wrapper script (sDaemonWrapper-r1.diff,459 bytes, patch)
2006-04-25 05:17 UTC, Jakub Moc (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Berryman 2006-04-23 11:08:01 UTC
skype ebuild is a heap of crap: whoever wrote the skype ebuild was clearly on crack - it doesn't depend on qt, the esd use flag doesn't do anything, and the static use flag doesn't do anything except on amd64
it also has ${PN} in HOMEPAGE and im sure USE=arts should make it depend on arts
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-04-23 11:12:18 UTC
Calm down, please... Why don't you attach a patch instead of insulting developers?
Comment 2 Steev Klimaszewski (RETIRED) gentoo-dev 2006-04-23 11:12:33 UTC
And you are going to attach an ebuild that is much better?  iirc, qt is statically built into skype, so there is no need to compile qt as well.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-04-23 11:12:52 UTC
*** Bug 130966 has been marked as a duplicate of this bug. ***
Comment 4 David Morgan 2006-04-23 11:39:43 UTC
Steev: there is a static version, but the ebuild doesn't use it

djm@sif ~ $ strace skype 2>&1 | grep qt && ps ax | grep skype
waitpid(-1, /opt/skype/skype.bin: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory

or

djm@sif ~ $ /opt/skype/skype.bin 
/opt/skype/skype.bin: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory

In both cases skype terminates unsuccessfully, but it works fine with qt installed. 
Comment 5 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-04-23 22:29:57 UTC
Please give the maintainer some time to work on the issues before requesting QA's intervention.

None of these are major issues.
Comment 6 Gustavo Felisberto (RETIRED) gentoo-dev 2006-04-25 03:22:31 UTC
skype is a piece of crack. Who did the ebuild was not on crack. This is IMHO not the way to put things. If the user had given himself the time to read the changelog we would have seent that this package is a pain to maintain because makes no use of alsa but needs oss and has LOTS of issues with sound daemons as arts and esd.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-04-25 03:54:51 UTC
*** Bug 121069 has been marked as a duplicate of this bug. ***
Comment 8 David Morgan 2006-04-25 04:28:21 UTC
humpback: no offence, but that's not really an excuse for some of the things in the ebuild:

USE=static is broken on x86 for 1.2.0.21-r1, and qt isn't being depending on anymore
USE=esd does nothing
USE=arts does nothing apart from add an extra ewarn

(the first is clearly the most serious)

Also, 1.2.0.21 isn't mentioned in the changelog at all, only 1.2.0.21-r1, and it doesn't show up in viewcvs :/
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-04-25 05:11:09 UTC
Created attachment 85449 [details]
skype-1.2.0.21-r2.ebuild

- static use flag dropped, there's no static tarball available for this version. Added ewarn to the ebuilds about this.
- added missing x11-libs/qt-3* dependency wrt the above
- dropping of static use flag fixes Bug 109746 as well, no need for virtual/libstdc++5 dependency any more
- arts and esd use flags dropped. The wrapper script takes care of sound daemons and falls back if none is available. Added einfo to the ebuild about this.
- workaround for Bug 100507 for PaX users by Kevin F. Quinn  (see Bug 100507, Comment #2)
- dropped einfo abour arts and full duplex (Bug 124196)
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-04-25 05:14:39 UTC
Created attachment 85451 [details, diff]
skype-1.2.0.21-r2.ebuild.diff

unified diff against current ebuild.

I also forgot to mention some cosmetic changes, additionally dropped LICENSE from dodoc, no need for that.
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-04-25 05:17:30 UTC
Created attachment 85452 [details, diff]
patch for the skype wrapper script

- patched wrapper script to fix Bug 107400 (also mentioned in Bug 81255)
Comment 12 Gustavo Felisberto (RETIRED) gentoo-dev 2006-04-26 15:16:29 UTC
I'm in the process of adding this to portage.

Jakub: Any ideas on how to integrate this with skype_dsp_hijacker? I can see some ways to do this for non arts users, but i have no idea how this will work form the others.
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2006-04-26 15:29:41 UTC
(In reply to comment #12)
> Jakub: Any ideas on how to integrate this with skype_dsp_hijacker? I can see
> some ways to do this for non arts users, but i have no idea how this will work
> form the others.
 
Hmmm, did you actually get the thing working on amd64? Anyway, I'd leave that one for another revbump to not over-complicate this one.
Comment 14 Zeksers 2006-06-25 10:01:47 UTC
Please replace skype-1.2.0.21-r1.ebuild with this ebuild in portage if you can because it's much better, imho.
Comment 15 Gustavo Felisberto (RETIRED) gentoo-dev 2006-07-02 16:07:45 UTC
Skype 1.3 and up now use ALSA so all these wrappers and stuff are no longer needed.